summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2009-09-18 07:20:21 +0000
committerAlistair Bush <ali_bush@gentoo.org>2009-09-18 07:20:21 +0000
commitbc8e0bd73edfb3bf263f440865135c965e0e2ccb (patch)
tree698fddb520a922323b0f21796a1814b4cdaa0009 /dev-db/octopus
parentVersion bump. (diff)
downloadgentoo-2-bc8e0bd73edfb3bf263f440865135c965e0e2ccb.tar.gz
gentoo-2-bc8e0bd73edfb3bf263f440865135c965e0e2ccb.tar.bz2
gentoo-2-bc8e0bd73edfb3bf263f440865135c965e0e2ccb.zip
Revbump and add patch to allow compulation with 1.5 vms.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/octopus')
-rw-r--r--dev-db/octopus/ChangeLog10
-rw-r--r--dev-db/octopus/files/octopus-jdk-1.5.patch220
-rw-r--r--dev-db/octopus/octopus-3.0.1-r2.ebuild84
3 files changed, 312 insertions, 2 deletions
diff --git a/dev-db/octopus/ChangeLog b/dev-db/octopus/ChangeLog
index 3d93a32c0fea..fabe0a3a5b0b 100644
--- a/dev-db/octopus/ChangeLog
+++ b/dev-db/octopus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/octopus
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/ChangeLog,v 1.13 2008/01/10 21:59:09 caster Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/ChangeLog,v 1.14 2009/09/18 07:20:21 ali_bush Exp $
+
+*octopus-3.0.1-r2 (18 Sep 2009)
+
+ 18 Sep 2009; Alistair Bush <ali_bush@gentoo.org>
+ +files/octopus-jdk-1.5.patch, +octopus-3.0.1-r2.ebuild:
+ Revbump and add patch to allow compulation with 1.5 vms.
10 Jan 2008; Vlastimil Babka <caster@gentoo.org> octopus-3.0.1-r1.ebuild:
Restrict junit dependency.
diff --git a/dev-db/octopus/files/octopus-jdk-1.5.patch b/dev-db/octopus/files/octopus-jdk-1.5.patch
new file mode 100644
index 000000000000..4d4996995376
--- /dev/null
+++ b/dev-db/octopus/files/octopus-jdk-1.5.patch
@@ -0,0 +1,220 @@
+diff -Naur XMLutil.bak/src/src/org/enhydra/xml/AttrImpl.java XMLutil/src/src/org/enhydra/xml/AttrImpl.java
+--- XMLutil/src/src/org/enhydra/xml/AttrImpl.java 2009-09-18 17:39:19.000000000 +1200
++++ XMLutil/src/src/org/enhydra/xml/AttrImpl.java 2009-09-18 18:03:36.000000000 +1200
+@@ -20,6 +20,7 @@
+
+ import org.w3c.dom.Attr;
+ import org.w3c.dom.Element;
++import org.w3c.dom.TypeInfo;
+
+
+ /**
+@@ -186,4 +187,18 @@
+ public Element getOwnerElement() {
+ return owner;
+ }
+-}
+\ No newline at end of file
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public TypeInfo getSchemaTypeInfo() {
++ return null;
++ }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public boolean isId() {
++ return false;
++ }
++}
+diff -Naur XMLutil.bak/src/src/org/enhydra/xml/CharacterDataImpl.java XMLutil/src/src/org/enhydra/xml/CharacterDataImpl.java
+--- XMLutil/src/src/org/enhydra/xml/CharacterDataImpl.java 2009-09-18 17:39:19.000000000 +1200
++++ XMLutil/src/src/org/enhydra/xml/CharacterDataImpl.java 2009-09-18 18:06:38.000000000 +1200
+@@ -177,5 +177,4 @@
+ return super.getNamespaceURI();
+ }
+
+-
+ }
+diff -Naur XMLutil.bak/src/src/org/enhydra/xml/ElementImpl.java XMLutil/src/src/org/enhydra/xml/ElementImpl.java
+--- XMLutil/src/src/org/enhydra/xml/ElementImpl.java 2009-09-18 17:39:19.000000000 +1200
++++ XMLutil/src/src/org/enhydra/xml/ElementImpl.java 2009-09-18 18:25:24.000000000 +1200
+@@ -33,6 +33,7 @@
+ import org.w3c.dom.NamedNodeMap;
+ import org.w3c.dom.Node;
+ import org.w3c.dom.NodeList;
++import org.w3c.dom.TypeInfo;
+
+ /**
+ * @author Tweety
+@@ -564,4 +565,33 @@
+ sb.append("</" + this.nodeName + ">");
+ // }
+ }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public TypeInfo getSchemaTypeInfo() {
++ return null;
++ }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public void setIdAttribute(String name,
++ boolean idId)
++ throws DOMException { }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public void setIdAttributeNS(String name,
++ String localName,
++ boolean isId)
++ throws DOMException {}
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public void setIdAttributeNode(Attr idAttr,
++ boolean isId)
++ throws DOMException {}
+ }
+diff -Naur XMLutil.bak/src/src/org/enhydra/xml/NodeImpl.java XMLutil/src/src/org/enhydra/xml/NodeImpl.java
+--- XMLutil/src/src/org/enhydra/xml/NodeImpl.java 2009-09-18 17:39:19.000000000 +1200
++++ XMLutil/src/src/org/enhydra/xml/NodeImpl.java 2009-09-18 18:19:58.000000000 +1200
+@@ -33,6 +33,7 @@
+ import org.w3c.dom.NamedNodeMap;
+ import org.w3c.dom.Node;
+ import org.w3c.dom.NodeList;
++import org.w3c.dom.UserDataHandler;
+
+ /**
+ * @author Tweety
+@@ -784,6 +785,92 @@
+ return sb.toString();
+ }
+
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public String getBaseURI() {
++ return null;
++ }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public short compareDocumentPosition(Node other)
++ throws DOMException {
++ throw new DOMException(DOMException.NOT_SUPPORTED_ERR,
++ "Unimplemented method");
++ }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public String getTextContent() throws DOMException {
++ return null;
++ }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public void setTextContent(String textContent)
++ throws DOMException { }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public boolean isSameNode(Node other) {
++ return false;
++ }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public String lookupPrefix(String namespaceURI) {
++ return null;
++ }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public boolean isDefaultNamespace(String namespaceURI) {
++ return true;
++ }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public String lookupNamespaceURI(String prefix) {
++ return null;
++ }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public boolean isEqualNode(Node arg) {
++ return false;
++ }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public Object getFeature(String feature, String version) {
++ return null;
++ }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public Object setUserData(String key, Object data,
++ UserDataHandler handler) {
++ return null;
++ }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public Object getUserData(String key) {
++ return null;
++ }
++
+
+ /**
+ * Method beginToString should be redefined in extended classes.
+diff -Naur XMLutil.bak/src/src/org/enhydra/xml/TextImpl.java XMLutil/src/src/org/enhydra/xml/TextImpl.java
+--- XMLutil/src/src/org/enhydra/xml/TextImpl.java 2009-09-18 17:39:19.000000000 +1200
++++ XMLutil/src/src/org/enhydra/xml/TextImpl.java 2009-09-18 18:27:04.000000000 +1200
+@@ -161,4 +161,26 @@
+
+ }
+
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public boolean isElementContentWhitespace() {
++ return false;
++ }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public String getWholeText() {
++ return null;
++ }
++
++ /**
++ * Unimplemented method included in DOM Level 3 (aka 1.5).
++ */
++ public Text replaceWholeText(String content)
++ throws DOMException {
++ return null;
++ }
++
+ }
diff --git a/dev-db/octopus/octopus-3.0.1-r2.ebuild b/dev-db/octopus/octopus-3.0.1-r2.ebuild
new file mode 100644
index 000000000000..e2ffd2eed975
--- /dev/null
+++ b/dev-db/octopus/octopus-3.0.1-r2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/octopus-3.0.1-r2.ebuild,v 1.1 2009/09/18 07:20:21 ali_bush Exp $
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source"
+
+inherit versionator java-pkg-2 java-ant-2
+
+MY_PV=${PV//./-}
+MY_PV=${MY_PV/-/.}
+DESCRIPTION="A Java-based Extraction, Transformation, and Loading (ETL) tool."
+SRC_URI="http://download.forge.objectweb.org/${PN}/${PN}-${MY_PV}.src.tar.gz
+ mirror://gentoo/${PN}-xmls-${PV}.tar.bz2"
+HOMEPAGE="http://octopus.objectweb.org"
+LICENSE="LGPL-2.1"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+COMMON_DEP="
+ >=dev-java/xerces-2.7
+ >=dev-java/log4j-1.2.8
+ =dev-java/rhino-1.6*
+ =dev-java/junit-3.8*
+ >=dev-java/ant-core-1.4"
+
+# Does not like org.w3c.dom.Node
+# from 1.5+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+DEPEND="|| ( =virtual/jdk-1.5* =virtual/jdk-1.4* )
+ ${COMMON_DEP}"
+
+TOPDIR="${PN}-$(get_version_component_range 1-2)"
+S=${WORKDIR}/${TOPDIR}/Octopus-src
+
+java_prepare() {
+ rm -fr ${TOPDIR}/maven
+
+ mv "${WORKDIR}/xmls" "${S}/modules/Octopus"
+
+ cd "${S}"/modules
+ cp "${FILESDIR}/${P}-gentoo-build.xml" build.xml
+ java-ant_rewrite-classpath build.xml
+ java-pkg_filter-compiler jikes
+
+ java-pkg_is-vm-version-eq 1.5 && \
+ epatch "${FILESDIR}/${PN}-jdk-1.5.patch"
+}
+
+EANT_GENTOO_CLASSPATH="xerces-2,rhino-1.6,ant-core,junit,log4j"
+
+src_compile() {
+ cd "${S}/modules"
+
+ use source && antflags="${antflags} sourcezip-all"
+
+ eant jar-all $(use_doc docs-all) ${antflags}
+}
+
+RESTRICT="test"
+
+# Would need maven to work properly as the build.xml just launches maven
+#src_test() {
+# eant test
+#}
+
+src_install() {
+ dodoc ChangeLog.txt ReleaseNotes.txt
+
+ cd "${S}/modules"
+ java-pkg_dojar dist/*.jar
+
+ if use source; then
+ dodir /usr/share/doc/${PF}/source
+ cp dist/*-src.zip "${D}usr/share/doc/${PF}/source"
+ fi
+ if use doc; then
+ docinto html/api
+ # Has multiple javadoc subdirs here
+ java-pkg_dohtml -r docs/*
+ fi
+}