summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-04-19 20:01:55 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-04-19 20:01:55 +0000
commit37e89fc2f4011e43ab13dcda65f80015c52fbdb8 (patch)
tree9359fae4cea521e25723290b68f8db98fc9a6e96 /dev-db/percona-toolkit
parentNo ewarns even if tar misses some files on unpack, as that is so common it's ... (diff)
downloadgentoo-2-37e89fc2f4011e43ab13dcda65f80015c52fbdb8.tar.gz
gentoo-2-37e89fc2f4011e43ab13dcda65f80015c52fbdb8.tar.bz2
gentoo-2-37e89fc2f4011e43ab13dcda65f80015c52fbdb8.zip
Initial commit. Based on the maatkit package. The names of all of the binaries have changed, and the FNV/Murmur UDFs are no longer included by upstream. Due to these changes by upstream, this is not being done as a pkgmove.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/percona-toolkit')
-rw-r--r--dev-db/percona-toolkit/ChangeLog12
-rw-r--r--dev-db/percona-toolkit/metadata.xml26
-rw-r--r--dev-db/percona-toolkit/percona-toolkit-2.1.1.ebuild34
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-db/percona-toolkit/ChangeLog b/dev-db/percona-toolkit/ChangeLog
new file mode 100644
index 000000000000..6626e95c08e6
--- /dev/null
+++ b/dev-db/percona-toolkit/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-db/percona-toolkit
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/percona-toolkit/ChangeLog,v 1.1 2012/04/19 20:01:55 robbat2 Exp $
+
+*percona-toolkit-2.1.1 (19 Apr 2012)
+
+ 19 Apr 2012; Robin H. Johnson <robbat2@gentoo.org> +metadata.xml,
+ +percona-toolkit-2.1.1.ebuild:
+ Initial commit. Based on the maatkit package. The names of all of the binaries
+ have changed, and the FNV/Murmur UDFs are no longer included by upstream. Due
+ to these changes by upstream, this is not being done as a pkgmove.
+
diff --git a/dev-db/percona-toolkit/metadata.xml b/dev-db/percona-toolkit/metadata.xml
new file mode 100644
index 000000000000..bff2ea86d9a1
--- /dev/null
+++ b/dev-db/percona-toolkit/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mysql</herd>
+ <maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ <description>Secondary maintainer</description>
+ </maintainer>
+ <longdescription>Percona Toolkit, formerly Maatkit and Aspersa, formerly MySQL Toolkit,
+ is a collection of command-line utilities that provide missing
+ functionality for MySQL. Some of the tools implement lacking server
+ functionality, such as online consistency checks for master/slave
+ replication; others are client-side utilities such as a query
+ profiler.</longdescription>
+ <!--
+ <upstream>
+ <remote-id type="launchpad">percona-toolkit</remote-id>
+ </upstream>
+ -->
+</pkgmetadata>
diff --git a/dev-db/percona-toolkit/percona-toolkit-2.1.1.ebuild b/dev-db/percona-toolkit/percona-toolkit-2.1.1.ebuild
new file mode 100644
index 000000000000..82022bd05c46
--- /dev/null
+++ b/dev-db/percona-toolkit/percona-toolkit-2.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/percona-toolkit/percona-toolkit-2.1.1.ebuild,v 1.1 2012/04/19 20:01:55 robbat2 Exp $
+
+EAPI=3
+
+inherit perl-app perl-module toolchain-funcs
+
+DESCRIPTION="essential command-line utilities for MySQL"
+HOMEPAGE="http://www.percona.com/software/percona-toolkit/"
+SRC_URI="http://www.percona.com/downloads/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 Artistic )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+COMMON_DEPEND="dev-perl/DBI
+ dev-perl/DBD-mysql
+ virtual/perl-Time-HiRes"
+RDEPEND="${COMMON_DEPEND}
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-Local
+ virtual/perl-Digest-MD5
+ virtual/perl-IO-Compress
+ virtual/perl-File-Temp
+ virtual/perl-File-Spec
+ virtual/perl-Time-HiRes
+ virtual/perl-Scalar-List-Utils
+ dev-perl/TermReadKey"
+DEPEND="${COMMON_DEPEND}
+ virtual/perl-ExtUtils-MakeMaker"
+
+# Percona Toolkit does NOT contain the UDF code for Murmur/FNV any more.