summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2013-08-26 11:48:14 +0000
committerDirkjan Ochtman <djc@gentoo.org>2013-08-26 11:48:14 +0000
commit0665117f167041e2bd19fc2b4057c30fdf8e5176 (patch)
tree5dc417b6963f9203fb1bcc9ee551ab3e6f06d490 /dev-db/redis
parentdev-haskell/word8: initial layout (diff)
downloadgentoo-2-0665117f167041e2bd19fc2b4057c30fdf8e5176.tar.gz
gentoo-2-0665117f167041e2bd19fc2b4057c30fdf8e5176.tar.bz2
gentoo-2-0665117f167041e2bd19fc2b4057c30fdf8e5176.zip
Clean out redis-2.4.*.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 6B065BFB)
Diffstat (limited to 'dev-db/redis')
-rw-r--r--dev-db/redis/ChangeLog6
-rw-r--r--dev-db/redis/redis-2.4.10.ebuild107
-rw-r--r--dev-db/redis/redis-2.4.18.ebuild112
3 files changed, 5 insertions, 220 deletions
diff --git a/dev-db/redis/ChangeLog b/dev-db/redis/ChangeLog
index 89e379d97c6b..446a301abe17 100644
--- a/dev-db/redis/ChangeLog
+++ b/dev-db/redis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/redis
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.67 2013/08/26 11:47:13 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.68 2013/08/26 11:48:14 djc Exp $
+
+ 26 Aug 2013; Dirkjan Ochtman <djc@gentoo.org> -redis-2.4.10.ebuild,
+ -redis-2.4.18.ebuild:
+ Clean out redis-2.4.*.
*redis-2.6.15 (26 Aug 2013)
diff --git a/dev-db/redis/redis-2.4.10.ebuild b/dev-db/redis/redis-2.4.10.ebuild
deleted file mode 100644
index 2cca57967f59..000000000000
--- a/dev-db/redis/redis-2.4.10.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.4.10.ebuild,v 1.5 2012/09/12 15:52:37 neurogeek Exp $
-
-EAPI="4"
-
-inherit autotools eutils flag-o-matic user
-
-DESCRIPTION="A persistent caching system, key-value and data structures database."
-HOMEPAGE="http://redis.io/"
-SRC_URI="http://redis.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="amd64 x86 ~x86-macos ~x86-solaris"
-IUSE="+jemalloc tcmalloc test"
-SLOT="0"
-
-RDEPEND="tcmalloc? ( dev-util/google-perftools )
- jemalloc? ( dev-libs/jemalloc )"
-DEPEND=">=sys-devel/autoconf-2.63
- test? ( dev-lang/tcl )
- ${RDEPEND}"
-REQUIRED_USE="tcmalloc? ( !jemalloc )
- jemalloc? ( !tcmalloc )"
-
-S="${WORKDIR}/${PN}-${PV/_/-}"
-
-REDIS_PIDDIR=/var/run/redis/
-REDIS_PIDFILE=${REDIS_PIDDIR}/redis.pid
-REDIS_DATAPATH=/var/lib/redis
-REDIS_LOGPATH=/var/log/redis
-REDIS_LOGFILE=${REDIS_LOGPATH}/redis.log
-
-pkg_setup() {
- enewgroup redis 75
- enewuser redis 75 -1 ${REDIS_DATAPATH} redis
- if use tcmalloc ; then
- export EXTRA_EMAKE="${EXTRA_EMAKE} USE_TCMALLOC=yes"
- elif use jemalloc ; then
- export EXTRA_EMAKE="${EXTRA_EMAKE} JEMALLOC_SHARED=yes"
- else
- export EXTRA_EMAKE="${EXTRA_EMAKE} FORCE_LIBC_MALLOC=yes"
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}/redis-2.4.3-shared.patch"
- epatch "${FILESDIR}/redis-2.4.4-tcmalloc.patch"
- if use jemalloc ; then
- sed -i -e "s/je_/j/" src/zmalloc.c
- fi
- # now we will rewrite present Makefiles
- local makefiles=""
- for MKF in $(find -name 'Makefile' | cut -b 3-); do
- mv "${MKF}" "${MKF}.in"
- sed -i -e 's:$(CC):@CC@:g' \
- -e 's:$(CFLAGS):@AM_CFLAGS@:g' \
- -e 's: $(DEBUG)::g' \
- -e 's:$(OBJARCH)::g' \
- -e 's:ARCH:TARCH:g' \
- -e '/^CCOPT=/s:$: $(LDFLAGS):g' \
- "${MKF}.in" \
- || die "Sed failed for ${MKF}"
- makefiles+=" ${MKF}"
- done
- # autodetection of compiler and settings; generates the modified Makefiles
- cp "${FILESDIR}"/configure.ac-2.2 configure.ac
- sed -i -e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
- configure.ac || die "Sed failed for configure.ac"
- eautoconf
-}
-
-src_install() {
- # configuration file rewrites
- insinto /etc/
- sed -r \
- -e "/^pidfile\>/s,/var.*,${REDIS_PIDFILE}," \
- -e '/^daemonize\>/s,no,yes,' \
- -e '/^# bind/s,^# ,,' \
- -e '/^# maxmemory\>/s,^# ,,' \
- -e '/^maxmemory\>/s,<bytes>,67108864,' \
- -e "/^dbfilename\>/s,dump.rdb,${REDIS_DATAPATH}/dump.rdb," \
- -e "/^dir\>/s, .*, ${REDIS_DATAPATH}/," \
- -e '/^loglevel\>/s:debug:notice:' \
- -e "/^logfile\>/s:stdout:${REDIS_LOGFILE}:" \
- <redis.conf \
- >redis.conf.gentoo
- newins redis.conf.gentoo redis.conf
- use prefix || fowners redis:redis /etc/redis.conf
- fperms 0644 /etc/redis.conf
-
- newconfd "${FILESDIR}/redis.confd" redis
- newinitd "${FILESDIR}/redis.initd" redis
-
- nonfatal dodoc 00-RELEASENOTES BUGS CONTRIBUTING README TODO
-
- dobin src/redis-cli
- dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-dump
- fperms 0750 /usr/sbin/redis-benchmark
-
- if use prefix; then
- diropts -m0750
- else
- diropts -m0750 -o redis -g redis
- fi
- keepdir ${REDIS_DATAPATH} ${REDIS_LOGPATH}
-}
diff --git a/dev-db/redis/redis-2.4.18.ebuild b/dev-db/redis/redis-2.4.18.ebuild
deleted file mode 100644
index 9eaa21c972f2..000000000000
--- a/dev-db/redis/redis-2.4.18.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.4.18.ebuild,v 1.2 2012/12/26 11:15:46 djc Exp $
-
-EAPI="4"
-
-inherit autotools eutils flag-o-matic user
-
-DESCRIPTION="A persistent caching system, key-value and data structures database."
-HOMEPAGE="http://redis.io/"
-SRC_URI="http://redis.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~x86-macos ~x86-solaris"
-IUSE="+jemalloc tcmalloc test"
-SLOT="0"
-
-RDEPEND="tcmalloc? ( dev-util/google-perftools )
- jemalloc? ( >=dev-libs/jemalloc-3.2 )"
-DEPEND=">=sys-devel/autoconf-2.63
- test? ( dev-lang/tcl )
- ${RDEPEND}"
-REQUIRED_USE="tcmalloc? ( !jemalloc )
- jemalloc? ( !tcmalloc )"
-
-S="${WORKDIR}/${PN}-${PV/_/-}"
-
-REDIS_PIDDIR=/var/run/redis/
-REDIS_PIDFILE=${REDIS_PIDDIR}/redis.pid
-REDIS_DATAPATH=/var/lib/redis
-REDIS_LOGPATH=/var/log/redis
-REDIS_LOGFILE=${REDIS_LOGPATH}/redis.log
-
-pkg_setup() {
- enewgroup redis 75
- enewuser redis 75 -1 ${REDIS_DATAPATH} redis
-}
-
-src_prepare() {
- epatch "${FILESDIR}/redis-2.4.17-shared.patch"
- epatch "${FILESDIR}/redis-2.4.4-tcmalloc.patch"
-
- # now we will rewrite present Makefiles
- local makefiles=""
- for MKF in $(find -name 'Makefile' | cut -b 3-); do
- mv "${MKF}" "${MKF}.in"
- sed -i -e 's:$(CC):@CC@:g' \
- -e 's:$(CFLAGS):@AM_CFLAGS@:g' \
- -e 's: $(DEBUG)::g' \
- -e 's:$(OBJARCH)::g' \
- -e 's:ARCH:TARCH:g' \
- -e '/^CCOPT=/s:$: $(LDFLAGS):g' \
- "${MKF}.in" \
- || die "Sed failed for ${MKF}"
- makefiles+=" ${MKF}"
- done
- # autodetection of compiler and settings; generates the modified Makefiles
- cp "${FILESDIR}"/configure.ac-2.2 configure.ac
- sed -i -e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
- configure.ac || die "Sed failed for configure.ac"
- eautoconf
-}
-
-src_compile() {
- local myconf=""
-
- if use tcmalloc ; then
- myconf="${myconf} USE_TCMALLOC=yes"
- elif use jemalloc ; then
- myconf="${myconf} JEMALLOC_SHARED=yes"
- else
- myconf="${myconf} FORCE_LIBC_MALLOC=yes"
- fi
-
- emake ${myconf}
-}
-
-src_install() {
- # configuration file rewrites
- insinto /etc/
- sed -r \
- -e "/^pidfile\>/s,/var.*,${REDIS_PIDFILE}," \
- -e '/^daemonize\>/s,no,yes,' \
- -e '/^# bind/s,^# ,,' \
- -e '/^# maxmemory\>/s,^# ,,' \
- -e '/^maxmemory\>/s,<bytes>,67108864,' \
- -e "/^dbfilename\>/s,dump.rdb,${REDIS_DATAPATH}/dump.rdb," \
- -e "/^dir\>/s, .*, ${REDIS_DATAPATH}/," \
- -e '/^loglevel\>/s:(verbose|debug):notice:' \
- -e "/^logfile\>/s:stdout:${REDIS_LOGFILE}:" \
- <redis.conf \
- >redis.conf.gentoo
- newins redis.conf.gentoo redis.conf
- use prefix || fowners redis:redis /etc/redis.conf
- fperms 0644 /etc/redis.conf
-
- newconfd "${FILESDIR}/redis.confd" redis
- newinitd "${FILESDIR}/redis.initd" redis
-
- nonfatal dodoc 00-RELEASENOTES BUGS CONTRIBUTING README
-
- dobin src/redis-cli
- dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-dump
- fperms 0750 /usr/sbin/redis-benchmark
-
- if use prefix; then
- diropts -m0750
- else
- diropts -m0750 -o redis -g redis
- fi
- keepdir ${REDIS_DATAPATH} ${REDIS_LOGPATH}
-}