summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-01-01 20:54:26 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-01-01 20:54:26 +0000
commit3e9279f90cefef9aa8b3f609d53fd1c621c14db0 (patch)
tree8c8147f2b32c7f7939f990fbf478a495607f2226 /dev-db/sqlite
parentRemove net-ftp/kbear; bug 152525 (diff)
downloadgentoo-2-3e9279f90cefef9aa8b3f609d53fd1c621c14db0.tar.gz
gentoo-2-3e9279f90cefef9aa8b3f609d53fd1c621c14db0.tar.bz2
gentoo-2-3e9279f90cefef9aa8b3f609d53fd1c621c14db0.zip
Remove virtual/libc from DEPEND.
(Portage version: 2.1.2_rc4-r4)
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/ChangeLog7
-rw-r--r--dev-db/sqlite/sqlite-2.8.16-r1.ebuild22
-rw-r--r--dev-db/sqlite/sqlite-3.2.1-r3.ebuild6
-rw-r--r--dev-db/sqlite/sqlite-3.3.5-r1.ebuild6
-rw-r--r--dev-db/sqlite/sqlite-3.3.6.ebuild6
5 files changed, 26 insertions, 21 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 0227a0455873..8b55fcd11211 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/sqlite
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.131 2007/01/01 20:50:20 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.132 2007/01/01 20:54:26 betelgeuse Exp $
+
+ 01 Jan 2007; Petteri Räty <betelgeuse@gentoo.org>
+ sqlite-2.8.16-r1.ebuild, sqlite-3.2.1-r3.ebuild, sqlite-3.3.5-r1.ebuild,
+ sqlite-3.3.6.ebuild:
+ Remove virtual/libc from DEPEND.
01 Jan 2007; Petteri Räty <betelgeuse@gentoo.org> -sqlite-2.8.15.ebuild,
-sqlite-2.8.16-r3.ebuild, -sqlite-3.2.7-r1.ebuild, -sqlite-3.3.4.ebuild,
diff --git a/dev-db/sqlite/sqlite-2.8.16-r1.ebuild b/dev-db/sqlite/sqlite-2.8.16-r1.ebuild
index 4b4d3d8d9f0c..9981d8f54b1d 100644
--- a/dev-db/sqlite/sqlite-2.8.16-r1.ebuild
+++ b/dev-db/sqlite/sqlite-2.8.16-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r1.ebuild,v 1.13 2006/07/28 19:28:30 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r1.ebuild,v 1.14 2007/01/01 20:54:26 betelgeuse Exp $
inherit eutils toolchain-funcs
@@ -50,13 +50,13 @@ src_compile() {
emake all || die
if use doc; then
- emake doc || die
+ emake doc || die
fi
if use tcl; then
- cp -P ${FILESDIR}/maketcllib.sh ${S}
- chmod +x ./maketcllib.sh
- ./maketcllib.sh
+ cp -P ${FILESDIR}/maketcllib.sh ${S}
+ chmod +x ./maketcllib.sh
+ ./maketcllib.sh
fi
}
@@ -70,13 +70,13 @@ src_install () {
doman sqlite.1
if use doc; then
- docinto html
- dohtml doc/*.html doc/*.txt doc/*.png
+ docinto html
+ dohtml doc/*.html doc/*.txt doc/*.png
fi
if use tcl; then
- mkdir ${D}/usr/lib/tclsqlite${PV}
- cp ${S}/tclsqlite.so ${D}/usr/lib/tclsqlite${PV}/
- cp ${S}/pkgIndex.tcl ${D}/usr/lib/tclsqlite${PV}/
+ mkdir ${D}/usr/lib/tclsqlite${PV}
+ cp ${S}/tclsqlite.so ${D}/usr/lib/tclsqlite${PV}/
+ cp ${S}/pkgIndex.tcl ${D}/usr/lib/tclsqlite${PV}/
fi
}
diff --git a/dev-db/sqlite/sqlite-3.2.1-r3.ebuild b/dev-db/sqlite/sqlite-3.2.1-r3.ebuild
index 7fe88c2352fb..a78e1c1a6681 100644
--- a/dev-db/sqlite/sqlite-3.2.1-r3.ebuild
+++ b/dev-db/sqlite/sqlite-3.2.1-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.2.1-r3.ebuild,v 1.11 2006/01/14 18:19:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.2.1-r3.ebuild,v 1.12 2007/01/01 20:54:26 betelgeuse Exp $
inherit eutils
@@ -13,7 +13,7 @@ SLOT="3"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ~ppc-macos ppc64 sh sparc x86"
IUSE="nothreadsafe doc"
-DEPEND="virtual/libc
+DEPEND="
doc? ( dev-lang/tcl )"
src_unpack() {
diff --git a/dev-db/sqlite/sqlite-3.3.5-r1.ebuild b/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
index 317ed2dcd0bf..72627026725d 100644
--- a/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
+++ b/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.5-r1.ebuild,v 1.14 2006/10/16 03:17:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.5-r1.ebuild,v 1.15 2007/01/01 20:54:26 betelgeuse Exp $
inherit eutils alternatives
@@ -13,7 +13,7 @@ SLOT="3"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc-macos ppc64 s390 sh sparc x86"
IUSE="nothreadsafe doc tcl debug"
-DEPEND="virtual/libc
+DEPEND="
doc? ( dev-lang/tcl )
tcl? ( dev-lang/tcl )"
diff --git a/dev-db/sqlite/sqlite-3.3.6.ebuild b/dev-db/sqlite/sqlite-3.3.6.ebuild
index ddf70c6efb72..39d10ed24d54 100644
--- a/dev-db/sqlite/sqlite-3.3.6.ebuild
+++ b/dev-db/sqlite/sqlite-3.3.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.6.ebuild,v 1.7 2006/11/15 22:08:12 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.6.ebuild,v 1.8 2007/01/01 20:54:26 betelgeuse Exp $
inherit eutils alternatives libtool
@@ -13,7 +13,7 @@ SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE="nothreadsafe doc tcl debug"
-DEPEND="virtual/libc
+DEPEND="
doc? ( dev-lang/tcl )
tcl? ( dev-lang/tcl )"