summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2012-09-26 06:50:53 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2012-09-26 06:50:53 +0000
commit2443dc3da7183968e03f3cc3a18e8fcaeef1a1ba (patch)
tree7476fd71d6ccb05cd908025baa6ac2987a77974a /dev-db
parentSpecify LICENSE more precisely. Bump ebuild to EAPI 4. (diff)
downloadgentoo-2-2443dc3da7183968e03f3cc3a18e8fcaeef1a1ba.tar.gz
gentoo-2-2443dc3da7183968e03f3cc3a18e8fcaeef1a1ba.tar.bz2
gentoo-2-2443dc3da7183968e03f3cc3a18e8fcaeef1a1ba.zip
Use dev-libs/ferrisloki instead of bundled one, bug#383109.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/tora/ChangeLog8
-rw-r--r--dev-db/tora/files/tora-2.1.3-ext-loki.patch84
-rw-r--r--dev-db/tora/tora-2.1.3-r2.ebuild80
3 files changed, 171 insertions, 1 deletions
diff --git a/dev-db/tora/ChangeLog b/dev-db/tora/ChangeLog
index af327785fc96..b2b49b4d0054 100644
--- a/dev-db/tora/ChangeLog
+++ b/dev-db/tora/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/tora
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.94 2012/09/24 19:49:08 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.95 2012/09/26 06:50:53 haubi Exp $
+
+*tora-2.1.3-r2 (25 Sep 2012)
+
+ 25 Sep 2012; Michael Haubenwallner <haubi@gentoo.org> +tora-2.1.3-r2.ebuild,
+ +files/tora-2.1.3-ext-loki.patch:
+ Use dev-libs/ferrisloki instead of bundled one, bug#383109.
24 Sep 2012; Michael Haubenwallner <haubi@gentoo.org> tora-2.1.3-r1.ebuild,
+files/tora-2.1.3-gcc-4.7.patch:
diff --git a/dev-db/tora/files/tora-2.1.3-ext-loki.patch b/dev-db/tora/files/tora-2.1.3-ext-loki.patch
new file mode 100644
index 000000000000..dec482a31bc1
--- /dev/null
+++ b/dev-db/tora/files/tora-2.1.3-ext-loki.patch
@@ -0,0 +1,84 @@
+--- CMakeLists.txt.orig 2012-09-25 21:47:27.591130679 +0200
++++ CMakeLists.txt 2012-09-25 21:51:02.953508806 +0200
+@@ -4,6 +4,7 @@
+ # options available for user's input
+ OPTION(WANT_DEBUG "Set the debug build and possible additional outputs" OFF)
+ OPTION(WANT_INTERNAL_QSCINTILLA "Use internal/bundled QScintilla2 source" OFF)
++OPTION(WANT_INTERNAL_LOKI "Use internal/bundled Loki source" OFF)
+ OPTION(ENABLE_ORACLE "Enable/Disable Oracle support at all. Including detection" ON)
+ OPTION(ENABLE_PGSQL "Enable/Disable PostgreSQL support. Including detection" ON)
+ OPTION(ENABLE_DB2 "Enable/Disable DB2 support. Including detection" ON)
+@@ -50,6 +51,7 @@
+ INCLUDE(CheckCXXCompilerFlag)
+ INCLUDE(CheckTypeSize)
+ INCLUDE(TestBigEndian)
++INCLUDE(FindPkgConfig)
+
+ #Set the custom CMake module directory where our include/lib finders are
+ SET(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules")
+@@ -197,6 +199,10 @@
+ MESSAGE(FATAL_ERROR "No Qt4 found")
+ ENDIF(QT_FOUND)
+
++IF (WANT_INTERNAL_LOKI)
++ELSE (WANT_INTERNAL_LOKI)
++ pkg_check_modules(LOKI REQUIRED ferrisloki)
++ENDIF (WANT_INTERNAL_LOKI)
+
+ IF (WANT_INTERNAL_QSCINTILLA)
+ MESSAGE(STATUS "QSci: Building with internal copy of QScintilla.")
+--- src/CMakeLists.txt.orig 2012-09-25 22:45:20.702694011 +0200
++++ src/CMakeLists.txt 2012-09-25 22:47:39.742124547 +0200
+@@ -3,7 +3,10 @@
+
+ #Subdirectories
+ # ADD_SUBDIRECTORY(i18n)
+-ADD_SUBDIRECTORY(loki)
++# Default: loki as 3rd party lib!
++IF (WANT_INTERNAL_LOKI)
++ ADD_SUBDIRECTORY(loki)
++ENDIF(WANT_INTERNAL_LOKI)
+ IF (WIN32)
+ ADD_SUBDIRECTORY(windows)
+ ENDIF (WIN32)
+@@ -468,7 +471,9 @@
+ QT4_ADD_RESOURCES(TORA_RCC_SRCS ${TORA_RCC_FILES})
+
+
+-LINK_DIRECTORIES(./loki)
++IF (WANT_INTERNAL_LOKI)
++ LINK_DIRECTORIES(./loki)
++ENDIF(WANT_INTERNAL_LOKI)
+ IF (WIN32)
+ LINK_DIRECTORIES(./windows)
+ ENDIF (WIN32)
+@@ -477,7 +482,10 @@
+ ENDIF (WANT_INTERNAL_QSCINTILLA)
+
+
+-SET(TORA_LOKI_LIB "tora_loki_lib")
++IF (WANT_INTERNAL_LOKI)
++ SET(LOKI_LIBRARIES "tora_loki_lib")
++ SET(LOKI_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/loki/include)
++ENDIF(WANT_INTERNAL_LOKI)
+ IF (WANT_INTERNAL_QSCINTILLA)
+ SET (TORA_QSCINTILLA_LIB tora_qscintilla2_lib)
+ ENDIF (WANT_INTERNAL_QSCINTILLA)
+@@ -493,7 +501,7 @@
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${QT_INCLUDES}
+- ${CMAKE_CURRENT_SOURCE_DIR}/loki/include
++ ${LOKI_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_SOURCE_DIR}/otl
+ )
+
+@@ -590,7 +598,7 @@
+ ENDIF (USE_TROTL)
+
+ # static
+-TARGET_LINK_LIBRARIES(${EXE_NAME} ${TORA_LOKI_LIB})
++TARGET_LINK_LIBRARIES(${EXE_NAME} ${LOKI_LIBRARIES})
+ IF (WANT_INTERNAL_QSCINTILLA)
+ TARGET_LINK_LIBRARIES(${EXE_NAME} ${TORA_QSCINTILLA_LIB} ${QT_LIBRARIES})
+ ENDIF (WANT_INTERNAL_QSCINTILLA)
diff --git a/dev-db/tora/tora-2.1.3-r2.ebuild b/dev-db/tora/tora-2.1.3-r2.ebuild
new file mode 100644
index 000000000000..82f141f8ba60
--- /dev/null
+++ b/dev-db/tora/tora-2.1.3-r2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-2.1.3-r2.ebuild,v 1.1 2012/09/26 06:50:53 haubi Exp $
+
+EAPI=2
+
+inherit cmake-utils eutils
+
+DESCRIPTION="TOra - Toolkit For Oracle"
+HOMEPAGE="http://tora.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+IUSE="debug mysql oracle oci8-instant-client postgres"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="
+ dev-libs/ferrisloki
+ x11-libs/qscintilla
+ x11-libs/qt-gui:4
+ x11-libs/qt-sql:4[mysql?,postgres?]
+ x11-libs/qt-xmlpatterns:4
+ oci8-instant-client? (
+ dev-db/oracle-instantclient-basic
+ dev-db/oracle-instantclient-sqlplus
+ )
+ postgres? ( dev-db/postgresql-server )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ( use oracle || use oci8-instant-client ) && [ -z "$ORACLE_HOME" ] ; then
+ eerror "ORACLE_HOME variable is not set."
+ eerror
+ eerror "You must install Oracle >= 8i client for Linux in"
+ eerror "order to compile TOra with Oracle support."
+ eerror
+ eerror "Otherwise specify -oracle in your USE variable."
+ eerror
+ eerror "You can download the Oracle software from"
+ eerror "http://otn.oracle.com/software/content.html"
+ die
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.7.patch #430044
+ epatch "${FILESDIR}"/${P}-ext-loki.patch #383109
+ sed -i \
+ -e "/COPYING/ d" \
+ CMakeLists.txt || die "Removal of COPYING file failed"
+}
+
+src_configure() {
+ local mycmakeargs=()
+ if use oracle || use oci8-instant-client ; then
+ mycmakeargs=(-DENABLE_ORACLE=ON)
+ else
+ mycmakeargs=(-DENABLE_ORACLE=OFF)
+ fi
+ mycmakeargs+=(
+ -DWANT_RPM=OFF
+ -DWANT_BUNDLE=OFF
+ -DWANT_BUNDLE_STANDALONE=OFF
+ -DWANT_INTERNAL_QSCINTILLA=OFF
+ -DWANT_INTERNAL_LOKI=OFF
+ $(cmake-utils_use_enable postgres PGSQL)
+ $(cmake-utils_use_want debug)
+ # path variables
+ -DTORA_DOC_DIR=share/doc/${PF}
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon src/icons/${PN}.xpm || die
+ domenu debian/${PN}.desktop || die
+}