summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-12 16:44:18 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-12 16:44:18 +0000
commit919a9c348bf64d4509807d00088aff8c188b09a9 (patch)
tree7e07e2cad103203266d0e00f9d5776844e9e99fd /dev-db
parentnew dutch dictionary (diff)
downloadgentoo-2-919a9c348bf64d4509807d00088aff8c188b09a9.tar.gz
gentoo-2-919a9c348bf64d4509807d00088aff8c188b09a9.tar.bz2
gentoo-2-919a9c348bf64d4509807d00088aff8c188b09a9.zip
tweaked the adduser section of the ebuild. Fixes #4796. Thx to Anndy Dustman.
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/ChangeLog6
-rw-r--r--dev-db/postgresql/postgresql-7.2-r3.ebuild4
-rw-r--r--dev-db/postgresql/postgresql-7.2.1-r1.ebuild11
3 files changed, 14 insertions, 7 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index e468fec2db10..2b64425ad1c9 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.14 2002/07/08 22:39:24 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.15 2002/07/12 16:44:18 rphillips Exp $
*postgresql-7.2-r3 (02 Jul 2002)
@@ -17,6 +17,10 @@
*postgresql-7.2.1-r1 (20 Jun 2002)
+ 12 Jul 2002; Ryan Phillips <rphillips@gentoo.org> postgresql-7.2.1-r1.ebuild :
+
+ Fixed user and group additions. Thx to Andy Dustman
+
08 Jul 2002; Ryan Phillips <rphillips@gentoo.org> postgresql-7.2.1-r1.ebuild :
Added creation of user and group
diff --git a/dev-db/postgresql/postgresql-7.2-r3.ebuild b/dev-db/postgresql/postgresql-7.2-r3.ebuild
index 9e6c3707ac0a..e3a09a080622 100644
--- a/dev-db/postgresql/postgresql-7.2-r3.ebuild
+++ b/dev-db/postgresql/postgresql-7.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.2-r3.ebuild,v 1.7 2002/07/11 06:30:19 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.2-r3.ebuild,v 1.8 2002/07/12 16:44:18 rphillips Exp $
S=${WORKDIR}/${P}
DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
@@ -158,7 +158,7 @@ pkg_config() {
echo -n "A postgres data directory already exists from version "; cat /var/lib/postgresql/data/PG_VERSION
echo "Read the documentation to check how to upgrade to version ${PV}."
else
- su - postgres -c "/usr/bin/initdb --pgdata /var/lib/postgresql/data"
+ setuidgid postgres /usr/bin/initdb --pgdata /var/lib/postgresql/data
fi
}
diff --git a/dev-db/postgresql/postgresql-7.2.1-r1.ebuild b/dev-db/postgresql/postgresql-7.2.1-r1.ebuild
index 5baabdccee6b..1b6ad69dafcb 100644
--- a/dev-db/postgresql/postgresql-7.2.1-r1.ebuild
+++ b/dev-db/postgresql/postgresql-7.2.1-r1.ebuild
@@ -1,6 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# /space/gentoo/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.2.1.ebuild,v 1.2 2002/06/17 04:05:39 rphillips Exp
+# Author Geert Bevin <gbevin@theleaf.be>
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.2.1-r1.ebuild,v 1.7 2002/07/12 16:44:18 rphillips Exp $
S=${WORKDIR}/${P}
DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
@@ -9,6 +10,7 @@ HOMEPAGE="http://www.postgresql.org"
LICENSE="POSTGRESQL"
DEPEND="virtual/glibc
+ >=sys-apps/daemontools-0.76-r1
sys-devel/autoconf
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
@@ -21,6 +23,7 @@ DEPEND="virtual/glibc
nls? ( sys-devel/gettext )"
RDEPEND="virtual/glibc
+ >=sys-apps/daemontools-0.76-r1
>=sys-libs/zlib-1.1.3
tcltk? ( >=dev-lang/tcl-8 )
perl? ( >=sys-devel/perl-5.6.1-r2 )
@@ -103,11 +106,11 @@ src_compile() {
}
pkg_preinst() {
- if ! groupmod postgresql ; then
+ if ! groupmod postgres ; then
groupadd -g 70 postgres || die "problem adding group postgres"
fi
- if ! id postgresql; then
+ if ! id postgres; then
useradd -g postgres -s /dev/null -d /var/lib/postgresql -c "postgres" postgres
assert "problem adding user postgres"
fi
@@ -168,7 +171,7 @@ pkg_config() {
echo -n "A postgres data directory already exists from version "; cat /var/lib/postgresql/data/PG_VERSION
echo "Read the documentation to check how to upgrade to version ${PV}."
else
- su - postgres -c "/usr/bin/initdb --pgdata /var/lib/postgresql/data"
+ setuidgid postgres /usr/bin/initdb --pgdata /var/lib/postgresql/data
fi
}