summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2012-06-07 15:40:51 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2012-06-07 15:40:51 +0000
commitff85b1fd95defc0970cdc6a0bdf83ee1d7f4a098 (patch)
treeade04b403b5820421f2d364db34cc420c700cb6a /dev-db
parentsci-chemistry/scala: Drop old (diff)
downloadgentoo-2-ff85b1fd95defc0970cdc6a0bdf83ee1d7f4a098.tar.gz
gentoo-2-ff85b1fd95defc0970cdc6a0bdf83ee1d7f4a098.tar.bz2
gentoo-2-ff85b1fd95defc0970cdc6a0bdf83ee1d7f4a098.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgadmin3/ChangeLog8
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.14.3.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-db/pgadmin3/ChangeLog b/dev-db/pgadmin3/ChangeLog
index 280650575afd..cf1ca08d34d3 100644
--- a/dev-db/pgadmin3/ChangeLog
+++ b/dev-db/pgadmin3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/pgadmin3
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.82 2012/04/19 18:46:10 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.83 2012/06/07 15:40:51 titanofold Exp $
+
+*pgadmin3-1.14.3 (07 Jun 2012)
+
+ 07 Jun 2012; Aaron W. Swenson <titanofold@gentoo.org>
+ +pgadmin3-1.14.3.ebuild:
+ Version bump.
19 Apr 2012; Aaron W. Swenson <titanofold@gentoo.org>
-pgadmin3-1.12.2.ebuild, -pgadmin3-1.12.3.ebuild, -pgadmin3-1.12.3-r1.ebuild,
diff --git a/dev-db/pgadmin3/pgadmin3-1.14.3.ebuild b/dev-db/pgadmin3/pgadmin3-1.14.3.ebuild
new file mode 100644
index 000000000000..f47999f89623
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.14.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.14.3.ebuild,v 1.1 2012/06/07 15:40:51 titanofold Exp $
+
+EAPI="4"
+
+WX_GTK_VER="2.8"
+
+inherit multilib versionator wxwidgets
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="x11-libs/wxGTK:2.8[X,debug=]
+ >=dev-db/postgresql-base-8.4.0
+ >=dev-libs/libxml2-2.6.18
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ local pgslot=$(postgresql-config show)
+
+ if [[ ${pgslot//.} < 84 ]] ; then
+ eerror "PostgreSQL slot must be set to 8.4 or higher."
+ eerror " postgresql-config set 8.4"
+ die "PostgreSQL slot is not set to 8.4 or higher."
+ fi
+}
+
+src_configure() {
+ econf --with-wx-version=2.8 \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
+
+ # icon location for the desktop file provided in pkg folder
+ insinto /usr/share/pgadmin3
+ doins "${S}/pgadmin/include/images/pgAdmin3.png"
+
+ domenu "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ fperms -R go-w /usr/share
+}