summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Tindal <urilith@gentoo.org>2005-06-21 23:43:27 +0000
committerMichael Tindal <urilith@gentoo.org>2005-06-21 23:43:27 +0000
commitee9c0923b957a06273318dfef83f8abd69e37fa3 (patch)
tree523626c4fb5d257cfa118ebb58a5670328dd2af2 /dev-dotnet/ml-pnet/ml-pnet-0.7.0.ebuild
parentFixed SRC_URI. Corrected symlink installation. (diff)
downloadgentoo-2-ee9c0923b957a06273318dfef83f8abd69e37fa3.tar.gz
gentoo-2-ee9c0923b957a06273318dfef83f8abd69e37fa3.tar.bz2
gentoo-2-ee9c0923b957a06273318dfef83f8abd69e37fa3.zip
Version bump.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-dotnet/ml-pnet/ml-pnet-0.7.0.ebuild')
-rw-r--r--dev-dotnet/ml-pnet/ml-pnet-0.7.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-dotnet/ml-pnet/ml-pnet-0.7.0.ebuild b/dev-dotnet/ml-pnet/ml-pnet-0.7.0.ebuild
new file mode 100644
index 000000000000..fc2b0afb53bc
--- /dev/null
+++ b/dev-dotnet/ml-pnet/ml-pnet-0.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ml-pnet/ml-pnet-0.7.0.ebuild,v 1.1 2005/06/21 23:43:27 urilith Exp $
+
+DESCRIPTION="Mono C# libraries for Portable.NET"
+HOMEPAGE="http://www.dotgnu.org/"
+#SRC_URI="mirror://gnu/dotgnu/pnet/${P}.tar.gz"
+SRC_URI="http://www.southern-storm.com.au/download/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 X11 )"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~ppc64 ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64"
+IUSE=""
+
+DEPEND="=dev-dotnet/pnetlib-${PV}*"
+
+src_compile() {
+ local lib_profile="framework1.1"
+ einfo "Using profile: ${lib_profile}"
+
+ econf --with-profile=${lib_profile} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}