summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-05-24 14:25:52 +0000
committerMichał Górny <mgorny@gentoo.org>2013-05-24 14:25:52 +0000
commitd81c4f079fc4b0c95f9f3186cbc7ff8f93889190 (patch)
tree9c61809fadb7999eb3c662f388b04ed77c0f5559 /dev-dotnet
parentdescribe ffhash in fftools use exapnd (diff)
downloadgentoo-2-d81c4f079fc4b0c95f9f3186cbc7ff8f93889190.tar.gz
gentoo-2-d81c4f079fc4b0c95f9f3186cbc7ff8f93889190.tar.bz2
gentoo-2-d81c4f079fc4b0c95f9f3186cbc7ff8f93889190.zip
Version bump. The new version fixes permissions on handler config file.
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/pe-format/ChangeLog9
-rw-r--r--dev-dotnet/pe-format/pe-format-2.1.2.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-dotnet/pe-format/ChangeLog b/dev-dotnet/pe-format/ChangeLog
index c000e6680afe..e06235ebcb7d 100644
--- a/dev-dotnet/pe-format/ChangeLog
+++ b/dev-dotnet/pe-format/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/pe-format
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/ChangeLog,v 1.41 2012/12/15 12:55:53 mgorny Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/ChangeLog,v 1.42 2013/05/24 14:25:52 mgorny Exp $
+
+*pe-format-2.1.2 (24 May 2013)
+
+ 24 May 2013; Michał Górny <mgorny@gentoo.org> +pe-format-2.1.2.ebuild:
+ Version bump. The new version fixes permissions on handler config file.
*pe-format-2.9999 (15 Dec 2012)
diff --git a/dev-dotnet/pe-format/pe-format-2.1.2.ebuild b/dev-dotnet/pe-format/pe-format-2.1.2.ebuild
new file mode 100644
index 000000000000..07d677f7eb28
--- /dev/null
+++ b/dev-dotnet/pe-format/pe-format-2.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/pe-format-2.1.2.ebuild,v 1.1 2013/05/24 14:25:52 mgorny Exp $
+
+EAPI=4
+
+inherit autotools-utils fdo-mime systemd
+
+DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
+HOMEPAGE="https://bitbucket.org/mgorny/pe-format2/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}2/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/openrc-0.9.4"
+
+src_configure() {
+ systemd_to_myeconfargs
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ keepdir /var/lib
+}
+
+pkg_postinst() {
+ ebegin "Calling pe-format2-setup to update handler setup"
+ pe-format2-setup
+ eend ${?}
+
+ fdo-mime_desktop_database_update
+}