summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-10-20 09:51:33 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-10-20 09:51:33 +0000
commit9dc5a61cd5a726b44c19fcba3dc2462cf4e2aa47 (patch)
tree9ce0ac256fdd99298ead6683eb0a015202a9314a /dev-embedded
parentinitial commit, package is still broken, needs more tcl/gcc3.3 fixes (diff)
downloadgentoo-2-9dc5a61cd5a726b44c19fcba3dc2462cf4e2aa47.tar.gz
gentoo-2-9dc5a61cd5a726b44c19fcba3dc2462cf4e2aa47.tar.bz2
gentoo-2-9dc5a61cd5a726b44c19fcba3dc2462cf4e2aa47.zip
initial commit, package is still broken, needs more tcl/gcc3.3 fixes
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/picptk/ChangeLog10
-rw-r--r--dev-embedded/picptk/Manifest5
-rw-r--r--dev-embedded/picptk/files/digest-picptk-0.5a1
-rw-r--r--dev-embedded/picptk/files/picptk-0.5a-headerfix.patch363
-rw-r--r--dev-embedded/picptk/metadata.xml5
-rw-r--r--dev-embedded/picptk/picptk-0.5a.ebuild41
6 files changed, 424 insertions, 1 deletions
diff --git a/dev-embedded/picptk/ChangeLog b/dev-embedded/picptk/ChangeLog
new file mode 100644
index 000000000000..bc9fa80a9b24
--- /dev/null
+++ b/dev-embedded/picptk/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-embedded/picptk
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/picptk/ChangeLog,v 1.1 2003/10/20 09:51:31 robbat2 Exp $
+
+*picptk-0.5a (20 Oct 2003)
+
+ 20 Oct 2003; Robin H. Johnson <robbat2@gentoo.org> metadata.xml,
+ picptk-0.5a.ebuild, files/picptk-0.5a-headerfix.patch:
+ initial commit, package is still broken, needs more tcl/gcc3.3 fixes
+
diff --git a/dev-embedded/picptk/Manifest b/dev-embedded/picptk/Manifest
index c671f15ee092..fd939609596d 100644
--- a/dev-embedded/picptk/Manifest
+++ b/dev-embedded/picptk/Manifest
@@ -1,2 +1,5 @@
-MD5 d88ea26a46ade5ef679f52a2139b9287 picptk-0.5a.ebuild 639
+MD5 00699ad7f5755b6d11ddd3d58e6f847c picptk-0.5a.ebuild 1137
+MD5 82c6d702361771c587544d04b80ccb73 ChangeLog 444
+MD5 420df847a3db1c4969aff20243f656dd metadata.xml 165
+MD5 68d9a1dd472341c4c938e9e16d3f8680 files/picptk-0.5a-headerfix.patch 12453
MD5 39715da9bc8affddf1c77a6e68f4f65c files/digest-picptk-0.5a 62
diff --git a/dev-embedded/picptk/files/digest-picptk-0.5a b/dev-embedded/picptk/files/digest-picptk-0.5a
new file mode 100644
index 000000000000..f918576222cd
--- /dev/null
+++ b/dev-embedded/picptk/files/digest-picptk-0.5a
@@ -0,0 +1 @@
+MD5 11b15476968c952573121ee0891f9488 picptk-0.5a.tar.gz 66629
diff --git a/dev-embedded/picptk/files/picptk-0.5a-headerfix.patch b/dev-embedded/picptk/files/picptk-0.5a-headerfix.patch
new file mode 100644
index 000000000000..3ad3c7df3e3c
--- /dev/null
+++ b/dev-embedded/picptk/files/picptk-0.5a-headerfix.patch
@@ -0,0 +1,363 @@
+diff -urbB picptk-0.5a.old/IfParPort.C picptk-0.5a/IfParPort.C
+--- picptk-0.5a.old/IfParPort.C 1998-12-30 17:40:31.000000000 -0800
++++ picptk-0.5a/IfParPort.C 2003-10-20 02:42:14.000000000 -0700
+@@ -27,6 +27,9 @@
+ * Byte wide transfers GetByte()
+ * Support bidiriectional pins
+ */
++
++using namespace std;
++
+ #include <IfParPort.h>
+ #include <stdio.h>
+ #include <unistd.h>
+@@ -72,7 +75,8 @@
+ { out, 1, 2, 0x08 }, /* pin 17 (out) !SI */
+ { nc, 0, 1, 0x00 }, /* pin 18 GND */
+ };
+- cPinInfo = pinfo;
++ //cPinInfo = pinfo;
++ for(uint i = 0; i < kMaxPins; i++) cPinInfo[i] = pinfo[i];
+ if(port >= kMaxPorts)
+ throw("Bad printer port number");
+ cPort = ports[port];
+diff -urbB picptk-0.5a.old/IfParPort.h picptk-0.5a/IfParPort.h
+--- picptk-0.5a.old/IfParPort.h 1998-12-30 17:40:31.000000000 -0800
++++ picptk-0.5a/IfParPort.h 2003-10-20 02:42:14.000000000 -0700
+@@ -32,6 +32,7 @@
+ #ifndef _ParPort_h_
+ #define _ParPort_h_
+
++using namespace std;
+ #include <stdlib.h> // for uint
+ #include <UtEnvLite.h>
+
+@@ -45,12 +46,14 @@
+ uint cState[kPortSize]; // in bytes...
+
+ typedef enum { nc, in, out, } Dir_t;
+- struct PinInfo_t {
++ typedef struct PinInfo_t {
+ Dir_t dir;
+ char sense;
+ char offset;
+ char mask;
+- } cPinInfo[kMaxPins];
++ };
++
++ PinInfo_t cPinInfo[kMaxPins];
+
+
+ // Gain access to parallel port, return 0 on success...
+diff -urbB picptk-0.5a.old/IoIntel.C picptk-0.5a/IoIntel.C
+--- picptk-0.5a.old/IoIntel.C 1998-12-30 17:40:32.000000000 -0800
++++ picptk-0.5a/IoIntel.C 2003-10-20 02:42:14.000000000 -0700
+@@ -22,6 +22,7 @@
+ * Intel Hex file I/O formatting and such...
+ *
+ */
++using namespace std;
+ #include <IoIntel.h>
+ #include <stdio.h> // for sscanf
+ // ParseLine(...) - parse one line of Intel Hex8 format
+@@ -65,7 +66,7 @@
+ // If length is zero, writes end of file marker...
+ // This should be smarter about supressing zeros, maybe?
+ bool
+-IntelHex::OutputLine(ostream &os, int len, uint addr = 0, char *buffer = 0) {
++IntelHex::OutputLine(ostream &os, int len, uint addr, char *buffer) {
+ char line[200];
+ int sum = 0;
+ int type = (len) ? 0 : 1;
+diff -urbB picptk-0.5a.old/IoIntel.h picptk-0.5a/IoIntel.h
+--- picptk-0.5a.old/IoIntel.h 1998-12-30 17:40:32.000000000 -0800
++++ picptk-0.5a/IoIntel.h 2003-10-20 02:43:00.000000000 -0700
+@@ -24,10 +24,11 @@
+
+ #ifndef IntelHex_h
+ #define IntelHex_h
++using namespace std;
+
+ #include <stdlib.h> // for uint
+-#include <fstream.h>
+-#include <iostream.h>
++#include <fstream>
++#include <iostream>
+
+ // This probably should be more general and read multiple formats...
+ class IntelHex {
+diff -urbB picptk-0.5a.old/Makefile.am picptk-0.5a/Makefile.am
+--- picptk-0.5a.old/Makefile.am 1998-12-30 18:23:05.000000000 -0800
++++ picptk-0.5a/Makefile.am 2003-10-20 02:42:14.000000000 -0700
+@@ -24,7 +24,7 @@
+ .picprc \
+ picptk.itk
+
+-INCLUDES = -I . -I /usr/include/tcl8.0-int/generic/
++INCLUDES = -I. -I/usr/include/tcl8.0-int/generic/ -I/usr/lib/tcl8.3/include/generic -I/usr/lib/tcl8.4/include/generic
+
+ ##dnl info_TEXINFOS = picptk.texi
+
+diff -urbB picptk-0.5a.old/PicCore.C picptk-0.5a/PicCore.C
+--- picptk-0.5a.old/PicCore.C 1998-12-30 17:40:32.000000000 -0800
++++ picptk-0.5a/PicCore.C 2003-10-20 02:42:14.000000000 -0700
+@@ -19,6 +19,7 @@
+ *
+ * $Id: picptk-0.5a-headerfix.patch,v 1.1 2003/10/20 09:51:31 robbat2 Exp $
+ */
++using namespace std;
+ #include <PicCore.h>
+ #include <IoIntel.h>
+ #include <string.h> // for strcat()
+@@ -504,7 +505,7 @@
+ SetPin(pin_do, 0);
+ }
+ // SetPin() - Hook to the driver's set pin...
+-void Pic::SetPin(Pin_t pin, int val = 1) {
++void Pic::SetPin(Pin_t pin, int val) {
+ if(!cDriver) throw (cDriver); // Get the hint?
+ cDriver->SetPin(pin, val);
+ }
+diff -urbB picptk-0.5a.old/PicCore.h picptk-0.5a/PicCore.h
+--- picptk-0.5a.old/PicCore.h 1998-12-30 17:40:32.000000000 -0800
++++ picptk-0.5a/PicCore.h 2003-10-20 02:43:17.000000000 -0700
+@@ -21,8 +21,9 @@
+ */
+ #ifndef Pic_h
+ #define Pic_h
++using namespace std;
+
+-#include <fstream.h>
++#include <fstream>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <UtEnvLite.h> // for Environment
+@@ -130,7 +131,7 @@
+ int VerifySegment(Segment &seg, ProgressCb_t cb=0, void *arg=0);
+ int EraseSegment (Segment &seg, ProgressCb_t cb=0, void *arg=0);
+ int InitSegment (Segment &seg, ProgressCb_t cb=0, void *arg=0) { seg.Init(); return(0); }
+- int DumpSegment (Segment &seg, ProgressCb_t cb=0, void *arg=0) { seg.Dump((ostream &)*arg); return(0); }
++ int DumpSegment (Segment &seg, ProgressCb_t cb=0, void *arg=0) { seg.Dump((ostream &)arg); return(0); }
+ int BlankCheckSegment (Segment &seg, ProgressCb_t cb=0, void *arg=0);
+
+ // Set/Get based on Pin name
+@@ -149,13 +150,13 @@
+ const char *GetPref(const char *attr) { return(cEnv.Get(attr)); }
+
+ // Make user functions apply to all segments...
+- int Read (ProgressCb_t cb = 0, void *obj = 0) { return(EachSegment(&ReadSegment, cb, obj)); }
+- int Write (ProgressCb_t cb = 0, void *obj = 0) { return(EachSegment(&WriteSegment, cb, obj)); }
+- int Verify(ProgressCb_t cb = 0, void *obj = 0) { return(EachSegment(&VerifySegment, cb, obj)); }
+- int Erase (ProgressCb_t cb = 0, void *obj = 0) { return(EachSegment(&EraseSegment, cb, obj)); }
+- int DumpRam (ostream &os) { return(EachSegment(&DumpSegment, 0, &os, false)); }
++ int Read (ProgressCb_t cb = 0, void *obj = 0) { return(EachSegment(&Pic::ReadSegment, cb, obj)); }
++ int Write (ProgressCb_t cb = 0, void *obj = 0) { return(EachSegment(&Pic::WriteSegment, cb, obj)); }
++ int Verify(ProgressCb_t cb = 0, void *obj = 0) { return(EachSegment(&Pic::VerifySegment, cb, obj)); }
++ int Erase (ProgressCb_t cb = 0, void *obj = 0) { return(EachSegment(&Pic::EraseSegment, cb, obj)); }
++ int DumpRam (ostream &os) { return(EachSegment(&Pic::DumpSegment, 0, &os, false)); }
+ int LoadRam (const char *file);
+- int InitRam () { return(EachSegment(&InitSegment, 0, 0, false)); }
++ int InitRam () { return(EachSegment(&Pic::InitSegment, 0, 0, false)); }
+
+ // Configuration functions...
+ virtual const char **Chips(); // What chip types we support...
+diff -urbB picptk-0.5a.old/PicDriver.h picptk-0.5a/PicDriver.h
+--- picptk-0.5a.old/PicDriver.h 1998-12-30 17:40:32.000000000 -0800
++++ picptk-0.5a/PicDriver.h 2003-10-20 02:43:19.000000000 -0700
+@@ -25,6 +25,7 @@
+ */
+ #ifndef _PicDriver_h_
+ #define _PicDriver_h_
++using namespace std;
+
+ #include <stdlib.h> // for uint
+ #include <termios.h> // for serial port support
+diff -urbB picptk-0.5a.old/PicMem.h picptk-0.5a/PicMem.h
+--- picptk-0.5a.old/PicMem.h 1998-12-30 17:40:32.000000000 -0800
++++ picptk-0.5a/PicMem.h 2003-10-20 02:43:22.000000000 -0700
+@@ -21,9 +21,10 @@
+ */
+ #ifndef Segment_h
+ #define Segment_h
++using namespace std;
+
+ #include <stdlib.h> // for uint
+-#include <iostream.h>
++#include <iostream>
+ #include <stdio.h> // for sprintf()
+ #include <string.h> // for strcat()
+
+diff -urbB picptk-0.5a.old/PicParallel.C picptk-0.5a/PicParallel.C
+--- picptk-0.5a.old/PicParallel.C 1998-12-30 17:40:32.000000000 -0800
++++ picptk-0.5a/PicParallel.C 2003-10-20 02:42:14.000000000 -0700
+@@ -27,6 +27,7 @@
+ * into actions...
+ */
+
++using namespace std;
+ #include <PicParallel.h>
+ #include <unistd.h> // for open(), close(), ...
+
+@@ -82,7 +83,7 @@
+ }
+
+ // Set specified pin...
+-void ParallelDriver::SetPin(Pic::Pin_t pin, int val = 1) {
++void ParallelDriver::SetPin(Pic::Pin_t pin, int val) {
+ int pinnum = cPinMap[pin];
+ if(pinnum < 0) cPort->SetPin(-pinnum, val^1);
+ else cPort->SetPin(pinnum, val);
+diff -urbB picptk-0.5a.old/PicParallel.h picptk-0.5a/PicParallel.h
+--- picptk-0.5a.old/PicParallel.h 1998-12-30 17:40:32.000000000 -0800
++++ picptk-0.5a/PicParallel.h 2003-10-20 02:43:24.000000000 -0700
+@@ -26,6 +26,7 @@
+ */
+ #ifndef _PicParallel_h_
+ #define _PicParallel_h_
++using namespace std;
+
+ #include <PicDriver.h>
+ #include <IfParPort.h>
+diff -urbB picptk-0.5a.old/PicPersonality.C picptk-0.5a/PicPersonality.C
+--- picptk-0.5a.old/PicPersonality.C 1998-12-30 17:40:33.000000000 -0800
++++ picptk-0.5a/PicPersonality.C 2003-10-20 02:42:14.000000000 -0700
+@@ -24,6 +24,7 @@
+ * ToDo:
+ * Place this information in a config file rather than in code...
+ */
++using namespace std;
+ #include <PicCore.h>
+
+ // Pic::cAllPics - Description of all supported Pic members
+diff -urbB picptk-0.5a.old/PicSerial.C picptk-0.5a/PicSerial.C
+--- picptk-0.5a.old/PicSerial.C 1998-12-30 17:40:33.000000000 -0800
++++ picptk-0.5a/PicSerial.C 2003-10-20 02:42:14.000000000 -0700
+@@ -34,6 +34,7 @@
+ * and they need a non-standard tty driver to hold TX low indefinately.
+ * The driver appears to be a seperate kernel patch...
+ */
++using namespace std;
+
+ #include <PicSerial.h>
+ #include <unistd.h> // for open(), close(), ...
+@@ -54,18 +55,18 @@
+ SerialDriver::SerialDriver(Environment &env) : Driver(env) {
+
+ #ifndef TIOCCBRK
+- throw("No TIOCCBRK ioctl?!
+-You probably can't use a serial port
+-programmer unless you install a kernel
++ throw("No TIOCCBRK ioctl?!\n\
++You probably can't use a serial port\n\
++programmer unless you install a kernel\n\
+ patch.");
+
+ // That'll get user's attention, now let compile it anyway...
+ #define TIOCCBRK 0
+ #endif
+ #ifndef TIOSCBRK
+- throw("No TIOCCBRK ioctl?!
+-You probably can't use a serial port
+-programmer unless you install a kernel
++ throw("No TIOCCBRK ioctl?!\n\
++You probably can't use a serial port\n\
++programmer unless you install a kernel\n\
+ patch.");
+ #define TIOSCBRK 0
+ #endif // TIOSCBRK
+@@ -94,7 +95,7 @@
+ }
+
+ // Set specified pin...
+-void SerialDriver::SetPin(Pic::Pin_t pin, int val = 1) {
++void SerialDriver::SetPin(Pic::Pin_t pin, int val) {
+ int tmp;
+ val &= 1;
+ switch(pin) {
+diff -urbB picptk-0.5a.old/PicSerial.h picptk-0.5a/PicSerial.h
+--- picptk-0.5a.old/PicSerial.h 1998-12-30 17:40:33.000000000 -0800
++++ picptk-0.5a/PicSerial.h 2003-10-20 02:43:25.000000000 -0700
+@@ -26,6 +26,7 @@
+ */
+ #ifndef _PicSerial_h_
+ #define _PicSerial_h_
++using namespace std;
+
+ #include <PicDriver.h>
+ /* Serial port programmer...
+diff -urbB picptk-0.5a.old/UiItk.C picptk-0.5a/UiItk.C
+--- picptk-0.5a.old/UiItk.C 1998-12-31 08:33:53.000000000 -0800
++++ picptk-0.5a/UiItk.C 2003-10-20 02:42:50.000000000 -0700
+@@ -27,6 +27,7 @@
+ * a the need...)
+ *
+ */
++using namespace std;
+
+ #include <UiItk.h>
+
+@@ -34,7 +35,7 @@
+ #include <itk.h>
+ #endif
+
+-#include <strstream.h> // for ostrstream
++#include <strstream> // for ostrstream
+
+
+ /* Gui dispatch table for TCL commands...
+diff -urbB picptk-0.5a.old/UiItk.h picptk-0.5a/UiItk.h
+--- picptk-0.5a.old/UiItk.h 1998-12-30 17:40:33.000000000 -0800
++++ picptk-0.5a/UiItk.h 2003-10-20 02:43:27.000000000 -0700
+@@ -30,6 +30,7 @@
+
+ // Even though the interface may be incrTk,
+ // <tk.h> contains what we need here...
++using namespace std;
+ #include <tk.h>
+ #include <PicCore.h>
+
+diff -urbB picptk-0.5a.old/UtEnvLite.h picptk-0.5a/UtEnvLite.h
+--- picptk-0.5a.old/UtEnvLite.h 1998-12-30 17:40:33.000000000 -0800
++++ picptk-0.5a/UtEnvLite.h 2003-10-20 02:43:31.000000000 -0700
+@@ -27,8 +27,9 @@
+ */
+ #ifndef _Environment_h_
+ #define _Environment_h_
++using namespace std;
+
+-#include <fstream.h>
++#include <fstream>
+ #include <stdio.h>
+ #include <stdlib.h>
+
+diff -urbB picptk-0.5a.old/UtRealTime.h picptk-0.5a/UtRealTime.h
+--- picptk-0.5a.old/UtRealTime.h 1998-12-30 17:40:33.000000000 -0800
++++ picptk-0.5a/UtRealTime.h 2003-10-20 02:43:33.000000000 -0700
+@@ -25,6 +25,7 @@
+
+ #ifndef RealTime_h
+ #define RealTime_h
++using namespace std;
+
+ #include <time.h> // for uint
+ #include <sched.h> // for sched_setscheduler()
+diff -urbB picptk-0.5a.old/configure.in picptk-0.5a/configure.in
+--- picptk-0.5a.old/configure.in 1998-12-31 08:46:54.000000000 -0800
++++ picptk-0.5a/configure.in 2003-10-20 02:42:14.000000000 -0700
+@@ -7,12 +7,12 @@
+ AC_PROG_INSTALL
+
+ dnl Checks for libraries.
+-AC_CHECK_LIB(itk3.0, Itk_Init)
+-AC_CHECK_LIB(itk3.0, Itk_Init, cp picptk.itk picptk, cp picptk.tcl picptk)
++AC_CHECK_LIB(itk3.2, Itk_Init)
++AC_CHECK_LIB(itk3.2, Itk_Init, cp picptk.itk picptk, cp picptk.tcl picptk)
+
+ dnl The following isn't totally true, but let's force the issue...
+-AC_CHECK_LIB(itk3.0, Itk_Init,,AC_MSG_ERROR([
+-**** picptk now requires itcl3.0
++AC_CHECK_LIB(itk3.2, Itk_Init,,AC_MSG_ERROR([
++**** picptk now requires itcl3.2
+ **** See the README file for more info.
+ ]))
+
diff --git a/dev-embedded/picptk/metadata.xml b/dev-embedded/picptk/metadata.xml
new file mode 100644
index 000000000000..92114080841c
--- /dev/null
+++ b/dev-embedded/picptk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-embedded</herd>
+</pkgmetadata>
diff --git a/dev-embedded/picptk/picptk-0.5a.ebuild b/dev-embedded/picptk/picptk-0.5a.ebuild
new file mode 100644
index 000000000000..9087937d479a
--- /dev/null
+++ b/dev-embedded/picptk/picptk-0.5a.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/picptk/picptk-0.5a.ebuild,v 1.1 2003/10/20 09:51:31 robbat2 Exp $
+
+#this is for autoconf
+inherit kde-functions
+
+DESCRIPTION="Picptk is a programmer supporting the whole PIC family including all memory types (EEPROM, EPROM, and OTP)"
+HOMEPAGE="http://huizen.dds.nl/~gnupic/programmers_mike_butler.html"
+# http://huizen.dds.nl/~gnupic/picptk-0.5a.tar.gz
+SRC_URI="http://huizen.dds.nl/~gnupic/picptk-0.5a.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+RDEPEND="dev-tcltk/itcl"
+DEPEND="${RDEPEND} sys-devel/gcc sys-devel/automake sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-headerfix.patch
+ cd ${S}
+ need-autoconf 2.1
+ automake
+ autoconf
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ #dobin picprog
+ #dodoc README #jdm*.png adapter.jpg
+ #dohtml picprog.html *.jpg *.png
+ #doman picprog.1
+ einstall || die "einstall failed"
+ dodoc AUTHORS NEWS README TODO
+ newdoc .picprc sample.picprc
+}