summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-11 15:08:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-11 15:08:10 +0000
commitf85970cdd7addfba5140f5e5b42163b361b7be57 (patch)
tree7529bcdf823941695b4576c2d160664d073966fe /dev-games/openscenegraph
parentMarked ~ppc for bug #300776. (diff)
downloadgentoo-2-f85970cdd7addfba5140f5e5b42163b361b7be57.tar.gz
gentoo-2-f85970cdd7addfba5140f5e5b42163b361b7be57.tar.bz2
gentoo-2-f85970cdd7addfba5140f5e5b42163b361b7be57.zip
Fix building with libpng14 wrt #307695 by Lars Wendler.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-games/openscenegraph')
-rw-r--r--dev-games/openscenegraph/ChangeLog6
-rw-r--r--dev-games/openscenegraph/files/openscenegraph-2.8.2-libpng14.patch22
-rw-r--r--dev-games/openscenegraph/openscenegraph-2.8.2.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/dev-games/openscenegraph/ChangeLog b/dev-games/openscenegraph/ChangeLog
index 79e1fcb5e25e..8ff69a350c1d 100644
--- a/dev-games/openscenegraph/ChangeLog
+++ b/dev-games/openscenegraph/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/openscenegraph
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/ChangeLog,v 1.21 2010/02/10 14:10:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/ChangeLog,v 1.22 2010/03/11 15:08:10 ssuominen Exp $
+
+ 11 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ openscenegraph-2.8.2.ebuild, +files/openscenegraph-2.8.2-libpng14.patch:
+ Fix building with libpng14 wrt #307695 by Lars Wendler.
10 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
openscenegraph-2.8.2.ebuild:
diff --git a/dev-games/openscenegraph/files/openscenegraph-2.8.2-libpng14.patch b/dev-games/openscenegraph/files/openscenegraph-2.8.2-libpng14.patch
new file mode 100644
index 000000000000..98b90dbaa206
--- /dev/null
+++ b/dev-games/openscenegraph/files/openscenegraph-2.8.2-libpng14.patch
@@ -0,0 +1,22 @@
+http://repos.archlinux.org/wsvn/community/openscenegraph/trunk/libpng14
+
+--- src/osgPlugins/png/ReaderWriterPNG.cpp
++++ src/osgPlugins/png/ReaderWriterPNG.cpp
+@@ -173,7 +173,7 @@ class ReaderWriterPNG : public osgDB::Re
+ endinfo = png_create_info_struct(png);
+
+ fin.read((char*)header,8);
+- if (fin.gcount() == 8 && png_check_sig(header, 8))
++ if (fin.gcount() == 8 && !png_sig_cmp(header, 0, 8))
+ png_set_read_fn(png,&fin,png_read_istream); //Use custom read function that will get data from istream
+ else
+ {
+@@ -224,7 +224,7 @@ class ReaderWriterPNG : public osgDB::Re
+ if (color == PNG_COLOR_TYPE_PALETTE)
+ png_set_palette_to_rgb(png);
+ if (color == PNG_COLOR_TYPE_GRAY && depth < 8)
+- png_set_gray_1_2_4_to_8(png);
++ png_set_expand_gray_1_2_4_to_8(png);
+ if (png_get_valid(png, info, PNG_INFO_tRNS))
+ png_set_tRNS_to_alpha(png);
+
diff --git a/dev-games/openscenegraph/openscenegraph-2.8.2.ebuild b/dev-games/openscenegraph/openscenegraph-2.8.2.ebuild
index ed8d96104bc9..c030a321bba0 100644
--- a/dev-games/openscenegraph/openscenegraph-2.8.2.ebuild
+++ b/dev-games/openscenegraph/openscenegraph-2.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/openscenegraph-2.8.2.ebuild,v 1.8 2010/02/10 14:10:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/openscenegraph-2.8.2.ebuild,v 1.9 2010/03/11 15:08:10 ssuominen Exp $
EAPI=2
inherit eutils versionator base cmake-utils
@@ -43,6 +43,7 @@ DOCS="AUTHORS.txt ChangeLog NEWS.txt"
PATCHES=(
"${FILESDIR}"/${P}-magicoff.patch
+ "${FILESDIR}"/${P}-libpng14.patch
)
src_configure() {