summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-09-25 11:44:48 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-09-25 11:44:48 +0000
commit040b4febbeb47c2af1af46b899eb77e32d5e3bdb (patch)
treeb6771671efd2133605e547f0b616dbf648c84465 /dev-games
parentDrop old (diff)
downloadgentoo-2-040b4febbeb47c2af1af46b899eb77e32d5e3bdb.tar.gz
gentoo-2-040b4febbeb47c2af1af46b899eb77e32d5e3bdb.tar.bz2
gentoo-2-040b4febbeb47c2af1af46b899eb77e32d5e3bdb.zip
Version bump to 2.3.6.
Adding required_use. Bug #425696 (Portage version: 2.1.11.21/cvs/Linux i686)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/clanlib/ChangeLog11
-rw-r--r--dev-games/clanlib/clanlib-2.3.6.ebuild90
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.6-autotools.patch45
3 files changed, 144 insertions, 2 deletions
diff --git a/dev-games/clanlib/ChangeLog b/dev-games/clanlib/ChangeLog
index a38a11c511d7..1b24ea55e9e6 100644
--- a/dev-games/clanlib/ChangeLog
+++ b/dev-games/clanlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-games/clanlib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.56 2012/08/03 12:47:39 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.57 2012/09/25 11:44:48 tupone Exp $
+
+*clanlib-2.3.6 (25 Sep 2012)
+
+ 25 Sep 2012; Tupone Alfredo <tupone@gentoo.org> +clanlib-2.3.6.ebuild,
+ +files/clanlib-2.3.6-autotools.patch:
+ Version bump to 2.3.6.
+ Adding required_use. Bug #425696 by Diego
03 Aug 2012; Markos Chandras <hwoarang@gentoo.org> clanlib-2.3.4.ebuild:
Stable on amd64 wrt bug #418677
@@ -24,7 +31,7 @@
06 Feb 2012; Tupone Alfredo <tupone@gentoo.org> +clanlib-2.3.4.ebuild,
+files/clanlib-2.3.4-autotools.patch:
- Version bump to 2.4.3 Bug #288218 by proDOOMman
+ Version bump to 2.3.4 Bug #288218 by proDOOMman
15 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> clanlib-0.8.1.ebuild,
+files/clanlib-0.8.1-libpng15.patch:
diff --git a/dev-games/clanlib/clanlib-2.3.6.ebuild b/dev-games/clanlib/clanlib-2.3.6.ebuild
new file mode 100644
index 000000000000..5242b0a2fd68
--- /dev/null
+++ b/dev-games/clanlib/clanlib-2.3.6.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-2.3.6.ebuild,v 1.1 2012/09/25 11:44:48 tupone Exp $
+
+EAPI=4
+inherit flag-o-matic eutils autotools-utils
+
+MY_P=ClanLib-${PV}
+
+DESCRIPTION="multi-platform game development library"
+HOMEPAGE="http://www.clanlib.org/"
+SRC_URI="http://clanlib.org/download/releases-2.0/${MY_P}.tgz"
+
+LICENSE="ZLIB"
+SLOT="2.3"
+KEYWORDS="~amd64 ~x86" #not big endian safe #82779
+IUSE="doc ipv6 mikmod opengl sound sqlite sse2 static-libs vorbis X"
+REQUIRED_USE="opengl? ( X )"
+
+RDEPEND="sys-libs/zlib
+ X? (
+ media-libs/libpng
+ virtual/jpeg
+ media-libs/freetype
+ media-libs/fontconfig
+ opengl? ( virtual/opengl )
+ app-arch/bzip2
+ x11-libs/libX11
+ )
+ sqlite? ( dev-db/sqlite )
+ sound? ( media-libs/alsa-lib )
+ mikmod? (
+ media-libs/libmikmod
+ media-libs/alsa-lib
+ )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/alsa-lib
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen dev-lang/perl )"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+DOCS=(
+ CODING_STYLE
+ CREDITS
+ PATCHES
+ README
+)
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable doc docs)
+ $(use_enable sse2)
+ $(use_enable opengl clanGL)
+ $(use_enable opengl clanGL1)
+ $(use_enable opengl clanGUI)
+ $(use_enable X clanDisplay)
+ $(use_enable vorbis clanVorbis)
+ $(use_enable mikmod clanMikMod)
+ $(use_enable sqlite clanSqlite)
+ $(use_enable ipv6 getaddr)
+ )
+ use sound \
+ || use vorbis \
+ || use mikmod \
+ || myeconfargs+=( --disable-clanSound )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile html
+}
+
+# html files are keeped in a directory that is dependent on the SLOT
+# so to keep eventual bookmarks to the doc from version to version
+src_install() {
+ autotools-utils_src_install
+ if use doc ; then
+ emake DESTDIR="${D}" install-html
+ dodoc -r Examples Resources
+ fi
+}
diff --git a/dev-games/clanlib/files/clanlib-2.3.6-autotools.patch b/dev-games/clanlib/files/clanlib-2.3.6-autotools.patch
new file mode 100644
index 000000000000..97db79ac4245
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-2.3.6-autotools.patch
@@ -0,0 +1,45 @@
+--- Documentation/Reference/Makefile.am.old 2012-09-25 10:39:25.973544935 +0200
++++ Documentation/Reference/Makefile.am 2012-09-25 10:39:42.560554053 +0200
+@@ -10,7 +10,7 @@
+ mkdir doxyoutput;
+ mkdir reftest
+ doxygen ./clanlib.doxygen
+- make -C ../Utilities/ReferenceDocs
++ $(MAKE) -C ../Utilities/ReferenceDocs
+ ../Utilities/ReferenceDocs/ReferenceDocs
+
+ install-html:
+--- configure.ac.old 2012-09-25 11:07:38.412537590 +0200
++++ configure.ac 2012-09-25 11:09:41.133939131 +0200
+@@ -337,11 +337,9 @@
+
+ dnl Optional linux/joystick.h
+ AC_CHECK_HEADERS(linux/joystick.h, linux_joystick=yes)
+- AM_CONDITIONAL(LINUX_JOYSTICK, test x$linux_joystick = xyes)
+
+ dnl Optional linux/input.h
+ AC_CHECK_HEADERS(linux/input.h, linux_input=yes)
+- AM_CONDITIONAL(LINUX_INPUT, test x$linux_input = xyes)
+
+ if test "$WIN32" = "no" && test "$enable_clanDisplay" != "no"; then
+ CLANLIB_CHECK_LIB(fontconfig, [`cat $srcdir/Setup/Tests/fontconfig.cpp`], clanDisplay, [ *** Cannot find fontconfig (See http://fontconfig.org/ ) (Try libfontconfig1-dev or better) ], [-lfontconfig])
+@@ -358,6 +356,8 @@
+ clanDisplay, [ *** Cannot find version 8 of DirectInput], [-ldxguid -lole32 -ldinput8])
+ fi
+ fi
++AM_CONDITIONAL(LINUX_JOYSTICK, test x$linux_joystick = xyes)
++AM_CONDITIONAL(LINUX_INPUT, test x$linux_input = xyes)
+
+ have_xrender=no
+
+@@ -515,9 +515,9 @@
+ fi
+
+ if test "$enable_clanSound" = "auto"; then enable_clanSound=yes; fi
+- AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
+
+ fi
++AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
+
+ if test "$enable_clanSound" != "no"; then
+ enable_clanSound=yes