summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-25 12:08:38 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-25 12:08:38 +0000
commit90de2a4b281c807db5ac6bbe2c187f42bb891924 (patch)
tree737f1145eba01957b17133658be9abafc0649af5 /dev-games
parentold (diff)
downloadgentoo-2-90de2a4b281c807db5ac6bbe2c187f42bb891924.tar.gz
gentoo-2-90de2a4b281c807db5ac6bbe2c187f42bb891924.tar.bz2
gentoo-2-90de2a4b281c807db5ac6bbe2c187f42bb891924.zip
touchups & move
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/kyra/ChangeLog14
-rw-r--r--dev-games/kyra/files/digest-kyra-2.0.71
-rw-r--r--dev-games/kyra/kyra-2.0.7.ebuild25
-rw-r--r--dev-games/kyra/metadata.xml43
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-games/kyra/ChangeLog b/dev-games/kyra/ChangeLog
new file mode 100644
index 000000000000..a1f0ad892853
--- /dev/null
+++ b/dev-games/kyra/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for media-libs/kyra
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/kyra/ChangeLog,v 1.1 2003/10/25 12:08:38 vapier Exp $
+
+*kyra-2.0.7 (21 Oct 2003)
+
+ 21 Oct 2003; Michael Sterrett <mr_bones_@gentoo.org> kyra-2.0.7.ebuild:
+ version bump; add more doc support
+
+*kyra-2.0.3 (1 Apr 2003)
+
+ 22 Jan 2003; Philip Walls <malverian@gentoo.org> kyra-2.0.3.ebuild :
+ Initial ebuild; Thanks to Stijn Vander Maelen <stijn@sunshine.rave.org>
+ for ebuild. Closes bug #14334
diff --git a/dev-games/kyra/files/digest-kyra-2.0.7 b/dev-games/kyra/files/digest-kyra-2.0.7
new file mode 100644
index 000000000000..92673ed9c598
--- /dev/null
+++ b/dev-games/kyra/files/digest-kyra-2.0.7
@@ -0,0 +1 @@
+MD5 b86f7a7599cc031df1bbe61031ff97e5 kyra_src_2_0_7.tar.gz 1994743
diff --git a/dev-games/kyra/kyra-2.0.7.ebuild b/dev-games/kyra/kyra-2.0.7.ebuild
new file mode 100644
index 000000000000..8e9c7eff3520
--- /dev/null
+++ b/dev-games/kyra/kyra-2.0.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/kyra/kyra-2.0.7.ebuild,v 1.1 2003/10/25 12:08:38 vapier Exp $
+
+DESCRIPTION="Kyra Sprite Engine"
+HOMEPAGE="http://www.grinninglizard.com/kyra/"
+SRC_URI="mirror://sourceforge/kyra/kyra_src_${PV//./_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="doc"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ einstall || dir
+ #emake install DESTDIR=${D} || die
+ dodoc AUTHORS ChangeLog NEWS README
+ dohtml docs/*
+ [ `use doc` ] && dohtml -r docs/api
+}
diff --git a/dev-games/kyra/metadata.xml b/dev-games/kyra/metadata.xml
new file mode 100644
index 000000000000..7e1d30a1f2c8
--- /dev/null
+++ b/dev-games/kyra/metadata.xml
@@ -0,0 +1,43 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+A Sprite Engine...
+from a Slightly Different Point of View
+
+Kyra is a simple, fully featured, industrial strength Sprite engine written in C++. It is built on
+top of SDL and has been tested on Windows and Linux. It is provided free for open source projects
+under the GPL and LGPL.
+
+What is a Sprite Engine? A Sprite Engine is the drawing and rendering component of 2D and quasi-3D
+games. Examples of this kind of game are Civilization, Donkey Kong (classic arcade), Pharaoh, Zeus,
+Warcraft, Diablo, Frogger, and Pirates!, among many others. It is so called because the "characters"
+or "little men" are referred to as "sprites".
+
+Simple and Easy to Use. Kyra has a clean and simple C++ interface. Or at least as simple as an engine
+can be. It comes with several examples to get you started, as well as full documentation for the API
+and the tool chain.
+
+Fully Featured. It is fully featured, supporting top-down, side, and isometric rendering. It supports
+the 'Sprite' as its basic type, but also supports Tiles and user-drawn Canvases. It can draw to a
+traditional bitmap surface, and supports OpenGL hardware acceleration.
+
+Industrial Strength. Kyra has a complete tool chain including a sprite editor and encoder. It's fast
+and capable, with specialized code for rendering and rectangle updates.
+
+...From a Slightly Different Point of View. But Kyra does some things differently. It supports color
+transformations and alpha blending (!). All objects in Kyra are inserted into a containment
+hierarchy, and children are transformed by their parents. So a complex object can be moved simply by
+changing the coordinates of the top level object, and color transformations and alpha transformations
+work the same way. The alpha blending can be applied at a per-image or per-pixel level.
+
+Objects can be scaled up or down when drawn, or scaling can be pre-cached. The screen can be split
+into sub window views, and each view has its own object transformations.
+
+Use as is. Kyra is currently working and ready for use. You can put it into your programs and start
+using it now. It has been used enough to mature some and be already bug fixed. On the other hand, if
+you're someone who likes to get involved, there are still optimization and feature opportunities in
+the code.
+</longdescription>
+</pkgmetadata>