summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-06-29 03:48:53 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-06-29 03:48:53 +0000
commit3c690e80adf7784edacdb5b00ca2221264137a88 (patch)
tree3dd11205c0fd011b914190b084650dbee48e3763 /dev-go
parentAllow only system-config-printer, not system-config-printer-gnome, to help po... (diff)
downloadgentoo-2-3c690e80adf7784edacdb5b00ca2221264137a88.tar.gz
gentoo-2-3c690e80adf7784edacdb5b00ca2221264137a88.tar.bz2
gentoo-2-3c690e80adf7784edacdb5b00ca2221264137a88.zip
Make live ebuild copyable
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-net/ChangeLog5
-rw-r--r--dev-go/go-net/go-net-9999.ebuild41
2 files changed, 43 insertions, 3 deletions
diff --git a/dev-go/go-net/ChangeLog b/dev-go/go-net/ChangeLog
index e16b83a2ffd9..20786f9a0a36 100644
--- a/dev-go/go-net/ChangeLog
+++ b/dev-go/go-net/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-go/go-net
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v 1.8 2015/06/25 19:24:07 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v 1.9 2015/06/29 03:48:53 williamh Exp $
+
+ 29 Jun 2015; William Hubbs <williamh@gentoo.org> go-net-9999.ebuild:
+ Make live ebuild copyable
25 Jun 2015; William Hubbs <williamh@gentoo.org> go-net-9999.ebuild:
Convert live ebuild to the new eclasses
diff --git a/dev-go/go-net/go-net-9999.ebuild b/dev-go/go-net/go-net-9999.ebuild
index 988e3ca8efda..f5657eec6a23 100644
--- a/dev-go/go-net/go-net-9999.ebuild
+++ b/dev-go/go-net/go-net-9999.ebuild
@@ -1,12 +1,20 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-9999.ebuild,v 1.5 2015/06/25 19:24:07 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-9999.ebuild,v 1.6 2015/06/29 03:48:53 williamh Exp $
EAPI=5
-inherit golang-build golang-vcs
EGO_PN=golang.org/x/net/...
EGO_SRC=golang.org/x/net
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="dfe268fd2bb5c793f4c083803609fce9806c6f80"
+ SRC_URI="https://github.com/golang/net/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+fi
+inherit golang-build
+
DESCRIPTION="Go supplementary network libraries"
HOMEPAGE="https://godoc.org/golang.org/x/net"
LICENSE="BSD"
@@ -15,6 +23,35 @@ IUSE=""
DEPEND="dev-go/go-text"
RDEPEND=""
+if [[ ${PV} != *9999* ]]; then
+src_unpack() {
+ local f
+
+ for f in ${A}
+ do
+ case "${f}" in
+ *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
+ local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
+
+ debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
+
+ # XXX: check whether the directory structure inside is
+ # fine? i.e. if the tarball has actually a parent dir.
+ mkdir -p "${destdir}" || die
+ tar -C "${destdir}" -x --strip-components 1 \
+ -f "${DISTDIR}/${f}" || die
+ ;;
+ *)
+ debug-print "${FUNCNAME}: falling back to unpack for ${f}"
+
+ # fall back to the default method
+ unpack "${f}"
+ ;;
+ esac
+ done
+}
+fi
+
src_prepare() {
# disable broken tests
sed -e 's:TestReadProppatch(:_\0:' \