summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-06-26 19:24:29 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-06-26 19:24:29 +0000
commitd66c5fa50a848b6b14899946f72b0c2c6f8b6cd2 (patch)
tree5478508f92a7f06cf59126f9772ab12eaf4166fe /dev-go
parentVersion bump fixing building (#542822) (diff)
downloadgentoo-2-d66c5fa50a848b6b14899946f72b0c2c6f8b6cd2.tar.gz
gentoo-2-d66c5fa50a848b6b14899946f72b0c2c6f8b6cd2.tar.bz2
gentoo-2-d66c5fa50a848b6b14899946f72b0c2c6f8b6cd2.zip
Make live ebuild copyable as future snapshots
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-tools/ChangeLog5
-rw-r--r--dev-go/go-tools/go-tools-9999.ebuild51
2 files changed, 48 insertions, 8 deletions
diff --git a/dev-go/go-tools/ChangeLog b/dev-go/go-tools/ChangeLog
index c48c169e45ea..2ed7d89c555c 100644
--- a/dev-go/go-tools/ChangeLog
+++ b/dev-go/go-tools/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-go/go-tools
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-tools/ChangeLog,v 1.10 2015/06/09 03:17:38 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-tools/ChangeLog,v 1.11 2015/06/26 19:24:29 williamh Exp $
+
+ 26 Jun 2015; William Hubbs <williamh@gentoo.org> go-tools-9999.ebuild:
+ Make live ebuild copyable as future snapshots
*go-tools-1.4.2_p20150606 (09 Jun 2015)
diff --git a/dev-go/go-tools/go-tools-9999.ebuild b/dev-go/go-tools/go-tools-9999.ebuild
index 6da00fc67c1a..e67093228d69 100644
--- a/dev-go/go-tools/go-tools-9999.ebuild
+++ b/dev-go/go-tools/go-tools-9999.ebuild
@@ -1,22 +1,59 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-tools/go-tools-9999.ebuild,v 1.8 2015/06/26 14:30:05 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-tools/go-tools-9999.ebuild,v 1.9 2015/06/26 19:24:29 williamh Exp $
EAPI=5
-inherit golang-build golang-vcs
-EGO_PN=golang.org/x/tools/...
-EGO_SRC=golang.org/x/tools
-ICON_URI="http://golang.org/favicon.ico -> go-favicon.ico"
+EGO_PN="golang.org/x/tools/..."
+EGO_SRC="golang.org/x/tools"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT="ac303766f5f240c1796eeea3dc9bf34f1261aa35"
+ ARCHIVE_URI="https://github.com/golang/tools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+inherit golang-build
DESCRIPTION="Go Tools"
-HOMEPAGE="https://godoc.org/x/tools"
-SRC_URI="${ICON_URI}"
+HOMEPAGE="https://godoc.org/golang.org/x/tools"
+SRC_URI="${ARCHIVE_URI}
+ http://golang.org/favicon.ico -> go-favicon.ico"
LICENSE="BSD"
SLOT="0"
IUSE=""
DEPEND="dev-go/go-net"
RDEPEND=""
+if [[ ${PV} != *9999* ]]; then
+src_unpack() {
+ local f
+
+ for f in ${A}
+ do
+ case "${f}" in
+ *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
+ local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
+
+ debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
+
+ # XXX: check whether the directory structure inside is
+ # fine? i.e. if the tarball has actually a parent dir.
+ mkdir -p "${destdir}" || die
+ tar -C "${destdir}" -x --strip-components 1 \
+ -f "${DISTDIR}/${f}" || die
+ ;;
+ *)
+ debug-print "${FUNCNAME}: falling back to unpack for ${f}"
+
+ # fall back to the default method
+ unpack "${f}"
+ ;;
+ esac
+ done
+}
+fi
+
src_prepare() {
# disable broken tests
sed -e 's:TestWeb(:_\0:' \