summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-07-09 13:23:40 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-07-09 13:23:40 +0000
commit8433d704977a2ff16468a4e6c7a179d4476cf35d (patch)
tree12a57847af0c824ea76d826ec3a7e76223011d9a /dev-haskell/arrows
parentApply fix from upstream to make pcap.findalldevs() work fine (bug #179342) (diff)
downloadgentoo-2-8433d704977a2ff16468a4e6c7a179d4476cf35d.tar.gz
gentoo-2-8433d704977a2ff16468a4e6c7a179d4476cf35d.tar.bz2
gentoo-2-8433d704977a2ff16468a4e6c7a179d4476cf35d.zip
Fix building arrows-0.2.1 with current Cabal.
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-haskell/arrows')
-rw-r--r--dev-haskell/arrows/ChangeLog5
-rw-r--r--dev-haskell/arrows/arrows-0.2.1.ebuild10
2 files changed, 12 insertions, 3 deletions
diff --git a/dev-haskell/arrows/ChangeLog b/dev-haskell/arrows/ChangeLog
index 28a004bc8651..a0a7712588e6 100644
--- a/dev-haskell/arrows/ChangeLog
+++ b/dev-haskell/arrows/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-haskell/arrows
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/arrows/ChangeLog,v 1.5 2007/07/08 17:33:42 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/arrows/ChangeLog,v 1.6 2007/07/09 13:23:40 dcoutts Exp $
+
+ 09 Jul 2007; Duncan Coutts <dcoutts@gentoo.org> arrows-0.2.1.ebuild:
+ Fix building arrows-0.2.1 with current Cabal.
*arrows-0.2.1 (08 Jul 2007)
diff --git a/dev-haskell/arrows/arrows-0.2.1.ebuild b/dev-haskell/arrows/arrows-0.2.1.ebuild
index de2abb93d6b6..08775d978edf 100644
--- a/dev-haskell/arrows/arrows-0.2.1.ebuild
+++ b/dev-haskell/arrows/arrows-0.2.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/arrows/arrows-0.2.1.ebuild,v 1.1 2007/07/08 17:33:42 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/arrows/arrows-0.2.1.ebuild,v 1.2 2007/07/09 13:23:40 dcoutts Exp $
CABAL_FEATURES="lib profile haddock"
-inherit base haskell-cabal
+inherit haskell-cabal
GHC_PV=6.6.1
@@ -19,3 +19,9 @@ IUSE=""
DEPEND=">=dev-lang/ghc-6.6"
S="${WORKDIR}/ghc-${GHC_PV}/libraries/${PN}"
+
+# Sadly Setup.hs in the ghc-6.6.1 extralibs was not tested with Cabal-1.1.6.x
+src_unpack() {
+ unpack "${A}"
+ sed -i -e "/type Hook/ s/UserHooks/Maybe UserHooks/" ${S}/Setup.hs
+}