summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-07-26 14:02:30 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2015-07-26 14:02:30 +0000
commit83d8ca8cacb8f63df49bd23c5bef4a2df5b7caea (patch)
tree91b15e18c054d2ddd90f7874d50e20a2e6cf38f8 /dev-haskell/cgi
parentPort to ghc-7.10. (diff)
downloadgentoo-2-83d8ca8cacb8f63df49bd23c5bef4a2df5b7caea.tar.gz
gentoo-2-83d8ca8cacb8f63df49bd23c5bef4a2df5b7caea.tar.bz2
gentoo-2-83d8ca8cacb8f63df49bd23c5bef4a2df5b7caea.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/cgi')
-rw-r--r--dev-haskell/cgi/ChangeLog7
-rw-r--r--dev-haskell/cgi/cgi-3001.2.2.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-haskell/cgi/ChangeLog b/dev-haskell/cgi/ChangeLog
index 650574825ceb..8b961f65602f 100644
--- a/dev-haskell/cgi/ChangeLog
+++ b/dev-haskell/cgi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/cgi
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cgi/ChangeLog,v 1.39 2015/06/06 10:35:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cgi/ChangeLog,v 1.40 2015/07/26 14:02:30 slyfox Exp $
+
+*cgi-3001.2.2.2 (26 Jul 2015)
+
+ 26 Jul 2015; Sergei Trofimovich <slyfox@gentoo.org> +cgi-3001.2.2.2.ebuild:
+ Version bump.
06 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-haskell/cgi/cgi-3001.2.2.2.ebuild b/dev-haskell/cgi/cgi-3001.2.2.2.ebuild
new file mode 100644
index 000000000000..b814345f4eb5
--- /dev/null
+++ b/dev-haskell/cgi/cgi-3001.2.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cgi/cgi-3001.2.2.2.ebuild,v 1.1 2015/07/26 14:02:30 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: -old-mtl
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A library for writing CGI programs"
+HOMEPAGE="https://github.com/cheecheeo/haskell-cgi"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND="<dev-haskell/exceptions-0.9:=[profile?]
+ >=dev-haskell/mtl-2.2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/multipart-0.1.2:=[profile?] <dev-haskell/multipart-0.2:=[profile?]
+ <dev-haskell/old-locale-1.1:=[profile?]
+ <dev-haskell/old-time-1.2:=[profile?]
+ >=dev-haskell/parsec-2.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/xhtml-3000.0.0:=[profile?] <dev-haskell/xhtml-3000.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-2.7:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri) \
+ --flag=-old-mtl
+}