summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-12-11 05:16:36 +0000
committerMark Wright <gienah@gentoo.org>2013-12-11 05:16:36 +0000
commit0dcbc19e781540d2d3c3a8c19fd0e030a6992702 (patch)
tree7de49ffb2fcd77f8ffbc70c9291a041cceb0319c /dev-haskell/cipher-aes
parentBump cereal to 0.4.0.1 (diff)
downloadgentoo-2-0dcbc19e781540d2d3c3a8c19fd0e030a6992702.tar.gz
gentoo-2-0dcbc19e781540d2d3c3a8c19fd0e030a6992702.tar.bz2
gentoo-2-0dcbc19e781540d2d3c3a8c19fd0e030a6992702.zip
Bump cipher-aes to 0.2.6
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/cipher-aes')
-rw-r--r--dev-haskell/cipher-aes/ChangeLog7
-rw-r--r--dev-haskell/cipher-aes/cipher-aes-0.2.6.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-haskell/cipher-aes/ChangeLog b/dev-haskell/cipher-aes/ChangeLog
index a0fb1d78e5ac..b83be546efae 100644
--- a/dev-haskell/cipher-aes/ChangeLog
+++ b/dev-haskell/cipher-aes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/cipher-aes
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cipher-aes/ChangeLog,v 1.4 2013/11/24 19:39:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cipher-aes/ChangeLog,v 1.5 2013/12/11 05:16:36 gienah Exp $
+
+*cipher-aes-0.2.6 (11 Dec 2013)
+
+ 11 Dec 2013; Mark Wright <gienah@gentoo.org> +cipher-aes-0.2.6.ebuild:
+ Bump cipher-aes to 0.2.6
24 Nov 2013; Agostino Sarubbo <ago@gentoo.org> cipher-aes-0.2.5.ebuild:
Stable for x86, wrt bug #488750
diff --git a/dev-haskell/cipher-aes/cipher-aes-0.2.6.ebuild b/dev-haskell/cipher-aes/cipher-aes-0.2.6.ebuild
new file mode 100644
index 000000000000..b78a55fbd287
--- /dev/null
+++ b/dev-haskell/cipher-aes/cipher-aes-0.2.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cipher-aes/cipher-aes-0.2.6.ebuild,v 1.1 2013/12/11 05:16:36 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast AES cipher implementation with advanced mode of operations"
+HOMEPAGE="http://github.com/vincenthz/hs-cipher-aes"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.6:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
+ >=dev-haskell/securemem-0.1.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/crypto-cipher-tests-0.0.8
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"