summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-11-14 18:27:13 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-11-14 18:27:13 +0000
commita56baf9f5c71876a19844def511385826b3d037e (patch)
tree7892a0f31cc73b57964420ae1c5a553e45391db3 /dev-haskell/cpu
parentVersion bump. (diff)
downloadgentoo-2-a56baf9f5c71876a19844def511385826b3d037e.tar.gz
gentoo-2-a56baf9f5c71876a19844def511385826b3d037e.tar.bz2
gentoo-2-a56baf9f5c71876a19844def511385826b3d037e.zip
Version bump.
(Portage version: 2.2.7_p18/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/cpu')
-rw-r--r--dev-haskell/cpu/ChangeLog8
-rw-r--r--dev-haskell/cpu/cpu-0.1.2.ebuild30
-rw-r--r--dev-haskell/cpu/metadata.xml3
3 files changed, 40 insertions, 1 deletions
diff --git a/dev-haskell/cpu/ChangeLog b/dev-haskell/cpu/ChangeLog
index b050d7139085..58e646acf7c1 100644
--- a/dev-haskell/cpu/ChangeLog
+++ b/dev-haskell/cpu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/cpu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cpu/ChangeLog,v 1.1 2013/08/26 12:16:09 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cpu/ChangeLog,v 1.2 2013/11/14 18:27:13 slyfox Exp $
+
+*cpu-0.1.2 (14 Nov 2013)
+
+ 14 Nov 2013; Sergei Trofimovich <slyfox@gentoo.org> +cpu-0.1.2.ebuild,
+ metadata.xml:
+ Version bump.
*cpu-0.1.1 (26 Aug 2013)
diff --git a/dev-haskell/cpu/cpu-0.1.2.ebuild b/dev-haskell/cpu/cpu-0.1.2.ebuild
new file mode 100644
index 000000000000..44a39bcf873e
--- /dev/null
+++ b/dev-haskell/cpu/cpu-0.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cpu/cpu-0.1.2.ebuild,v 1.1 2013/11/14 18:27:13 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Cpu information and properties helpers."
+HOMEPAGE="http://github.com/vincenthz/hs-cpu"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable"
+
+RDEPEND=">=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}
diff --git a/dev-haskell/cpu/metadata.xml b/dev-haskell/cpu/metadata.xml
index 90a7294cbdd9..2ac3b07045a2 100644
--- a/dev-haskell/cpu/metadata.xml
+++ b/dev-haskell/cpu/metadata.xml
@@ -5,6 +5,9 @@
<maintainer>
<email>haskell@gentoo.org</email>
</maintainer>
+ <use>
+ <flag name='executable'>build 'cpuid' tool</flag>
+ </use>
<longdescription>
Lowlevel cpu routines to get basic properties of the cpu platform, like endianness and architecture.
</longdescription>