summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-10-11 23:33:40 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-10-11 23:33:40 +0000
commitfe8446b03bd371d1b6c849e7489bafadd37f0cb4 (patch)
tree38a33573152dce8ac11ab87b9ffbfba908b822a1 /dev-haskell/drift
parentAdded patch to make buddha work with ghc-6.4 and 6.6. (diff)
downloadgentoo-2-fe8446b03bd371d1b6c849e7489bafadd37f0cb4.tar.gz
gentoo-2-fe8446b03bd371d1b6c849e7489bafadd37f0cb4.tar.bz2
gentoo-2-fe8446b03bd371d1b6c849e7489bafadd37f0cb4.zip
Version bump
(Portage version: 2.1.1-r1)
Diffstat (limited to 'dev-haskell/drift')
-rw-r--r--dev-haskell/drift/ChangeLog7
-rw-r--r--dev-haskell/drift/drift-2.2.0.ebuild33
-rw-r--r--dev-haskell/drift/files/digest-drift-2.2.03
3 files changed, 42 insertions, 1 deletions
diff --git a/dev-haskell/drift/ChangeLog b/dev-haskell/drift/ChangeLog
index 01b90968660e..ef565b5115a6 100644
--- a/dev-haskell/drift/ChangeLog
+++ b/dev-haskell/drift/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/drift
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/drift/ChangeLog,v 1.13 2006/10/05 03:11:31 cparrott Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/drift/ChangeLog,v 1.14 2006/10/11 23:33:40 dcoutts Exp $
+
+*drift-2.2.0 (11 Oct 2006)
+
+ 11 Oct 2006; Duncan Coutts <dcoutts@gentoo.org> +drift-2.2.0.ebuild:
+ Version bump
05 Oct 2006; Chris Parrott <cparrott@gentoo.org> drift-2.1.2.ebuild:
marked stable for amd64 (bug 144678)
diff --git a/dev-haskell/drift/drift-2.2.0.ebuild b/dev-haskell/drift/drift-2.2.0.ebuild
new file mode 100644
index 000000000000..c3dfe1599640
--- /dev/null
+++ b/dev-haskell/drift/drift-2.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/drift/drift-2.2.0.ebuild,v 1.1 2006/10/11 23:33:40 dcoutts Exp $
+
+inherit ghc-package
+
+MY_PN="DrIFT"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Preprocessor for automatic derivation of Haskell class instances"
+HOMEPAGE="http://repetae.net/john/computer/haskell/DrIFT/"
+SRC_URI="http://repetae.net/john/computer/haskell/DrIFT/drop/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+
+DEPEND=">=virtual/ghc-6"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf --with-hc="$(ghc-getghc)" || die "configure failed"
+ # Makefile has no parallelism
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}
diff --git a/dev-haskell/drift/files/digest-drift-2.2.0 b/dev-haskell/drift/files/digest-drift-2.2.0
new file mode 100644
index 000000000000..d6fbaf911554
--- /dev/null
+++ b/dev-haskell/drift/files/digest-drift-2.2.0
@@ -0,0 +1,3 @@
+MD5 403f8449d763df40a3bdc6b027de1845 DrIFT-2.2.0.tar.gz 252043
+RMD160 74daea78e4d5c4371c3acfb41966e06c732476a6 DrIFT-2.2.0.tar.gz 252043
+SHA256 ae24a61a4ca2f81e9f033ce6cc08b2f5f5239de11c53aa677b3de62da4f97406 DrIFT-2.2.0.tar.gz 252043