summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-02-20 18:28:33 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-02-20 18:28:33 +0000
commita8629425ce3c0257f17d36fa14d880f9efc3c8a7 (patch)
treed107de947452c5fcab399029d8392d617e1f48e6 /dev-haskell/gtk2hs
parentFix building with ghc-6.2.2. Fixes bug #115657. (diff)
downloadgentoo-2-a8629425ce3c0257f17d36fa14d880f9efc3c8a7.tar.gz
gentoo-2-a8629425ce3c0257f17d36fa14d880f9efc3c8a7.tar.bz2
gentoo-2-a8629425ce3c0257f17d36fa14d880f9efc3c8a7.zip
Remove old 0.9.7 version.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'dev-haskell/gtk2hs')
-rw-r--r--dev-haskell/gtk2hs/ChangeLog5
-rw-r--r--dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.72
-rw-r--r--dev-haskell/gtk2hs/gtk2hs-0.9.7.ebuild104
3 files changed, 4 insertions, 107 deletions
diff --git a/dev-haskell/gtk2hs/ChangeLog b/dev-haskell/gtk2hs/ChangeLog
index 4d7ca97e1c63..c83df3b096e0 100644
--- a/dev-haskell/gtk2hs/ChangeLog
+++ b/dev-haskell/gtk2hs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-haskell/gtk2hs
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/ChangeLog,v 1.23 2006/02/20 18:25:32 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/ChangeLog,v 1.24 2006/02/20 18:28:33 dcoutts Exp $
+
+ 20 Feb 2006; <duncan@gentoo.org> -gtk2hs-0.9.7.ebuild:
+ Remove old 0.9.7 version.
20 Feb 2006; <duncan@gentoo.org> +files/gtk2hs-0.9.10-ghc622.patch,
gtk2hs-0.9.10.ebuild:
diff --git a/dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.7 b/dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.7
deleted file mode 100644
index 9f2aeaedb706..000000000000
--- a/dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.7
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 690f4192d427c43531d990e34ff0ad0b gtk2hs-0.9.7-ghc64.patch.gz 6986
-MD5 af4476dec61c82bd522b537155282fb9 gtk2hs-0.9.7.tar.gz 546945
diff --git a/dev-haskell/gtk2hs/gtk2hs-0.9.7.ebuild b/dev-haskell/gtk2hs/gtk2hs-0.9.7.ebuild
deleted file mode 100644
index f030de834fc0..000000000000
--- a/dev-haskell/gtk2hs/gtk2hs-0.9.7.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/gtk2hs-0.9.7.ebuild,v 1.6 2006/01/29 15:45:14 blubb Exp $
-
-inherit base check-reqs ghc-package
-
-DESCRIPTION="GTK+-2.x bindings for Haskell"
-HOMEPAGE="http://haskell.org/gtk2hs/"
-SRC_URI="mirror://sourceforge/gtk2hs/${P}.tar.gz
- mirror://gentoo/gtk2hs-0.9.7-ghc64.patch.gz"
-LICENSE="LGPL-2 GPL-2"
-SLOT="0"
-
-KEYWORDS="~x86 ~ppc -amd64 ~sparc"
-
-IUSE="doc gnome mozilla"
-
-DEPEND=">=virtual/ghc-5.04
- >=x11-libs/gtk+-2
- gnome? ( >=gnome-base/libglade-2
- >=x11-libs/gtksourceview-0.6
- >=gnome-base/gconf-2 )
- mozilla? ( >=www-client/mozilla-1.4 )
- doc? ( =dev-haskell/haddock-0.6* )"
-
-pkg_setup() {
- # need this much memory (in MBytes) (does *not* check swap)
- CHECKREQS_MEMORY="400"
-
- check_reqs
-}
-
-src_unpack() {
- base_src_unpack
-
- # patch for GHC 6.4 compatability
- epatch ${WORKDIR}/gtk2hs-0.9.7-ghc64.patch
-}
-
-src_compile() {
- econf \
- --libdir=$(ghc-libdir) \
- --with-hcflags="-O" \
- --without-pkgreg \
- `use_enable gnome gnome` \
- `use_enable gnome libglade` \
- `use_enable mozilla mozilla` \
- `use_enable doc docs` \
- || die "Configure failed"
-
- # parallel build doesn't work, so specify -j1
- emake -j1 HSTOOLFLAGS="-H380m -M380m" || die "Make failed"
-}
-
-src_install() {
-
- make install \
- DESTDIR=${D} \
- htmldir="/usr/share/doc/${PF}/html" \
- haddockifacedir="/usr/share/doc/${PF}" \
- || die "Make install failed"
-
- # for some reason it creates the doc dir even if it is configured
- # to not generate docs, so lets remove the empty dirs in that case
- # (and lets be cautious and only remove them if they're empty)
- if ! use doc; then
- rmdir ${D}/usr/share/doc/${PF}/html
- rmdir ${D}/usr/share/doc/${PF}
- rmdir ${D}/usr/share/doc
- rmdir ${D}/usr/share
- fi
-
- # arrange for the packages to be registered
- if ghc-cabal; then
- pkgext=cabal
- else
- pkgext=pkg
- fi
- ghc-setup-pkg \
- "${D}/$(ghc-libdir)/gtk2hs/glib.${pkgext}" \
- "${D}/$(ghc-libdir)/gtk2hs/gtk.${pkgext}" \
- "${D}/$(ghc-libdir)/gtk2hs/mogul.${pkgext}" \
- $(useq gnome && echo \
- "${D}/$(ghc-libdir)/gtk2hs/glade.${pkgext}" \
- "${D}/$(ghc-libdir)/gtk2hs/gconf.${pkgext}" \
- "${D}/$(ghc-libdir)/gtk2hs/sourceview.${pkgext}") \
- $(useq mozilla && echo \
- "${D}/$(ghc-libdir)/gtk2hs/mozembed.${pkgext}")
- ghc-install-pkg
-
- # build ghci .o files from .a files
- ghc-makeghcilib ${D}/$(ghc-libdir)/gtk2hs/libHSglib.a
- ghc-makeghcilib ${D}/$(ghc-libdir)/gtk2hs/libHSgtk.a
- ghc-makeghcilib ${D}/$(ghc-libdir)/gtk2hs/libHSmogul.a
- if use gnome; then
- ghc-makeghcilib ${D}/$(ghc-libdir)/gtk2hs/libHSglade.a
- ghc-makeghcilib ${D}/$(ghc-libdir)/gtk2hs/libHSgconf.a
- ghc-makeghcilib ${D}/$(ghc-libdir)/gtk2hs/libHSsourceview.a
- fi
- if use mozilla; then
- ghc-makeghcilib ${D}/$(ghc-libdir)/gtk2hs/libHSmozembed.a
- fi
-}
-