summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-08-05 18:07:58 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-08-05 18:07:58 +0000
commit02ef40b2ecd8927baae2860dfebb490842105dec (patch)
tree8e4e654626da034e232840b6825964afb5a59023 /dev-haskell/hsql
parentfixed oxygen-air kdm theme installation (diff)
downloadgentoo-2-02ef40b2ecd8927baae2860dfebb490842105dec.tar.gz
gentoo-2-02ef40b2ecd8927baae2860dfebb490842105dec.tar.bz2
gentoo-2-02ef40b2ecd8927baae2860dfebb490842105dec.zip
Version bump dev-haskell/hsql.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/hsql')
-rw-r--r--dev-haskell/hsql/ChangeLog9
-rw-r--r--dev-haskell/hsql/hsql-1.7.1.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-haskell/hsql/ChangeLog b/dev-haskell/hsql/ChangeLog
index 0243e9188cdf..2857e82597a7 100644
--- a/dev-haskell/hsql/ChangeLog
+++ b/dev-haskell/hsql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hsql
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsql/ChangeLog,v 1.11 2007/12/13 05:41:55 dcoutts Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsql/ChangeLog,v 1.12 2009/08/05 18:07:58 kolmodin Exp $
+
+*hsql-1.7.1 (05 Aug 2009)
+
+ 05 Aug 2009; Lennart Kolmodin <kolmodin@gentoo.org> +hsql-1.7.1.ebuild:
+ Version bump (builds with ghc 6.10).
13 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> hsql-1.7.ebuild:
Updates for upward compatability with cabal-1.2 and ghc-6.8
diff --git a/dev-haskell/hsql/hsql-1.7.1.ebuild b/dev-haskell/hsql/hsql-1.7.1.ebuild
new file mode 100644
index 000000000000..afb98a65584c
--- /dev/null
+++ b/dev-haskell/hsql/hsql-1.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsql/hsql-1.7.1.ebuild,v 1.1 2009/08/05 18:07:58 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+DESCRIPTION="Simple library for database access from Haskell."
+HOMEPAGE="http://hackage.haskell.org/cgi-bin/hackage-scripts/package/hsql"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.6.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+pkg_postinst () {
+ ghc-package_pkg_postinst
+
+ elog "You will probably want to emerge one or more HSQL backend."
+ elog "These backends are available:"
+ elog " hsql-postgresql"
+ elog " hsql-mysql"
+ elog " hsql-sqlite"
+ elog " hsql-odbc"
+}