summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2005-01-24 14:20:03 +0000
committerAndres Loeh <kosmikus@gentoo.org>2005-01-24 14:20:03 +0000
commit95cb81063fbe1a932729cd6db210490cdc4919e3 (patch)
tree0bd541c7a7ee8f4c5be6f947d293adcb54043869 /dev-haskell/hsshellscript
parentVersion bump. (diff)
downloadgentoo-2-95cb81063fbe1a932729cd6db210490cdc4919e3.tar.gz
gentoo-2-95cb81063fbe1a932729cd6db210490cdc4919e3.tar.bz2
gentoo-2-95cb81063fbe1a932729cd6db210490cdc4919e3.zip
New ebuild, bug #79170.
Diffstat (limited to 'dev-haskell/hsshellscript')
-rw-r--r--dev-haskell/hsshellscript/ChangeLog7
-rw-r--r--dev-haskell/hsshellscript/Manifest2
-rw-r--r--dev-haskell/hsshellscript/files/digest-hsshellscript-2.1.01
-rw-r--r--dev-haskell/hsshellscript/hsshellscript-2.1.0.ebuild46
-rw-r--r--dev-haskell/hsshellscript/metadata.xml8
5 files changed, 64 insertions, 0 deletions
diff --git a/dev-haskell/hsshellscript/ChangeLog b/dev-haskell/hsshellscript/ChangeLog
new file mode 100644
index 000000000000..a60bb84842fc
--- /dev/null
+++ b/dev-haskell/hsshellscript/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for dev-haskell/hsshellscript
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/ChangeLog,v 1.1 2005/01/24 14:20:03 kosmikus Exp $
+
+ 24 Jan 2005; Andres Loeh <kosmikus@gentoo.org> :
+ Initial import (bug #79170).
+
diff --git a/dev-haskell/hsshellscript/Manifest b/dev-haskell/hsshellscript/Manifest
new file mode 100644
index 000000000000..bb7e1f495608
--- /dev/null
+++ b/dev-haskell/hsshellscript/Manifest
@@ -0,0 +1,2 @@
+MD5 a5fd29f35e2987ab0500369698be1390 hsshellscript-2.1.0.ebuild 1198
+MD5 29b043a8133ca29f855bd09a4ce05033 files/digest-hsshellscript-2.1.0 71
diff --git a/dev-haskell/hsshellscript/files/digest-hsshellscript-2.1.0 b/dev-haskell/hsshellscript/files/digest-hsshellscript-2.1.0
new file mode 100644
index 000000000000..6d7d30bc58da
--- /dev/null
+++ b/dev-haskell/hsshellscript/files/digest-hsshellscript-2.1.0
@@ -0,0 +1 @@
+MD5 1d85645fdf43b1496be5767272220cf1 hsshellscript-2.1.0.tar.gz 133452
diff --git a/dev-haskell/hsshellscript/hsshellscript-2.1.0.ebuild b/dev-haskell/hsshellscript/hsshellscript-2.1.0.ebuild
new file mode 100644
index 000000000000..5853c5f21c50
--- /dev/null
+++ b/dev-haskell/hsshellscript/hsshellscript-2.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/hsshellscript-2.1.0.ebuild,v 1.1 2005/01/24 14:20:03 kosmikus Exp $
+
+inherit base eutils ghc-package
+
+DESCRIPTION="A Haskell library for UNIX shell scripting tasks"
+HOMEPAGE="http://www.volker-wysk.de/hsshellscript/"
+SRC_URI="http://www.volker-wysk.de/hsshellscript/dist/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND=">=virtual/ghc-6.2
+ doc? ( >=dev-haskell/haddock-0.6-r2 )"
+RDEPEND=">=virtual/ghc-6.2"
+
+
+src_unpack() {
+ base_src_unpack
+ cd ${S}
+ sed -i -e "s:ghc-pkg\(.*\)--auto-ghci-libs:$(ghc-getghcpkg) -f ${S}/$(ghc-localpkgconf) \1:" \
+ Makefile
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use doc; then
+ emake doc || die "make doc failed"
+ fi
+}
+
+src_install() {
+ ghc-setup-pkg
+ make install \
+ DESTDIR="${D}" \
+ DEST_LIB="$(ghc-libdir)" \
+ DEST_IMPORTS="$(ghc-libdir)/imports" \
+ DEST_DOC="/usr/share/doc/${PF}" \
+ || die "make failed"
+ ghc-install-pkg
+ ghc-makeghcilib "${D}/$(ghc-libdir)/libhsshellscript.a"
+}
diff --git a/dev-haskell/hsshellscript/metadata.xml b/dev-haskell/hsshellscript/metadata.xml
new file mode 100644
index 000000000000..a53a18c06081
--- /dev/null
+++ b/dev-haskell/hsshellscript/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>haskell</herd>
+<maintainer>
+ <email>kosmikus@gentoo.org</email>
+</maintainer>
+</pkgmetadata>