summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2006-07-08 19:06:13 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2006-07-08 19:06:13 +0000
commit6ef9b9e5121131f4ae59cdc0a5e3b0e8a98c88ba (patch)
tree943db040423a5e33287275bdad33eda2099a6909 /dev-haskell/http
parentStable on alpha wrt Bug #119923. (diff)
downloadgentoo-2-6ef9b9e5121131f4ae59cdc0a5e3b0e8a98c88ba.tar.gz
gentoo-2-6ef9b9e5121131f4ae59cdc0a5e3b0e8a98c88ba.tar.bz2
gentoo-2-6ef9b9e5121131f4ae59cdc0a5e3b0e8a98c88ba.zip
Version bump.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'dev-haskell/http')
-rw-r--r--dev-haskell/http/ChangeLog7
-rw-r--r--dev-haskell/http/files/digest-http-2006.7.73
-rw-r--r--dev-haskell/http/http-2006.7.7.ebuild32
3 files changed, 41 insertions, 1 deletions
diff --git a/dev-haskell/http/ChangeLog b/dev-haskell/http/ChangeLog
index 3eed03efb39f..fd6b7e161f3e 100644
--- a/dev-haskell/http/ChangeLog
+++ b/dev-haskell/http/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/http
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.1 2006/07/06 17:33:43 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.2 2006/07/08 19:06:13 kolmodin Exp $
+
+*http-2006.7.7 (08 Jul 2006)
+
+ 08 Jul 2006; <kolmodin@gentoo.org> +http-2006.7.7.ebuild:
+ Version bump.
*http-2006.7.5 (06 Jul 2006)
diff --git a/dev-haskell/http/files/digest-http-2006.7.7 b/dev-haskell/http/files/digest-http-2006.7.7
new file mode 100644
index 000000000000..f3f3eeec507d
--- /dev/null
+++ b/dev-haskell/http/files/digest-http-2006.7.7
@@ -0,0 +1,3 @@
+MD5 f641b4bde64a6486bb1180173d2c4a30 http-20060707.tar.gz 37151
+RMD160 0d42a5097909e2a97717ea8384f1fc8b51bfb975 http-20060707.tar.gz 37151
+SHA256 f96e217b191c2057005ec1d331ed06cd70bcbca126dbc533901c88f94f6c91f4 http-20060707.tar.gz 37151
diff --git a/dev-haskell/http/http-2006.7.7.ebuild b/dev-haskell/http/http-2006.7.7.ebuild
new file mode 100644
index 000000000000..763f663562e5
--- /dev/null
+++ b/dev-haskell/http/http-2006.7.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-2006.7.7.ebuild,v 1.1 2006/07/08 19:06:13 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit base versionator eutils haskell-cabal
+
+MY_PV_YEAR=$(get_version_component_range 1)
+MY_PV_MONTH=$(get_version_component_range 2)
+(( ${MY_PV_MONTH} < 10 )) && MY_PV_MONTH="0${MY_PV_MONTH}"
+MY_PV_DAY=$(get_version_component_range 3)
+(( ${MY_PV_DAY} < 10 )) && MY_PV_DAY="0${MY_PV_DAY}"
+MY_PV="${MY_PV_YEAR}${MY_PV_MONTH}${MY_PV_DAY}"
+
+DESCRIPTION="Haskell HTTP Package"
+HOMEPAGE="http://www.haskell.org/http/"
+SRC_URI="http://www.haskell.org/http/download/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/ghc-6.4"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ cabal_src_install
+
+ dodoc README LICENSE
+}