summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2006-07-06 18:05:29 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2006-07-06 18:05:29 +0000
commitd1f7fe16264a566127708a72b546a83bdf55f0cc (patch)
tree8835d2113d968221db418e2d56940709a4c99e27 /dev-haskell/hxt
parentInitial version. (diff)
downloadgentoo-2-d1f7fe16264a566127708a72b546a83bdf55f0cc.tar.gz
gentoo-2-d1f7fe16264a566127708a72b546a83bdf55f0cc.tar.bz2
gentoo-2-d1f7fe16264a566127708a72b546a83bdf55f0cc.zip
Version bump.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'dev-haskell/hxt')
-rw-r--r--dev-haskell/hxt/ChangeLog7
-rw-r--r--dev-haskell/hxt/files/digest-hxt-6.03
-rw-r--r--dev-haskell/hxt/hxt-6.0.ebuild43
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-haskell/hxt/ChangeLog b/dev-haskell/hxt/ChangeLog
index 2de647b6b785..1d10d0a7a537 100644
--- a/dev-haskell/hxt/ChangeLog
+++ b/dev-haskell/hxt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hxt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/ChangeLog,v 1.4 2006/04/27 15:17:17 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/ChangeLog,v 1.5 2006/07/06 18:05:29 kolmodin Exp $
+
+*hxt-6.0 (06 Jul 2006)
+
+ 06 Jul 2006; <kolmodin@gentoo.org> +hxt-6.0.ebuild:
+ Version bump.
27 Apr 2006; Marien Zwart <marienz@gentoo.org> files/digest-hxt-4.02,
files/digest-hxt-4.02-r1, files/digest-hxt-5.00, Manifest:
diff --git a/dev-haskell/hxt/files/digest-hxt-6.0 b/dev-haskell/hxt/files/digest-hxt-6.0
new file mode 100644
index 000000000000..b50a4fdabeae
--- /dev/null
+++ b/dev-haskell/hxt/files/digest-hxt-6.0
@@ -0,0 +1,3 @@
+MD5 59f914a5428561c5aba91ca91c38fa9f HXT-6.0.tar.gz 2893958
+RMD160 88d90300ccd7e88cc5ebc48aa5e79fd96ba20f5d HXT-6.0.tar.gz 2893958
+SHA256 8d0619e75918867bcc2acbe12137f60936d2e4ceb74c9afa190846d8d504a131 HXT-6.0.tar.gz 2893958
diff --git a/dev-haskell/hxt/hxt-6.0.ebuild b/dev-haskell/hxt/hxt-6.0.ebuild
new file mode 100644
index 000000000000..540263118c71
--- /dev/null
+++ b/dev-haskell/hxt/hxt-6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/hxt-6.0.ebuild,v 1.1 2006/07/06 18:05:29 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit base haskell-cabal
+
+MY_PN="HXT"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A collection of tools for processing XML with Haskell"
+HOMEPAGE="http://www.fh-wedel.de/~si/HXmlToolbox/"
+SRC_URI="http://www.fh-wedel.de/~si/HXmlToolbox/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/ghc-6.4
+ dev-haskell/http"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ base_src_unpack
+
+ sed -i \
+ -e 's/, Browser//' \
+ -e 's/-O2/-O/' \
+ "${S}/hxt.cabal"
+}
+
+src_install() {
+ cabal_src_install
+
+ dodoc LICENSE README
+ if use doc; then
+ cd ${S}/doc
+ dodoc thesis.ps
+ dohtml -r *
+ fi
+}