summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-12-04 18:05:02 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-12-04 18:05:02 +0000
commitdc88505e36abfdd1e4d32f9709f4b74d6786e589 (patch)
tree36eff67d39d756e64bc79399e4cd99280df9290c /dev-haskell/monad-control
parentInitial version. Unicode alternatives for common functions and operators (dev... (diff)
downloadgentoo-2-dc88505e36abfdd1e4d32f9709f4b74d6786e589.tar.gz
gentoo-2-dc88505e36abfdd1e4d32f9709f4b74d6786e589.tar.bz2
gentoo-2-dc88505e36abfdd1e4d32f9709f4b74d6786e589.zip
Initial version. Lift control operations, like exception catching, through monad transformers (dev-vcs/git-annex depend)
(Portage version: 2.2.0_alpha77_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/monad-control')
-rw-r--r--dev-haskell/monad-control/ChangeLog11
-rw-r--r--dev-haskell/monad-control/Manifest3
-rw-r--r--dev-haskell/monad-control/metadata.xml30
-rw-r--r--dev-haskell/monad-control/monad-control-0.2.0.3.ebuild35
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-haskell/monad-control/ChangeLog b/dev-haskell/monad-control/ChangeLog
new file mode 100644
index 000000000000..6289d41450b7
--- /dev/null
+++ b/dev-haskell/monad-control/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-haskell/monad-control
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/monad-control/ChangeLog,v 1.1 2011/12/04 18:05:02 slyfox Exp $
+
+*monad-control-0.2.0.3 (04 Dec 2011)
+
+ 04 Dec 2011; Sergei Trofimovich <slyfox@gentoo.org> +metadata.xml,
+ +monad-control-0.2.0.3.ebuild:
+ Initial version. Lift control operations, like exception catching, through
+ monad transformers (dev-vcs/git-annex depend)
+
diff --git a/dev-haskell/monad-control/Manifest b/dev-haskell/monad-control/Manifest
new file mode 100644
index 000000000000..8ea9af26c162
--- /dev/null
+++ b/dev-haskell/monad-control/Manifest
@@ -0,0 +1,3 @@
+DIST monad-control-0.2.0.3.tar.gz 13160 RMD160 229e944dcba41786a5153fe9ac800e6a051f5f0c SHA1 955e4e57879e88a35e40791615a87ef2edc5e993 SHA256 d00e24e47be81bcf27d44d0d099104ac0e1b7c2b66f3fe84c6f09a9e6994fc7c
+EBUILD monad-control-0.2.0.3.ebuild 896 RMD160 6744bf25124ac202b047a7e43503b8eb890e9fe8 SHA1 d6f88f0434fe41546994949169c9503d8f6e695f SHA256 bc44a17e23c7656b773212d0026b78c33c7d18575d9f5feccbfcc27f4bf6fd51
+MISC metadata.xml 1318 RMD160 6c47c168b26c63e3061e6c17fe385c43767512f8 SHA1 0cc82f2edc53bacf87998d3c040871147a642138 SHA256 cf41ccf2d762ef9684f0228f9955d3270f2d1748daca3d847d595c2620ea5f3c
diff --git a/dev-haskell/monad-control/metadata.xml b/dev-haskell/monad-control/metadata.xml
new file mode 100644
index 000000000000..f5ba38a664d2
--- /dev/null
+++ b/dev-haskell/monad-control/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This package defines the type class @MonadControlIO@, a subset of
+ @MonadIO@ into which generic control operations such as @catch@ can
+ be lifted from @IO@. Instances are based on monad transformers in
+ @MonadTransControl@, which includes all standard monad transformers
+ in the @transformers@ library except @ContT@. For convenience, it
+ provides a wrapped version of @Control.Exception@ with types
+ generalized from @IO@ to all monads in @MonadControlIO@.
+
+ Note that this package is a rewrite of Anders Kaseorg&#39;s @monad-peel@ library.
+ The main difference is that this package provides CPS style
+ operators and exploits the @RankNTypes@ language extension to
+ simplify most definitions.
+
+ The package includes a copy of the @monad-peel@ testsuite written by Anders Kaseorg.
+ The tests can be performed by using @cabal test@.
+
+ The following @critertion@ based benchmark shows that @monad-control@
+ is on average about 2.5 times faster than @monad-peel@:
+
+ &lt;https://github.com/basvandijk/bench-monad-peel-control&gt;
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/monad-control/monad-control-0.2.0.3.ebuild b/dev-haskell/monad-control/monad-control-0.2.0.3.ebuild
new file mode 100644
index 000000000000..3a9850287a97
--- /dev/null
+++ b/dev-haskell/monad-control/monad-control-0.2.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/monad-control/monad-control-0.2.0.3.ebuild,v 1.1 2011/12/04 18:05:02 slyfox Exp $
+
+# ebuild generated by hackport 0.2.14
+
+EAPI="3"
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit base haskell-cabal
+
+DESCRIPTION="Lift control operations, like exception catching, through monad transformers"
+HOMEPAGE="https://github.com/basvandijk/monad-control/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="<dev-haskell/base-unicode-symbols-0.3
+ =dev-haskell/transformers-0.2*
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.9.2
+ test? (
+ >=dev-haskell/cabal-1.10
+ <dev-haskell/test-framework-0.5
+ <dev-haskell/test-framework-hunit-0.3
+ )
+ "
+
+src_configure() {
+ cabal_src_configure $(use_enable test tests) $(cabal_flag test)
+}