summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-04-03 21:34:48 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-04-03 21:34:48 +0000
commit12eaa88d2dddf431989b31ce9d28c8ddc89d925a (patch)
tree3ba503d5f46238023c64e9a717ed1d1753253ff8 /dev-haskell/quickcheck
parentStable for HPPA (bug #410129). (diff)
downloadgentoo-2-12eaa88d2dddf431989b31ce9d28c8ddc89d925a.tar.gz
gentoo-2-12eaa88d2dddf431989b31ce9d28c8ddc89d925a.tar.bz2
gentoo-2-12eaa88d2dddf431989b31ce9d28c8ddc89d925a.zip
Added missing 'random' depend found by Nick Bowler in bug #410709.
(Portage version: 2.2.0_alpha96_p5/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/quickcheck')
-rw-r--r--dev-haskell/quickcheck/ChangeLog9
-rw-r--r--dev-haskell/quickcheck/metadata.xml25
-rw-r--r--dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild7
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.4.2-r1.ebuild39
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.4.2.ebuild5
5 files changed, 75 insertions, 10 deletions
diff --git a/dev-haskell/quickcheck/ChangeLog b/dev-haskell/quickcheck/ChangeLog
index f15c8815d7fe..fa2dfb152417 100644
--- a/dev-haskell/quickcheck/ChangeLog
+++ b/dev-haskell/quickcheck/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-haskell/quickcheck
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.51 2012/01/22 14:05:49 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.52 2012/04/03 21:34:48 slyfox Exp $
+
+*quickcheck-2.4.2-r1 (03 Apr 2012)
+
+ 03 Apr 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +quickcheck-2.4.2-r1.ebuild, metadata.xml, quickcheck-1.2.0.0.ebuild,
+ quickcheck-2.4.2.ebuild:
+ Added missing 'random' depend found by Nick Bowler in bug #410709.
*quickcheck-2.4.2 (22 Jan 2012)
diff --git a/dev-haskell/quickcheck/metadata.xml b/dev-haskell/quickcheck/metadata.xml
index 8c66906af531..7256195592c0 100644
--- a/dev-haskell/quickcheck/metadata.xml
+++ b/dev-haskell/quickcheck/metadata.xml
@@ -1,8 +1,25 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>haskell</herd>
-<maintainer>
- <email>haskell@gentoo.org</email>
-</maintainer>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="template_haskell">Enable additional test modules requiring Template Haskell support.</flag>
+ </use>
+ <longdescription>
+ QuickCheck is a library for random testing of program properties.
+
+ The programmer provides a specification of the program, in
+ the form of properties which functions should satisfy, and
+ QuickCheck then tests that the properties hold in a large number
+ of randomly generated cases.
+
+ Specifications are expressed in
+ Haskell, using combinators defined in the QuickCheck library.
+ QuickCheck provides combinators to define properties, observe
+ the distribution of test data, and define test
+ data generators.
+ </longdescription>
</pkgmetadata>
diff --git a/dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild b/dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild
index 6559e4c191d8..797ffac597ad 100644
--- a/dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild
+++ b/dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild,v 1.5 2010/07/01 19:58:21 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild,v 1.6 2012/04/03 21:34:48 slyfox Exp $
CABAL_FEATURES="lib profile haddock"
inherit haskell-cabal
@@ -17,7 +17,8 @@ SLOT="1"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE=""
-RDEPEND=">=dev-lang/ghc-6.6.1"
+RDEPEND=">=dev-lang/ghc-6.6.1
+ dev-haskell/random"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.2"
diff --git a/dev-haskell/quickcheck/quickcheck-2.4.2-r1.ebuild b/dev-haskell/quickcheck/quickcheck-2.4.2-r1.ebuild
new file mode 100644
index 000000000000..0c8c1223875a
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-2.4.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-2.4.2-r1.ebuild,v 1.1 2012/04/03 21:34:48 slyfox Exp $
+
+EAPI="3"
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit haskell-cabal
+
+MY_PN="QuickCheck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="http://code.haskell.org/QuickCheck"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+template_haskell"
+
+RDEPEND=">=dev-lang/ghc-6.10.1
+ dev-haskell/random"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+# would work with ghc 6.8 (6.6 too?) too if we added this dep
+# dev-haskell/extensible-exceptions. however, we'd prefer not to add more co$
+# packages, as we don't want them upgradeable (leads to trouble).
+#
+# this means that we can only support the architectures which has >=ghc-6.10
+# and unfortunately have to drop the other arches until we get proper ghc su$
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # GHCi-less platforms do not support Template Haskell
+ cabal_src_configure $(cabal_flag template_haskell templateHaskell)
+}
diff --git a/dev-haskell/quickcheck/quickcheck-2.4.2.ebuild b/dev-haskell/quickcheck/quickcheck-2.4.2.ebuild
index fd61bd35f0e3..3dfddcf45eb9 100644
--- a/dev-haskell/quickcheck/quickcheck-2.4.2.ebuild
+++ b/dev-haskell/quickcheck/quickcheck-2.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-2.4.2.ebuild,v 1.1 2012/01/22 14:05:49 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-2.4.2.ebuild,v 1.2 2012/04/03 21:34:48 slyfox Exp $
EAPI="3"
@@ -19,7 +19,8 @@ SLOT="2"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE=""
-RDEPEND=">=dev-lang/ghc-6.10.1"
+RDEPEND=">=dev-lang/ghc-6.10.1
+ dev-haskell/random"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6"