summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-06-20 05:16:16 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-06-20 05:16:16 +0000
commite1f894505726bdb22dcefa2a7d5c7be5fe2cbb9b (patch)
tree76f386defbc92605dca4369d0b6f24c41ec67734 /dev-haskell/threads
parentadd 0.7.0.6 due to #473858 (diff)
downloadgentoo-2-e1f894505726bdb22dcefa2a7d5c7be5fe2cbb9b.tar.gz
gentoo-2-e1f894505726bdb22dcefa2a7d5c7be5fe2cbb9b.tar.bz2
gentoo-2-e1f894505726bdb22dcefa2a7d5c7be5fe2cbb9b.zip
add 0.5.0.2 due to #473858
(Portage version: 2.2.0_alpha181/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/threads')
-rw-r--r--dev-haskell/threads/ChangeLog9
-rw-r--r--dev-haskell/threads/metadata.xml31
-rw-r--r--dev-haskell/threads/threads-0.5.0.2.ebuild36
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-haskell/threads/ChangeLog b/dev-haskell/threads/ChangeLog
new file mode 100644
index 000000000000..f1363ca8904a
--- /dev/null
+++ b/dev-haskell/threads/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/threads
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/threads/ChangeLog,v 1.1 2013/06/20 05:16:16 qnikst Exp $
+
+*threads-0.5.0.2 (20 Jun 2013)
+
+ 20 Jun 2013; Alexander Vershilov <qnikst@gentoo.org> +metadata.xml,
+ +threads-0.5.0.2.ebuild:
+ add 0.5.0.2 due to #473858
diff --git a/dev-haskell/threads/metadata.xml b/dev-haskell/threads/metadata.xml
new file mode 100644
index 000000000000..cbc2c1376d96
--- /dev/null
+++ b/dev-haskell/threads/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This package provides functions to fork threads and
+ wait for their result, whether it&#39;s an exception or a
+ normal value.
+
+ Besides waiting for the termination of a single thread
+ this packages also provides functions to wait for a
+ group of threads to terminate.
+
+ This package is similar to the
+ @threadmanager@, @async@ and @spawn@ packages.
+ The advantages of this package are:
+
+ * Simpler API.
+
+ * More efficient in both space and time.
+
+ * No space-leak when forking a large number of threads.
+
+ * Correct handling of asynchronous exceptions.
+
+ * GHC specific functionality like @forkOn@ and @forkIOWithUnmask@.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/threads/threads-0.5.0.2.ebuild b/dev-haskell/threads/threads-0.5.0.2.ebuild
new file mode 100644
index 000000000000..679e9d7c1f74
--- /dev/null
+++ b/dev-haskell/threads/threads-0.5.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/threads/threads-0.5.0.2.ebuild,v 1.1 2013/06/20 05:16:16 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fork threads and wait for their result"
+HOMEPAGE="https://github.com/basvandijk/threads"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base-unicode-symbols-0.1.1:=[profile?]
+ <dev-haskell/base-unicode-symbols-0.3:=[profile?]
+ >=dev-haskell/stm-2.1:=[profile?]
+ <dev-haskell/stm-2.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.9.2
+ test? ( >=dev-haskell/concurrent-extra-0.5.1
+ <dev-haskell/concurrent-extra-0.8
+ >=dev-haskell/hunit-1.2.2
+ <dev-haskell/hunit-1.3
+ >=dev-haskell/test-framework-0.2.4
+ <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.4
+ <dev-haskell/test-framework-hunit-0.4
+ )"