summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2006-08-15 00:28:59 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2006-08-15 00:28:59 +0000
commit0be0fe66bcdc6dc623be6fe6eadf09e3ccd975d2 (patch)
tree09fc611bf53b4d75f8273e6ad85ff8f18d39c8fd /dev-haskell
parent* bump (diff)
downloadgentoo-2-0be0fe66bcdc6dc623be6fe6eadf09e3ccd975d2.tar.gz
gentoo-2-0be0fe66bcdc6dc623be6fe6eadf09e3ccd975d2.tar.bz2
gentoo-2-0be0fe66bcdc6dc623be6fe6eadf09e3ccd975d2.zip
Adding new hsshellscript version
(Portage version: 2.1.1_pre5-r1)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hsshellscript/ChangeLog8
-rw-r--r--dev-haskell/hsshellscript/files/digest-hsshellscript-2.6.33
-rw-r--r--dev-haskell/hsshellscript/hsshellscript-2.6.3.ebuild50
3 files changed, 60 insertions, 1 deletions
diff --git a/dev-haskell/hsshellscript/ChangeLog b/dev-haskell/hsshellscript/ChangeLog
index e3f05049d9c5..96abb61b7593 100644
--- a/dev-haskell/hsshellscript/ChangeLog
+++ b/dev-haskell/hsshellscript/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/hsshellscript
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/ChangeLog,v 1.12 2006/04/20 10:49:32 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/ChangeLog,v 1.13 2006/08/15 00:28:58 araujo Exp $
+
+*hsshellscript-2.6.3 (15 Aug 2006)
+
+ 15 Aug 2006; Luis F. Araujo <araujo@gentoo.org>
+ +hsshellscript-2.6.3.ebuild:
+ Adding new version of hsshellscript.
20 Apr 2006; Andres Loeh <kosmikus@gentoo.org> hsshellscript-2.6.0.ebuild:
Moved setup code to pkg_setup, hopefully fixing bug #130553.
diff --git a/dev-haskell/hsshellscript/files/digest-hsshellscript-2.6.3 b/dev-haskell/hsshellscript/files/digest-hsshellscript-2.6.3
new file mode 100644
index 000000000000..e877565dc54f
--- /dev/null
+++ b/dev-haskell/hsshellscript/files/digest-hsshellscript-2.6.3
@@ -0,0 +1,3 @@
+MD5 1b7464138803c7dca9f27bd93917c91c hsshellscript-2.6.3.tar.gz 153029
+RMD160 7fc9f769ae7aecafcbd9c839836f554b46e9b1d6 hsshellscript-2.6.3.tar.gz 153029
+SHA256 8ba7af080cdca0dd2e6f98014fb67855c16bbafe56fc657b48b148e2a08c2762 hsshellscript-2.6.3.tar.gz 153029
diff --git a/dev-haskell/hsshellscript/hsshellscript-2.6.3.ebuild b/dev-haskell/hsshellscript/hsshellscript-2.6.3.ebuild
new file mode 100644
index 000000000000..5b624c5f0a97
--- /dev/null
+++ b/dev-haskell/hsshellscript/hsshellscript-2.6.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/hsshellscript-2.6.3.ebuild,v 1.1 2006/08/15 00:28:58 araujo Exp $
+
+inherit base eutils multilib ghc-package
+
+DESCRIPTION="A Haskell library for UNIX shell scripting tasks"
+HOMEPAGE="http://www.volker-wysk.de/hsshellscript/"
+SRC_URI="http://www.volker-wysk.de/hsshellscript/dist/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~ppc ~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=virtual/ghc-6.4
+ >=dev-libs/glib-2.0
+ >=dev-haskell/haddock-0.6"
+RDEPEND=""
+
+pkg_setup() {
+ HSLIB="/usr/$(get_libdir)/${P}/ghc-$(ghc-version)/"
+}
+
+src_unpack() {
+ base_src_unpack
+ # Don't register the package
+ sed -i "/ghc-pkg/d" "${S}/Makefile"
+ # Fix hsshellscript.cabal library path
+ sed -i "s:@DEST_LIB:${HSLIB}:" "${S}/lib/hsshellscript.cabal"
+ sed -i "s:@DEST_IMPORTS:${HSLIB}/imports:" "${S}/lib/hsshellscript.cabal"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ # we register the .cabal file generated by make
+ ghc-setup-pkg "${S}/build/hsshellscript.cabal"
+ emake install \
+ DESTDIR="${D}" \
+ DEST_LIB="${HSLIB}" \
+ DEST_IMPORTS="${HSLIB}/imports" \
+ DEST_DOC="/usr/share/doc/${PF}" \
+ || die "make failed"
+ ghc-makeghcilib "${D}/${HSLIB}/libhsshellscript.a"
+ ghc-install-pkg
+ fperms 0644 "${HSLIB}/imports/hsshellscript.h"
+}