summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-12-04 17:49:25 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-12-04 17:49:25 +0000
commit5bc738fe2abda14956a7c857fc054e192964ae63 (patch)
tree47fd61b135ab0dc66b486d2ed441daf65d8452ca /dev-haskell
parentDrop alpha/ia64/sparc keywords (diff)
downloadgentoo-2-5bc738fe2abda14956a7c857fc054e192964ae63.tar.gz
gentoo-2-5bc738fe2abda14956a7c857fc054e192964ae63.tar.bz2
gentoo-2-5bc738fe2abda14956a7c857fc054e192964ae63.zip
Initian version. Implementations of the SHA suite of message digest functions (dev-vcs/git-annex depend)
(Portage version: 2.2.0_alpha77_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/sha/ChangeLog11
-rw-r--r--dev-haskell/sha/Manifest3
-rw-r--r--dev-haskell/sha/metadata.xml17
-rw-r--r--dev-haskell/sha/sha-1.5.0.0.ebuild29
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-haskell/sha/ChangeLog b/dev-haskell/sha/ChangeLog
new file mode 100644
index 000000000000..528454825772
--- /dev/null
+++ b/dev-haskell/sha/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-haskell/sha
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/sha/ChangeLog,v 1.1 2011/12/04 17:49:25 slyfox Exp $
+
+*sha-1.5.0.0 (04 Dec 2011)
+
+ 04 Dec 2011; Sergei Trofimovich <slyfox@gentoo.org> +metadata.xml,
+ +sha-1.5.0.0.ebuild:
+ Initian version. Implementations of the SHA suite of message digest functions
+ (dev-vcs/git-annex depend)
+
diff --git a/dev-haskell/sha/Manifest b/dev-haskell/sha/Manifest
new file mode 100644
index 000000000000..194425164828
--- /dev/null
+++ b/dev-haskell/sha/Manifest
@@ -0,0 +1,3 @@
+DIST SHA-1.5.0.0.tar.gz 2714032 RMD160 c0347e52366c50116dbb3e7e17ac3439e6ee0ff2 SHA1 397a1ff44b098d22f862ccae1a34e861d94b3b86 SHA256 9361cf9dffb8640e435b7b61bc4922c7bdf4c26d96bb42de423ede4a570b5f8b
+EBUILD sha-1.5.0.0.ebuild 674 RMD160 75fcf706056bb38eed7293b0ffea496d3d49943a SHA1 63262fb1743c953aff61380f4d445f8973da5579 SHA256 da00b51ab2d92a401d330e51c44625c924d363f347f2c41107d6a34ba878eb56
+MISC metadata.xml 677 RMD160 3d4ab9c4d332f77135fa85ec2352099260db7fa7 SHA1 e9ff37034e0d459018fdd4951816d1c4aaa7eeea SHA256 5fffce9afd721638598f7588485d6ad8757574f2010bfed2c6e205bc68001402
diff --git a/dev-haskell/sha/metadata.xml b/dev-haskell/sha/metadata.xml
new file mode 100644
index 000000000000..b3a30d785b5d
--- /dev/null
+++ b/dev-haskell/sha/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This library implements the SHA suite of message digest functions,
+ according to NIST FIPS 180-2 (with the SHA-224 addendum), as well
+ as the SHA-based HMAC routines. The functions have been tested
+ against most of the NIST and RFC test vectors for the various
+ functions. While some attention has been paid to performance,
+ these do not presently reach the speed of well-tuned libraries,
+ like OpenSSL.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/sha/sha-1.5.0.0.ebuild b/dev-haskell/sha/sha-1.5.0.0.ebuild
new file mode 100644
index 000000000000..ec6b422aaf3b
--- /dev/null
+++ b/dev-haskell/sha/sha-1.5.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/sha/sha-1.5.0.0.ebuild,v 1.1 2011/12/04 17:49:25 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="SHA"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Implementations of the SHA suite of message digest functions"
+HOMEPAGE="http://hackage.haskell.org/package/sha"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/binary
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"