summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2008-05-25 11:17:06 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2008-05-25 11:17:06 +0000
commitaa7e0d0632e7b6f6611663fa3e76382ecb82b0fb (patch)
tree6e78a6aeae22849b13cef7aa3522d468c5500cfc /dev-haskell
parentAdd USE="xinerama" to most recent dev-haskell/x11 versions. This fixes bug #2... (diff)
downloadgentoo-2-aa7e0d0632e7b6f6611663fa3e76382ecb82b0fb.tar.gz
gentoo-2-aa7e0d0632e7b6f6611663fa3e76382ecb82b0fb.tar.bz2
gentoo-2-aa7e0d0632e7b6f6611663fa3e76382ecb82b0fb.zip
Bump dev-haskell/x11 to 1.4.2.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/x11/ChangeLog7
-rw-r--r--dev-haskell/x11/x11-1.4.2.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-haskell/x11/ChangeLog b/dev-haskell/x11/ChangeLog
index b393f84c1d42..55727793e892 100644
--- a/dev-haskell/x11/ChangeLog
+++ b/dev-haskell/x11/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/x11
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/ChangeLog,v 1.7 2008/05/25 11:14:18 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/ChangeLog,v 1.8 2008/05/25 11:17:06 kolmodin Exp $
+
+*x11-1.4.2 (25 May 2008)
+
+ 25 May 2008; Lennart Kolmodin <kolmodin@gentoo.org> +x11-1.4.2.ebuild:
+ Version bump.
25 May 2008; Lennart Kolmodin <kolmodin@gentoo.org> x11-1.2.1.ebuild,
x11-1.4.0.ebuild, x11-1.4.1.ebuild:
diff --git a/dev-haskell/x11/x11-1.4.2.ebuild b/dev-haskell/x11/x11-1.4.2.ebuild
new file mode 100644
index 000000000000..73f34edb4c05
--- /dev/null
+++ b/dev-haskell/x11/x11-1.4.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/x11-1.4.2.ebuild,v 1.1 2008/05/25 11:17:06 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal eutils autotools
+
+MY_PN="X11"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A binding to the X11 graphics library"
+HOMEPAGE="http://darcs.haskell.org/X11"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="xinerama"
+
+DEPEND=">=dev-lang/ghc-6.4.2
+ >=dev-haskell/cabal-1.2.3.0
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack $A
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-with-xinerama.patch"
+ eautoreconf
+}
+
+src_compile() {
+ CABAL_CONFIGURE_FLAGS="--configure-option=$(use_with xinerama)"
+ cabal_src_compile
+}