summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-11-18 22:30:35 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-11-18 22:30:35 +0000
commitd90082b3c6b12b079fc7b084c3be29522c1cc1f3 (patch)
treee1c630fd9e74b8322db704c72d4a9328a83a0605 /dev-haskell
parentWe don't need no stinky libstdc++-v3 on MIPS. Not to mention that 3.4.3 can't... (diff)
downloadgentoo-2-d90082b3c6b12b079fc7b084c3be29522c1cc1f3.tar.gz
gentoo-2-d90082b3c6b12b079fc7b084c3be29522c1cc1f3.tar.bz2
gentoo-2-d90082b3c6b12b079fc7b084c3be29522c1cc1f3.zip
Initial import, as suggested in bug #69995.
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/drift/ChangeLog10
-rw-r--r--dev-haskell/drift/Manifest2
-rw-r--r--dev-haskell/drift/drift-2.0.4.ebuild33
-rw-r--r--dev-haskell/drift/files/digest-drift-2.0.41
-rw-r--r--dev-haskell/drift/metadata.xml8
5 files changed, 54 insertions, 0 deletions
diff --git a/dev-haskell/drift/ChangeLog b/dev-haskell/drift/ChangeLog
new file mode 100644
index 000000000000..dabe2b7b484b
--- /dev/null
+++ b/dev-haskell/drift/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-haskell/drift
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/drift/ChangeLog,v 1.1 2004/11/18 22:30:35 kosmikus Exp $
+
+*drift-2.0.4 (18 Nov 2004)
+
+ 18 Nov 2004; Andres Loeh <kosmikus@gentoo.org> +metadata.xml,
+ +drift-2.0.4.ebuild:
+ Initial import, as suggested in bug #69995.
+
diff --git a/dev-haskell/drift/Manifest b/dev-haskell/drift/Manifest
new file mode 100644
index 000000000000..1ec186d4680e
--- /dev/null
+++ b/dev-haskell/drift/Manifest
@@ -0,0 +1,2 @@
+MD5 5a881848fcaba77cb5d7fabd6d314fa9 drift-2.0.4.ebuild 658
+MD5 ef4178698c778fa0dad69a79526d4a86 files/digest-drift-2.0.4 63
diff --git a/dev-haskell/drift/drift-2.0.4.ebuild b/dev-haskell/drift/drift-2.0.4.ebuild
new file mode 100644
index 000000000000..4984ddbf3778
--- /dev/null
+++ b/dev-haskell/drift/drift-2.0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/drift/drift-2.0.4.ebuild,v 1.1 2004/11/18 22:30:35 kosmikus Exp $
+
+inherit ghc-package
+
+MY_PN="DrIFT"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Preprocessor for automatic derivation of Haskell class instances"
+HOMEPAGE="http://repetae.net/john/computer/haskell/${MY_PN}/"
+SRC_URI="http://repetae.net/john/computer/haskell/${MY_PN}/drop/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=">=virtual/ghc-6"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf --with-hc="$(ghc-getghc)" || die "configure failed"
+ # Makefile has no parallelism
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}
diff --git a/dev-haskell/drift/files/digest-drift-2.0.4 b/dev-haskell/drift/files/digest-drift-2.0.4
new file mode 100644
index 000000000000..8d944fe2736e
--- /dev/null
+++ b/dev-haskell/drift/files/digest-drift-2.0.4
@@ -0,0 +1 @@
+MD5 4b7e6928bdd4310ae53b99e93ef5b9f2 DrIFT-2.0.4.tar.gz 215283
diff --git a/dev-haskell/drift/metadata.xml b/dev-haskell/drift/metadata.xml
new file mode 100644
index 000000000000..a53a18c06081
--- /dev/null
+++ b/dev-haskell/drift/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>haskell</herd>
+<maintainer>
+ <email>kosmikus@gentoo.org</email>
+</maintainer>
+</pkgmetadata>