summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-11-30 08:04:04 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-11-30 08:04:04 +0000
commitfd7f9a06c8cbafea794d62aa1d5a35cd13b7bea4 (patch)
treee3299d7f24c6485b6c9504cacf26bd9219ff1b5b /dev-java/asm
parentmetadata.xml; added herd, python-keystoneclient-0.3.2; upgraded test phase, r... (diff)
downloadgentoo-2-fd7f9a06c8cbafea794d62aa1d5a35cd13b7bea4.tar.gz
gentoo-2-fd7f9a06c8cbafea794d62aa1d5a35cd13b7bea4.tar.bz2
gentoo-2-fd7f9a06c8cbafea794d62aa1d5a35cd13b7bea4.zip
Quoted S variable. Indented metadata.xml.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/asm')
-rw-r--r--dev-java/asm/ChangeLog6
-rw-r--r--dev-java/asm/asm-1.4.3-r3.ebuild9
-rw-r--r--dev-java/asm/metadata.xml28
3 files changed, 26 insertions, 17 deletions
diff --git a/dev-java/asm/ChangeLog b/dev-java/asm/ChangeLog
index 4247e0c199d2..100c7da3ba72 100644
--- a/dev-java/asm/ChangeLog
+++ b/dev-java/asm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/asm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/asm/ChangeLog,v 1.86 2013/09/16 19:12:03 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/asm/ChangeLog,v 1.87 2013/11/30 08:04:04 tomwij Exp $
+
+ 30 Nov 2013; Tom Wijsman <TomWij@gentoo.org> asm-1.4.3-r3.ebuild,
+ metadata.xml:
+ Quoted S variable. Indented metadata.xml.
*asm-1.4.3-r4 (16 Sep 2013)
*asm-1.5.3-r1 (16 Sep 2013)
diff --git a/dev-java/asm/asm-1.4.3-r3.ebuild b/dev-java/asm/asm-1.4.3-r3.ebuild
index 1b1b023bd873..f5ec3cb65089 100644
--- a/dev-java/asm/asm-1.4.3-r3.ebuild
+++ b/dev-java/asm/asm-1.4.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/asm/asm-1.4.3-r3.ebuild,v 1.12 2013/09/01 09:30:56 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/asm/asm-1.4.3-r3.ebuild,v 1.13 2013/11/30 08:04:04 tomwij Exp $
JAVA_PKG_IUSE="doc source"
@@ -9,19 +9,23 @@ inherit java-pkg-2 java-ant-2
DESCRIPTION="Bytecode manipulation framework for Java"
HOMEPAGE="http://asm.objectweb.org"
SRC_URI="http://download.forge.objectweb.org/${PN}/${P}.tar.gz"
+
LICENSE="BSD"
SLOT="1.4"
KEYWORDS="amd64 ppc ppc64 x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
IUSE=""
+
DEPEND=">=virtual/jdk-1.3
dev-java/ant-core
dev-java/ant-owanttask"
RDEPEND=">=virtual/jre-1.3"
+
RESTRICT="test"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
echo "objectweb.ant.tasks.path /usr/share/ant-owanttask/lib/ow_util_ant_tasks.jar" \
>> build.properties
}
@@ -34,6 +38,7 @@ src_install() {
for x in output/dist/lib/*.jar ; do
java-pkg_newjar ${x} $(basename ${x/-${PV}})
done
+
use doc && java-pkg_dohtml -r output/dist/doc/javadoc/user/*
use source && java-pkg_dosrc src/*
}
diff --git a/dev-java/asm/metadata.xml b/dev-java/asm/metadata.xml
index 22a451862693..d399bf77554e 100644
--- a/dev-java/asm/metadata.xml
+++ b/dev-java/asm/metadata.xml
@@ -2,20 +2,20 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>java</herd>
+ <herd>java</herd>
-<longdescription>
-ASM is a Java bytecode manipulation framework. It can be used to
-dynamically generate stub classes or other proxy classes, directly in
-binary form, or to dynamically modify classes at load time, i.e., just
-before they are loaded into the Java Virtual Machine.
+ <longdescription>
+ ASM is a Java bytecode manipulation framework. It can be used to
+ dynamically generate stub classes or other proxy classes, directly in
+ binary form, or to dynamically modify classes at load time, i.e., just
+ before they are loaded into the Java Virtual Machine.
-ASM offers similar functionalities as BCEL or SERP, but is much more
-smaller (25KB instead of 350KB for BCEL and 150KB for SERP) and faster
-than these tools (the overhead of a load time class transformation is of
-the order of 60% with ASM, 700% or more with BCEL, and 1100% or more
-with SERP). Indeed ASM was designed to be used in a dynamic way* and was
-therefore designed and implemented to be as small and as fast as
-possible.
-</longdescription>
+ ASM offers similar functionalities as BCEL or SERP, but is much more
+ smaller (25KB instead of 350KB for BCEL and 150KB for SERP) and faster
+ than these tools (the overhead of a load time class transformation is of
+ the order of 60% with ASM, 700% or more with BCEL, and 1100% or more
+ with SERP). Indeed ASM was designed to be used in a dynamic way* and was
+ therefore designed and implemented to be as small and as fast as
+ possible.
+ </longdescription>
</pkgmetadata>