summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-09-10 16:07:19 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-09-10 16:07:19 +0000
commit785f4e68b152ad4759de1913e6bed0f831cc8f83 (patch)
tree9ccd10770fc40729a03611b85aa252781831051c /dev-java/batik
parentwhite space fix (diff)
downloadgentoo-2-785f4e68b152ad4759de1913e6bed0f831cc8f83.tar.gz
gentoo-2-785f4e68b152ad4759de1913e6bed0f831cc8f83.tar.bz2
gentoo-2-785f4e68b152ad4759de1913e6bed0f831cc8f83.zip
Version bump, thanks too Josh Nichols in 101844
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-java/batik')
-rw-r--r--dev-java/batik/ChangeLog8
-rw-r--r--dev-java/batik/Manifest19
-rw-r--r--dev-java/batik/batik-1.6.ebuild70
-rw-r--r--dev-java/batik/files/batik-1.6-jikes.patch30
-rw-r--r--dev-java/batik/files/digest-batik-1.61
5 files changed, 114 insertions, 14 deletions
diff --git a/dev-java/batik/ChangeLog b/dev-java/batik/ChangeLog
index b40942ace0eb..72144498f5a3 100644
--- a/dev-java/batik/ChangeLog
+++ b/dev-java/batik/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/batik
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/batik/ChangeLog,v 1.26 2005/08/26 13:15:33 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/batik/ChangeLog,v 1.27 2005/09/10 16:07:19 axxo Exp $
+
+*batik-1.6 (10 Sep 2005)
+
+ 10 Sep 2005; Thomas Matthijs <axxo@gentoo.org>
+ +files/batik-1.6-jikes.patch, +batik-1.6.ebuild:
+ Version bump, thanks too Josh Nichols in 101844
26 Aug 2005; Diego Pettenò <flameeyes@gentoo.org> batik-1.5.1-r4.ebuild:
Fix cp -a usage for Gentoo/FreeBSD.
diff --git a/dev-java/batik/Manifest b/dev-java/batik/Manifest
index 2446e2d137e1..0a6a79360a89 100644
--- a/dev-java/batik/Manifest
+++ b/dev-java/batik/Manifest
@@ -1,16 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 897ff0218d3fb0146b1020cf3ba81532 batik-1.6.ebuild 1685
MD5 b087293c51969cbebba76f2c6ff134dc ChangeLog 3221
-MD5 feea67feb4d07019ef9cc08ef1cf41df batik-1.5.ebuild 1742
-MD5 cd9726dba2d7ec03d52ef50129eaab99 batik-1.5.1-r4.ebuild 1747
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
-MD5 2773f6aa10bcb901bd07ea509571ccef files/digest-batik-1.5.1-r4 66
+MD5 cd9726dba2d7ec03d52ef50129eaab99 batik-1.5.1-r4.ebuild 1747
+MD5 feea67feb4d07019ef9cc08ef1cf41df batik-1.5.ebuild 1742
MD5 479ed0922a69b318b40b485614a6af16 files/digest-batik-1.5 63
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDDxYTj5H05b2HAEkRAtHeAJ4vtjzxQV80aganXVdnMTFPKaARRgCfcub1
-bQTTN7iIXAO59Rvx5YRY1YE=
-=C0qV
------END PGP SIGNATURE-----
+MD5 a929b00b059832c13cf91cc68c2cecf1 files/digest-batik-1.6 64
+MD5 88405976cca078c6468469f91d2ff161 files/batik-1.6-jikes.patch 1738
+MD5 2773f6aa10bcb901bd07ea509571ccef files/digest-batik-1.5.1-r4 66
diff --git a/dev-java/batik/batik-1.6.ebuild b/dev-java/batik/batik-1.6.ebuild
new file mode 100644
index 000000000000..c950e95df4f8
--- /dev/null
+++ b/dev-java/batik/batik-1.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/batik/batik-1.6.ebuild,v 1.1 2005/09/10 16:07:19 axxo Exp $
+
+inherit java-pkg eutils
+
+DESCRIPTION="A Java toolkit to use images in the Scalable Vector Graphics (SVG) format for various purposes, such as viewing, generation or manipulation."
+HOMEPAGE="http://xml.apache.org/batik/"
+SRC_URI="mirror://apache/xml/batik/${PN}-src-${PV}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="1.6"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc jikes"
+
+RDEPEND=">=virtual/jre-1.3
+ =dev-java/rhino-1.5*
+ dev-java/xml-commons"
+DEPEND=">=virtual/jdk-1.3
+ ${RDEPEND}
+ app-arch/unzip
+ dev-java/ant-core"
+
+S=${WORKDIR}/xml-batik
+
+src_unpack() {
+ unpack ${A}
+
+ use jikes && epatch ${FILESDIR}/${P}-jikes.patch
+
+ cd ${S}/lib && rm -f *.jar
+ java-pkg_jar-from rhino-1.5
+ java-pkg_jar-from xml-commons
+}
+
+src_compile() {
+ local antflags="jars all-jar"
+ use doc && antflags="${antflags} javadoc"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+
+ ant ${antflags} || die "compile problem"
+}
+
+src_install() {
+ java-pkg_dojar ${P}/batik*.jar
+
+ cd ${P}/lib
+ rm {js,x*}.jar
+
+ # needed because batik expects this layout:
+ # batik.jar lib/*.jar
+ # there are hardcoded classpathes in the manifest :(
+ for jar in *.jar
+ do
+ java-pkg_dojar ${jar}
+ rm -f ${jar}
+ ln -s ${DESTTREE}/share/${PN}-${SLOT}/lib/${jar} ${jar}
+ done
+
+ cd ${S}
+ cp -pPR ${P}/lib ${D}${DESTTREE}/share/${PN}-${SLOT}/lib/
+
+ dodoc README
+ use doc && java-pkg_dohtml -r ${P}/docs/api xdocs/*
+
+ echo "#!/bin/sh" > ${PN}${SLOT}
+ echo '${JAVA_HOME}/bin/java -classpath $(java-config -p batik-1.6,xml-commons,rhino-1.5) org.apache.batik.apps.svgbrowser.Main $*' >> ${PN}${SLOT}
+ dobin ${PN}${SLOT}
+
+}
diff --git a/dev-java/batik/files/batik-1.6-jikes.patch b/dev-java/batik/files/batik-1.6-jikes.patch
new file mode 100644
index 000000000000..25e3751e99aa
--- /dev/null
+++ b/dev-java/batik/files/batik-1.6-jikes.patch
@@ -0,0 +1,30 @@
+diff -ru xml-batik/sources/org/apache/batik/ext/awt/image/rendered/LRUCache.java xml-batik-patched/sources/org/apache/batik/ext/awt/image/rendered/LRUCache.java
+--- xml-batik/sources/org/apache/batik/ext/awt/image/rendered/LRUCache.java 2004-08-18 03:14:08.000000000 -0400
++++ xml-batik-patched/sources/org/apache/batik/ext/awt/image/rendered/LRUCache.java 2005-08-09 19:18:20.000000000 -0400
+@@ -33,12 +33,12 @@
+ * should be remembered so it can be returned by
+ * <tt>lruGet</tt>.
+ */
+- public void lruSet(LRUNode nde);
++ public void lruSet(LRUCache.LRUNode nde);
+ /**
+ * Called to get the LRU node for this object. Should return the
+ * node passed in to lruSet.
+ */
+- public LRUNode lruGet();
++ public LRUCache.LRUNode lruGet();
+ /**
+ * Called to inform the object that it is no longer in the cache.
+ */
+diff -ru xml-batik/sources/org/apache/batik/script/rhino/RhinoInterpreter.java xml-batik-patched/sources/org/apache/batik/script/rhino/RhinoInterpreter.java
+--- xml-batik/sources/org/apache/batik/script/rhino/RhinoInterpreter.java 2005-03-29 05:48:02.000000000 -0500
++++ xml-batik-patched/sources/org/apache/batik/script/rhino/RhinoInterpreter.java 2005-08-09 19:16:33.000000000 -0400
+@@ -418,7 +418,7 @@
+ public Object get(ScriptableObject so) {
+ Context ctx = Context.getCurrentContext();
+ if (ctx == null ) return null;
+- return ((ExtendedContext)ctx).getInterpreter().objects.get(name);
++ return ((RhinoInterpreter.ExtendedContext)ctx).getInterpreter().objects.get(name);
+ }
+ }
+ // The method to use for getting the value from the
diff --git a/dev-java/batik/files/digest-batik-1.6 b/dev-java/batik/files/digest-batik-1.6
new file mode 100644
index 000000000000..ad72fccf206c
--- /dev/null
+++ b/dev-java/batik/files/digest-batik-1.6
@@ -0,0 +1 @@
+MD5 b65e12f520f8342605f700204c96cd2b batik-src-1.6.zip 10199668