summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-03-31 23:38:14 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-03-31 23:38:14 +0000
commite1bd92d08c529f39237307385b4495c42ed8f7b0 (patch)
tree4f9c5f2d8b8d0cc5fc5f14092ba99d2eecd76d47 /dev-java/commons-cli
parentapp-admin/setools: Update with fixes for glibc 2.7, gcc 3.4, and tcl/tk 8.5. (diff)
downloadgentoo-2-e1bd92d08c529f39237307385b4495c42ed8f7b0.tar.gz
gentoo-2-e1bd92d08c529f39237307385b4495c42ed8f7b0.tar.bz2
gentoo-2-e1bd92d08c529f39237307385b4495c42ed8f7b0.zip
Version bump. Fixes bug #215609.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-java/commons-cli')
-rw-r--r--dev-java/commons-cli/ChangeLog10
-rw-r--r--dev-java/commons-cli/commons-cli-1.1.ebuild33
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-java/commons-cli/ChangeLog b/dev-java/commons-cli/ChangeLog
index 67a170b4fac0..953162fd8290 100644
--- a/dev-java/commons-cli/ChangeLog
+++ b/dev-java/commons-cli/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-cli
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/ChangeLog,v 1.34 2007/08/03 15:30:33 betelgeuse Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/ChangeLog,v 1.35 2008/03/31 23:38:14 betelgeuse Exp $
+
+*commons-cli-1.1 (31 Mar 2008)
+
+ 31 Mar 2008; Petteri Räty <betelgeuse@gentoo.org>
+ +commons-cli-1.1.ebuild:
+ Version bump. Fixes bug #215609.
03 Aug 2007; Petteri Räty <betelgeuse@gentoo.org>
commons-cli-1.0-r5.ebuild:
diff --git a/dev-java/commons-cli/commons-cli-1.1.ebuild b/dev-java/commons-cli/commons-cli-1.1.ebuild
new file mode 100644
index 000000000000..ba79edf4aaea
--- /dev/null
+++ b/dev-java/commons-cli/commons-cli-1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/commons-cli-1.1.ebuild,v 1.1 2008/03/31 23:38:14 betelgeuse Exp $
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="A Java library for working with the command line arguments and options."
+HOMEPAGE="http://commons.apache.org/cli/"
+MY_P=${P}-src
+SRC_URI="mirror://apache/commons/cli/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit )"
+
+S=${WORKDIR}/${MY_P}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ dodoc README.txt RELEASE-NOTES.txt || die
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/org
+}