summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-05-29 12:44:02 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-05-29 12:44:02 +0000
commit115b58bd4bd5799bf6ff647fbaa124be1451ee79 (patch)
treed897f30a89288f6d2e879ca4f27d81d9e2e63164 /dev-java/commons-math
parentrevbump. migrate -> distutils-r1, remove old ebuild (diff)
downloadgentoo-2-115b58bd4bd5799bf6ff647fbaa124be1451ee79.tar.gz
gentoo-2-115b58bd4bd5799bf6ff647fbaa124be1451ee79.tar.bz2
gentoo-2-115b58bd4bd5799bf6ff647fbaa124be1451ee79.zip
Version bump to 3.2.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/commons-math')
-rw-r--r--dev-java/commons-math/ChangeLog11
-rw-r--r--dev-java/commons-math/commons-math-3.2.ebuild54
-rw-r--r--dev-java/commons-math/files/commons-math-3.2-build.xml288
3 files changed, 350 insertions, 3 deletions
diff --git a/dev-java/commons-math/ChangeLog b/dev-java/commons-math/ChangeLog
index 72724ed97bfc..26870e7bdab4 100644
--- a/dev-java/commons-math/ChangeLog
+++ b/dev-java/commons-math/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-math
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-math/ChangeLog,v 1.8 2010/12/12 06:36:02 ken69267 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-math/ChangeLog,v 1.9 2013/05/29 12:44:02 tomwij Exp $
+
+*commons-math-3.2 (29 May 2013)
+
+ 29 May 2013; Tom Wijsman <TomWij@gentoo.org> +commons-math-3.2.ebuild,
+ +files/commons-math-3.2-build.xml:
+ Version bump to 3.2.
12 Dec 2010; Kenneth Prugh <ken69267@gentoo.org>
commons-math-2.1-r1.ebuild:
@@ -43,4 +49,3 @@
02 Oct 2009; Andrey Kislyuk <weaver@gentoo.org> +metadata.xml,
+commons-math-1.2.ebuild, +commons-math-2.0.ebuild:
Import from Java overlay and rewrite
-
diff --git a/dev-java/commons-math/commons-math-3.2.ebuild b/dev-java/commons-math/commons-math-3.2.ebuild
new file mode 100644
index 000000000000..01d955094677
--- /dev/null
+++ b/dev-java/commons-math/commons-math-3.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-math/commons-math-3.2.ebuild,v 1.1 2013/05/29 12:44:02 tomwij Exp $
+
+EAPI="5"
+
+# Tests are currently broken due to nasty -lib argument.
+JAVA_PKG_IUSE="doc source" # test
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+MY_PN="${PN}3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
+HOMEPAGE="http://commons.apache.org/math/"
+SRC_URI="mirror://apache/commons/math/source/${MY_P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.5"
+
+# Tests are currently broken due to nasty -lib argument.
+# test? (
+# dev-java/ant-junit4
+# dev-java/hamcrest-core:0
+# )"
+
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/${MY_P}-src"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+
+ sed -i 's/manifest=".*MANIFEST.MF"//g' build.xml || die
+ sed -i '/name="Main-Class"/d' build.xml || die
+}
+
+# Tests are currently broken due to nasty -lib argument.
+# src_test() {
+# java-pkg_jar-from junit-4
+# java-pkg_jar-from hamcrest-core
+# ANT_TASKS="ant-junit4" eant -Djunit.jar=junit.jar test
+# }
+
+src_install() {
+ java-osgi_newjar target/${MY_P}.jar ${MY_PN} ${MY_PN} "Export-Package: ${MY_PN}"
+
+ use doc && java-pkg_dojavadoc target/apidocs
+ use source && java-pkg_dosrc src/main/java/org
+}
diff --git a/dev-java/commons-math/files/commons-math-3.2-build.xml b/dev-java/commons-math/files/commons-math-3.2-build.xml
new file mode 100644
index 000000000000..905d12657e26
--- /dev/null
+++ b/dev-java/commons-math/files/commons-math-3.2-build.xml
@@ -0,0 +1,288 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 5/29/13 1:59 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="commons-math3-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="commons-math3-3.2"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.resourceDir.1" value="."/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.build.testResourceDir.1" value="."/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.1}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ <mkdir dir="${maven.build.testOutputDir}/META-INF"/>
+ <copy todir="${maven.build.testOutputDir}/META-INF">
+ <fileset dir="${maven.build.testResourceDir.1}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/*Test.java"/>
+ <include name="**/*TestBinary.java"/>
+ <include name="**/*TestPermutations.java"/>
+ <exclude name="**/*AbstractTest.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*AbstractTest.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="UTF-8"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ docencoding="UTF-8"
+ source="1.5"
+ linksource="true"
+ breakiterator="false">
+ <link href="http://download.oracle.com/javase/6/docs/api/"/>
+ <link href="http://download.oracle.com/javaee/6/api/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ manifest="/var/tmp/portage/dev-java/commons-math-3.2/work/commons-math3-3.2-src/target/osgi/MANIFEST.MF"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ <manifest>
+ <attribute name="Main-Class"/>
+ </manifest>
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.10"/>
+ <get src="http://repository.apache.org/snapshots/junit/junit/4.10/junit-4.10.jar"
+ dest="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.10/junit-4.10.jar"
+ dest="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1"/>
+ <get src="http://repository.apache.org/snapshots/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>