summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2012-02-23 20:31:30 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2012-02-23 20:31:30 +0000
commit606e7a8fa97db7b80670a2c3a49a30c9b80ac844 (patch)
tree9840c83e8a234575fe47707cd298cc35b0153ced /dev-java/css-validator
parentremove old (diff)
downloadgentoo-2-606e7a8fa97db7b80670a2c3a49a30c9b80ac844.tar.gz
gentoo-2-606e7a8fa97db7b80670a2c3a49a30c9b80ac844.tar.bz2
gentoo-2-606e7a8fa97db7b80670a2c3a49a30c9b80ac844.zip
Initial version of htmlparser: Check Cascading Style Sheets (CSS) and (X)HTML documents with style sheets.
(Portage version: 2.1.10.47/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/css-validator')
-rw-r--r--dev-java/css-validator/ChangeLog12
-rw-r--r--dev-java/css-validator/css-validator-20120222.ebuild78
-rw-r--r--dev-java/css-validator/files/css-validator-20120222-build.xml.patch37
-rw-r--r--dev-java/css-validator/metadata.xml8
4 files changed, 135 insertions, 0 deletions
diff --git a/dev-java/css-validator/ChangeLog b/dev-java/css-validator/ChangeLog
new file mode 100644
index 000000000000..84232df93786
--- /dev/null
+++ b/dev-java/css-validator/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-java/css-validator
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/css-validator/ChangeLog,v 1.1 2012/02/23 20:31:30 nelchael Exp $
+
+*css-validator-20120222 (23 Feb 2012)
+
+ 23 Feb 2012; Krzysztof Pawlik <nelchael@gentoo.org>
+ +css-validator-20120222.ebuild,
+ +files/css-validator-20120222-build.xml.patch, +metadata.xml:
+ Initial version of htmlparser: Check Cascading Style Sheets (CSS) and (X)HTML
+ documents with style sheets.
+
diff --git a/dev-java/css-validator/css-validator-20120222.ebuild b/dev-java/css-validator/css-validator-20120222.ebuild
new file mode 100644
index 000000000000..256185e04150
--- /dev/null
+++ b/dev-java/css-validator/css-validator-20120222.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/css-validator/css-validator-20120222.ebuild,v 1.1 2012/02/23 20:31:30 nelchael Exp $
+
+EAPI=4
+
+JAVA_PKG_IUSE="doc source"
+
+# How to create the release tarball:
+# $ export CVSROOT=":pserver:anonymous@dev.w3.org:/sources/public"
+# $ cvs login
+# $ cvs get 2002/css-validator
+# $ cd 2002
+# $ tar jcf css-validator-$(date "+%Y%m%d") css-validator --exclude=CVS
+
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="Check Cascading Style Sheets (CSS) and (X)HTML documents with style sheets"
+HOMEPAGE="http://jigsaw.w3.org/css-validator/DOWNLOAD.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="W3C"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+COMMON_DEP="java-virtuals/servlet-api:2.5
+ dev-java/velocity
+ dev-java/commons-lang:2.1
+ dev-java/tagsoup
+ dev-java/jigsaw
+ dev-java/xerces:2
+ dev-java/htmlparser
+ "
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+EANT_BUILD_TARGET="jar war"
+EANT_DOC_TARGET="javadoc"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ rm -f tmp/*.jar
+ mkdir -p "${S}/lib" || die "mkdir failed"
+
+ epatch "${FILESDIR}/${P}-build.xml.patch"
+
+ java-pkg_jarfrom --into lib/ servlet-api-2.5
+ java-pkg_jarfrom --into lib/ velocity
+ java-pkg_jarfrom --into lib/ commons-lang-2.1
+ java-pkg_jarfrom --into lib/ tagsoup
+ java-pkg_jarfrom --into lib/ jigsaw
+ java-pkg_jarfrom --into lib/ xerces-2
+ java-pkg_jarfrom --into lib/ htmlparser
+}
+
+src_install() {
+ java-pkg_dojar "${PN}.jar"
+
+ use source && java-pkg_dosrc org
+ if use doc; then
+ java-pkg_dojavadoc javadoc
+
+ insinto "/usr/share/${PN}"
+ doins "${PN}.war"
+ einfo "Documentation for ${PN} has been installed as:"
+ einfo " /usr/share/${PN}/${PN}.war"
+ einfo "You need to deploy this file using one of:"
+ einfo " * www-servers/tomcat"
+ einfo " * www-servers/resin"
+ fi
+}
diff --git a/dev-java/css-validator/files/css-validator-20120222-build.xml.patch b/dev-java/css-validator/files/css-validator-20120222-build.xml.patch
new file mode 100644
index 000000000000..faedcd04396c
--- /dev/null
+++ b/dev-java/css-validator/files/css-validator-20120222-build.xml.patch
@@ -0,0 +1,37 @@
+Index: build.xml
+===================================================================
+RCS file: /sources/public/2002/css-validator/build.xml,v
+retrieving revision 1.23
+diff -u -r1.23 build.xml
+--- build.xml 1 Nov 2011 07:51:20 -0000 1.23
++++ build.xml 22 Feb 2012 23:57:47 -0000
+@@ -75,10 +75,10 @@
+ <copy file="tmp/htmlparser-1.3.1/htmlparser-1.3.1.jar" tofile="lib/htmlparser-1.3.1.jar"/>
+ </target>
+
+- <target name="build" description="Builds the validator" depends="prepare">
++ <target name="build" description="Builds the validator">
+ <mkdir dir="./build"/>
+ <javac classpathref="build.class.path" destdir="./build" encoding="UTF-8"
+- debug="yes" includes="org/w3c/**" srcdir="." source="1.6" target="1.6"/>
++ includes="org/w3c/**" srcdir="."/>
+ <copy todir="./build">
+ <fileset dir="./">
+ <include name="org/**"/>
+@@ -91,7 +91,7 @@
+ <target name="jigsaw" description="Builds the validator for Jigsaw" depends="prepare">
+ <mkdir dir="./build"/>
+ <javac classpathref="build.class.path" destdir="." encoding="UTF-8"
+- debug="yes" source="1.6" target="1.6">
++ >
+ <src path="./org/w3c"/>
+ </javac>
+ </target>
+@@ -99,6 +99,7 @@
+ <target name="javadoc" description="Generates API docs">
+ <mkdir dir="./javadoc"/>
+ <javadoc
++ classpathref="build.class.path"
+ packagenames="org.w3c.*"
+ sourcepath="./"
+ destdir="./javadoc"
diff --git a/dev-java/css-validator/metadata.xml b/dev-java/css-validator/metadata.xml
new file mode 100644
index 000000000000..ed8c1e2e7469
--- /dev/null
+++ b/dev-java/css-validator/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <maintainer>
+ <email>nelchael@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>