summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2015-01-11 16:11:57 +0000
committerJohann Schmitz <ercpe@gentoo.org>2015-01-11 16:11:57 +0000
commita13847f2b0d2713918ff7d5825b6674690279a9f (patch)
treef54aa6182a677c770acbb605c2140a212d245718 /dev-java/itext
parentVersion bump. Clean up old revision. (diff)
downloadgentoo-2-a13847f2b0d2713918ff7d5825b6674690279a9f.tar.gz
gentoo-2-a13847f2b0d2713918ff7d5825b6674690279a9f.tar.bz2
gentoo-2-a13847f2b0d2713918ff7d5825b6674690279a9f.zip
Version bump of dev-java/itext (bug #475552). Dropped old, broken :5 version. Removed unused patch file.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java/itext')
-rw-r--r--dev-java/itext/ChangeLog11
-rw-r--r--dev-java/itext/files/2.0.8-site_xml.patch12
-rw-r--r--dev-java/itext/itext-5.2.0.ebuild53
-rw-r--r--dev-java/itext/itext-5.5.4.ebuild43
4 files changed, 52 insertions, 67 deletions
diff --git a/dev-java/itext/ChangeLog b/dev-java/itext/ChangeLog
index 8ebe9e82bb81..aa21d0814763 100644
--- a/dev-java/itext/ChangeLog
+++ b/dev-java/itext/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/itext
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/itext/ChangeLog,v 1.102 2014/08/10 20:15:26 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/itext/ChangeLog,v 1.103 2015/01/11 16:11:57 ercpe Exp $
+
+*itext-5.5.4 (11 Jan 2015)
+
+ 11 Jan 2015; Johann Schmitz <ercpe@gentoo.org> +itext-5.5.4.ebuild,
+ -files/2.0.8-site_xml.patch, -itext-5.2.0.ebuild:
+ Version bump of dev-java/itext (bug #475552). Dropped old, broken :5 version.
+ Removed unused patch file.
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> itext-2.1.5-r2.ebuild,
itext-5.2.0.ebuild:
diff --git a/dev-java/itext/files/2.0.8-site_xml.patch b/dev-java/itext/files/2.0.8-site_xml.patch
deleted file mode 100644
index 6ea2af936725..000000000000
--- a/dev-java/itext/files/2.0.8-site_xml.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur itext-2.0.8_orig/work/src/ant/site.xml itext-2.0.8/work/src/ant/site.xml
---- itext-2.0.8_orig/work/src/ant/site.xml 2008-01-26 13:26:26.000000000 -0500
-+++ itext-2.0.8/work/src/ant/site.xml 2008-01-26 13:26:46.000000000 -0500
-@@ -67,8 +67,6 @@
- <include name="com/lowagie/**" />
- </packageset>
- <classpath refid="itext.classpath"/>
-- <link href="http://java.sun.com/j2se/1.4/docs/api/" />
-- <link href="http://www.bouncycastle.org/docs/docs1.4/" />
- <header>&lt;a href="http://itext.ugent.be/itext-in-action/" target="_blank"&gt;&lt;img src="http://itext.ugent.be/img/lowagie_3d.jpg" border="0" /&gt;&lt;/a&gt;</header>
- </javadoc>
- </target>
diff --git a/dev-java/itext/itext-5.2.0.ebuild b/dev-java/itext/itext-5.2.0.ebuild
deleted file mode 100644
index e3de1f8d0450..000000000000
--- a/dev-java/itext/itext-5.2.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/itext/itext-5.2.0.ebuild,v 1.3 2014/08/10 20:15:26 slyfox Exp $
-
-EAPI="4"
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Java library that generate documents in the Portable Document Format (PDF) and/or HTML"
-HOMEPAGE="http://itextpdf.com"
-SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
-
-LICENSE="AGPL-3"
-SLOT="5"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-COMMON_DEP="
- dev-java/bcmail:0
- dev-java/bcprov:0
- dev-java/bctsp:0"
-RDEPEND="${COMMON_DEP}
- >=virtual/jre-1.5"
-DEPEND="${COMMON_DEP}
- >=virtual/jdk-1.5
- app-arch/unzip"
-
-src_unpack() {
- default
- unpack ./${PN}{pdf,-xtra}-${PV}-sources.jar
-}
-
-java_prepare() {
- # Extract resources from precompiled jar
- mkdir target/classes -p || die
- pushd target/classes > /dev/null || die
- declare -a resources
- resources=( $(jar -tf "${WORKDIR}"/${PN}pdf-${PV}.jar \
- | sed -e '/class$/d' -e '/\/$/d' -e '/META-INF/d') )
- assert
- jar -xf "${WORKDIR}"/${PN}pdf-${PV}.jar "${resources[@]}" || die
- popd > /dev/null
-
- find "${WORKDIR}" -name '*.jar' -exec rm -v {} + || die
-}
-
-JAVA_GENTOO_CLASSPATH="bcmail,bcprov,bctsp"
-
-src_install() {
- java-pkg-simple_src_install
-}
diff --git a/dev-java/itext/itext-5.5.4.ebuild b/dev-java/itext/itext-5.5.4.ebuild
new file mode 100644
index 000000000000..8d97b2e943f1
--- /dev/null
+++ b/dev-java/itext/itext-5.5.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/itext/itext-5.5.4.ebuild,v 1.1 2015/01/11 16:11:57 ercpe Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java library that generate documents in the Portable Document Format (PDF) and/or HTML."
+HOMEPAGE="http://itextpdf.com"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="AGPL-3"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEP="
+ dev-java/bcmail:0
+ >=dev-java/bcprov-1.49:0
+ dev-java/bcpkix:0
+ dev-java/xml-security:0
+"
+
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.5"
+
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.5
+ app-arch/unzip"
+
+JAVA_GENTOO_CLASSPATH="bcmail,bcprov,bcpkix,xml-security"
+
+java_prepare() {
+ mkdir source || die
+
+ for x in *-sources.jar; do
+ unzip -n ${x} -d source || die
+ done
+
+ rm -v *.jar || die
+}