summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-05-08 14:15:18 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-05-08 14:15:18 +0000
commita45d8df946b6114726a7fa16df55f2d395b4f352 (patch)
treedcd8b9bc7fc129ce9c27fca3bf101cccf0bbb472 /dev-java/jboss-logging
parentvanilla-3.14.3 + genpatches-3.14-6 + grsecurity-3.0-3.14.3-201405071928 (diff)
downloadgentoo-2-a45d8df946b6114726a7fa16df55f2d395b4f352.tar.gz
gentoo-2-a45d8df946b6114726a7fa16df55f2d395b4f352.tar.bz2
gentoo-2-a45d8df946b6114726a7fa16df55f2d395b4f352.zip
Revision bump, thorough review to use java-pkg-2 and fix up common mistakes; could fix bug #509602, reported by Victor Orozo.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/jboss-logging')
-rw-r--r--dev-java/jboss-logging/ChangeLog11
-rw-r--r--dev-java/jboss-logging/files/jboss-logging-3.1.3-r1-build.xml224
-rw-r--r--dev-java/jboss-logging/jboss-logging-3.1.3-r1.ebuild43
3 files changed, 276 insertions, 2 deletions
diff --git a/dev-java/jboss-logging/ChangeLog b/dev-java/jboss-logging/ChangeLog
index 3f4c7445023f..2ed4a192c52c 100644
--- a/dev-java/jboss-logging/ChangeLog
+++ b/dev-java/jboss-logging/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jboss-logging
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jboss-logging/ChangeLog,v 1.1 2013/09/26 17:39:00 ercpe Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jboss-logging/ChangeLog,v 1.2 2014/05/08 14:15:18 tomwij Exp $
+
+*jboss-logging-3.1.3-r1 (08 May 2014)
+
+ 08 May 2014; Tom Wijsman <TomWij@gentoo.org>
+ +files/jboss-logging-3.1.3-r1-build.xml, +jboss-logging-3.1.3-r1.ebuild:
+ Revision bump, thorough review to use java-pkg-2 and fix up common mistakes;
+ could fix bug #509602, reported by Victor Orozo.
*jboss-logging-3.1.3 (26 Sep 2013)
diff --git a/dev-java/jboss-logging/files/jboss-logging-3.1.3-r1-build.xml b/dev-java/jboss-logging/files/jboss-logging-3.1.3-r1-build.xml
new file mode 100644
index 000000000000..f024bcc74854
--- /dev/null
+++ b/dev-java/jboss-logging/files/jboss-logging-3.1.3-r1-build.xml
@@ -0,0 +1,224 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 5/8/14 3:59 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="jboss-logging-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jboss-logging-3.1.3.GA"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/org/jboss/logmanager/jboss-logmanager/1.2.0.GA/jboss-logmanager-1.2.0.GA.jar"/>
+ <pathelement location="${maven.repo.local}/log4j/log4j/1.2.16/log4j-1.2.16.jar"/>
+ <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.6.1/slf4j-api-1.6.1.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/jboss/logmanager/jboss-logmanager/1.2.0.GA/jboss-logmanager-1.2.0.GA.jar"/>
+ <pathelement location="${maven.repo.local}/log4j/log4j/1.2.16/log4j-1.2.16.jar"/>
+ <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.6.1/slf4j-api-1.6.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="true"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.1"
+ verbose="false"
+ fork="false"
+ source="1.3">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases"/>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false">
+ <doctitle>&lt;![CDATA[JBoss Logging 3.1.3.GA]]&gt;</doctitle>
+ <header>&lt;![CDATA[JBoss Logging 3.1.3.GA]]&gt;</header>
+ <footer>&lt;![CDATA[JBoss Logging 3.1.3.GA]]&gt;</footer>
+ <bottom>&lt;![CDATA[&lt;i&gt;Copyright &amp;#169; 2012 Red Hat, Inc.&lt;/i&gt;]]&gt;</bottom>
+ <link href="http://java.sun.com/javase/6/docs/api/"/>
+ <doclet name="net.gleamynode.apiviz.APIviz"
+ path="${maven.repo.local}/org/jboss/apiviz/apiviz/1.2.5.GA/apiviz-1.2.5.GA.jar"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="true"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/org/jboss/logmanager/jboss-logmanager/1.2.0.GA"/>
+ <get src="http://repo.maven.apache.org/maven2/org/jboss/logmanager/jboss-logmanager/1.2.0.GA/jboss-logmanager-1.2.0.GA.jar"
+ dest="${maven.repo.local}/org/jboss/logmanager/jboss-logmanager/1.2.0.GA/jboss-logmanager-1.2.0.GA.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/log4j/log4j/1.2.16"/>
+ <get src="http://repo.maven.apache.org/maven2/log4j/log4j/1.2.16/log4j-1.2.16.jar"
+ dest="${maven.repo.local}/log4j/log4j/1.2.16/log4j-1.2.16.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/slf4j/slf4j-api/1.6.1"/>
+ <get src="http://repo.maven.apache.org/maven2/org/slf4j/slf4j-api/1.6.1/slf4j-api-1.6.1.jar"
+ dest="${maven.repo.local}/org/slf4j/slf4j-api/1.6.1/slf4j-api-1.6.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/jboss-logging/jboss-logging-3.1.3-r1.ebuild b/dev-java/jboss-logging/jboss-logging-3.1.3-r1.ebuild
new file mode 100644
index 000000000000..788e19204039
--- /dev/null
+++ b/dev-java/jboss-logging/jboss-logging-3.1.3-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jboss-logging/jboss-logging-3.1.3-r1.ebuild,v 1.1 2014/05/08 14:15:18 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="JBoss logging framework"
+HOMEPAGE="http://www.jboss.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.GA.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="dev-java/jboss-logmanager:0
+ dev-java/slf4j-api:0
+ dev-java/log4j:0"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEPEND}"
+
+S="${WORKDIR}/${P}.GA/"
+
+EANT_GENTOO_CLASSPATH="jboss-logmanager,slf4j-api,log4j"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+java_prepare() {
+ cp "${FILESDIR}"/${PF}-build.xml build.xml || die
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.GA.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/org
+} \ No newline at end of file