summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-02-12 23:07:41 +0000
committerVlastimil Babka <caster@gentoo.org>2010-02-12 23:07:41 +0000
commita6f232f58d7c4d583250a688a458b2489bb22b59 (patch)
tree007035b0b0d55dea17db7d515e2d75cc4bb8330d /dev-java/jdbc-mysql
parentNow taking over maintainership of g-cpan. Fixed bugs 239217, 281948, 250718, ... (diff)
downloadgentoo-2-a6f232f58d7c4d583250a688a458b2489bb22b59.tar.gz
gentoo-2-a6f232f58d7c4d583250a688a458b2489bb22b59.tar.bz2
gentoo-2-a6f232f58d7c4d583250a688a458b2489bb22b59.zip
Do the same with 5.1.10, might help bug #292876 as well.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/jdbc-mysql')
-rw-r--r--dev-java/jdbc-mysql/ChangeLog6
-rw-r--r--dev-java/jdbc-mysql/files/5.1.6-java6-detection.patch22
-rw-r--r--dev-java/jdbc-mysql/jdbc-mysql-5.1.10.ebuild12
3 files changed, 12 insertions, 28 deletions
diff --git a/dev-java/jdbc-mysql/ChangeLog b/dev-java/jdbc-mysql/ChangeLog
index 700879610bfb..3e6074c63762 100644
--- a/dev-java/jdbc-mysql/ChangeLog
+++ b/dev-java/jdbc-mysql/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/jdbc-mysql
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-mysql/ChangeLog,v 1.67 2010/02/12 22:55:28 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-mysql/ChangeLog,v 1.68 2010/02/12 23:07:40 caster Exp $
+
+ 12 Feb 2010; Vlastimil Babka <caster@gentoo.org>
+ -files/5.1.6-java6-detection.patch, jdbc-mysql-5.1.10.ebuild:
+ Do the same with 5.1.10, might help bug #292876 as well.
12 Feb 2010; Vlastimil Babka <caster@gentoo.org> jdbc-mysql-5.1.6.ebuild:
Fix compilation with ibm-jdk-bin-1.6, mentioned in bug #284299.
diff --git a/dev-java/jdbc-mysql/files/5.1.6-java6-detection.patch b/dev-java/jdbc-mysql/files/5.1.6-java6-detection.patch
deleted file mode 100644
index a388db104cb6..000000000000
--- a/dev-java/jdbc-mysql/files/5.1.6-java6-detection.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: build.xml
-===================================================================
---- build.xml (revision 6792)
-+++ build.xml (working copy)
-@@ -97,7 +97,7 @@
-
- <target name="-compiler-check">
- <if>
-- <and>
-+ <or>
- <not>
- <or>
- <equals arg1="${ant.java.version}" arg2="1.4" />
-@@ -112,7 +112,7 @@
- <available file="${com.mysql.jdbc.java6.rtjar}" />
- </not>
- </or>
-- </and>
-+ </or>
- <then>
- <echo>This version of MySQL Connector/J requires a compiler from Java-1.4 or Java-1.5 to be used, set your JAVA_HOME property to point to one of these versions of the JDK.
-
diff --git a/dev-java/jdbc-mysql/jdbc-mysql-5.1.10.ebuild b/dev-java/jdbc-mysql/jdbc-mysql-5.1.10.ebuild
index 8105b7ad88f2..c92b8f52f62a 100644
--- a/dev-java/jdbc-mysql/jdbc-mysql-5.1.10.ebuild
+++ b/dev-java/jdbc-mysql/jdbc-mysql-5.1.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-mysql/jdbc-mysql-5.1.10.ebuild,v 1.2 2009/12/28 14:17:13 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-mysql/jdbc-mysql-5.1.10.ebuild,v 1.3 2010/02/12 23:07:40 caster Exp $
JAVA_PKG_IUSE="source"
WANT_ANT_TASKS="ant-contrib"
@@ -40,7 +40,9 @@ src_unpack() {
epatch "${FILESDIR}/5.0.5-remove-jboss-dependency-from-tests.patch"
# http://bugs.mysql.com/bug.php?id=28286
epatch "${FILESDIR}/5.0.5-dist-target-depends.patch"
- epatch "${FILESDIR}/5.1.6-java6-detection.patch"
+
+ # checks fail if java6 bootclasspath is not a single jar
+ sed -i 's/depends="-compiler-check, /depends="/' build.xml || die
rm -v *.jar || die
@@ -61,10 +63,10 @@ EANT_BUILD_TARGET="dist"
src_compile() {
local vm=$(depend-java-query -v ">=virtual/jdk-1.6")
local javac=$(GENTOO_VM="${vm}" java-config --javac)
- local rt=$(GENTOO_VM="${vm}" java-config --jdk-home)/jre/lib/rt.jar
+ local rt=$(GENTOO_VM="${vm}" java-config -g BOOTCLASSPATH)
einfo "Using ${vm} to compile the JDBC4 driver"
einfo "javac: ${javac}"
- einfo "rt.jar: ${rt}"
+ einfo "bootclasspath: ${rt}"
java-pkg-2_src_compile \
-Dcom.mysql.jdbc.java6.javac="${javac}" \
-Dcom.mysql.jdbc.java6.rtjar="${rt}"