summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2013-10-08 16:27:31 +0000
committerJohann Schmitz <ercpe@gentoo.org>2013-10-08 16:27:31 +0000
commit16c5408b3cf6ee8952d48f2582e1724a9e5fbc61 (patch)
treef992812a0de11f168bca90d5c190d20f9d0eceaf /dev-java/jmdns
parentFix wacom panel not getting enabled in panel loader (bug #487240, thanks to S... (diff)
downloadgentoo-2-16c5408b3cf6ee8952d48f2582e1724a9e5fbc61.tar.gz
gentoo-2-16c5408b3cf6ee8952d48f2582e1724a9e5fbc61.tar.bz2
gentoo-2-16c5408b3cf6ee8952d48f2582e1724a9e5fbc61.zip
Version bump of jmdns to slot 3.1 (dependency of mucommander)
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java/jmdns')
-rw-r--r--dev-java/jmdns/ChangeLog10
-rw-r--r--dev-java/jmdns/jmdns-3.1.4.ebuild29
2 files changed, 36 insertions, 3 deletions
diff --git a/dev-java/jmdns/ChangeLog b/dev-java/jmdns/ChangeLog
index 330cf597995d..e5095dccf7d8 100644
--- a/dev-java/jmdns/ChangeLog
+++ b/dev-java/jmdns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/jmdns
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jmdns/ChangeLog,v 1.13 2009/05/23 21:10:26 ali_bush Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jmdns/ChangeLog,v 1.14 2013/10/08 16:27:31 ercpe Exp $
+
+*jmdns-3.1.4 (08 Oct 2013)
+
+ 08 Oct 2013; Johann Schmitz <ercpe@gentoo.org> +jmdns-3.1.4.ebuild:
+ Version bump of jmdns to slot 3.1 (dependency of mucommander)
23 May 2009; Alistair Bush <ali_bush@gentoo.org> jmdns-1.0.ebuild:
Fix build failure when source use flag enabled. See #268346
@@ -44,4 +49,3 @@
18 Apr 2004; Chris Aniszczyk <zx@gentoo.org> jmdns-0.2.ebuild, metadata.xml:
Initial Import. Closes #48047
Thanks to Guy de Pourtales <guy@gadp.ch> for the initial ebuild.
-
diff --git a/dev-java/jmdns/jmdns-3.1.4.ebuild b/dev-java/jmdns/jmdns-3.1.4.ebuild
new file mode 100644
index 000000000000..a6c78364e6f6
--- /dev/null
+++ b/dev-java/jmdns/jmdns-3.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jmdns/jmdns-3.1.4.ebuild,v 1.1 2013/10/08 16:27:31 ercpe Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="JmDNS is an implementation of multi-cast DNS in Java."
+SRC_URI="mirror://sourceforge/${PN}/${PF}.tgz"
+HOMEPAGE="http://jmdns.sourceforge.net"
+
+LICENSE="Apache-2.0"
+SLOT="3.1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/${P}"
+JAVA_SRC_DIR="src"
+
+src_prepare() {
+ rm "${S}"/build.xml
+ rm "${S}"/lib/*.jar || die
+}