summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2011-09-09 23:08:25 +0000
committerVlastimil Babka <caster@gentoo.org>2011-09-09 23:08:25 +0000
commit59a43a5b8ce8470510e0cf829beb11b13294ce95 (patch)
tree5d395283e0720acb39619747e94c7c2d83c46a4f /dev-java/jnlp-api/jnlp-api-6.0.18.ebuild
parentAdding support for >=libnl-2.0 (diff)
downloadgentoo-2-59a43a5b8ce8470510e0cf829beb11b13294ce95.tar.gz
gentoo-2-59a43a5b8ce8470510e0cf829beb11b13294ce95.tar.bz2
gentoo-2-59a43a5b8ce8470510e0cf829beb11b13294ce95.zip
New package for stuff that builds against JNLP API classes javax/jnlp, to replace the broken dev-java/netx, bug #382351.
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/jnlp-api/jnlp-api-6.0.18.ebuild')
-rw-r--r--dev-java/jnlp-api/jnlp-api-6.0.18.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-java/jnlp-api/jnlp-api-6.0.18.ebuild b/dev-java/jnlp-api/jnlp-api-6.0.18.ebuild
new file mode 100644
index 000000000000..4e270d949825
--- /dev/null
+++ b/dev-java/jnlp-api/jnlp-api-6.0.18.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jnlp-api/jnlp-api-6.0.18.ebuild,v 1.1 2011/09/09 23:08:25 caster Exp $
+
+EAPI="4"
+JAVA_PKG_IUSE="source"
+
+inherit eutils java-pkg-2 java-pkg-simple
+
+DESCRIPTION="JNLP API classes, repackaged from the icedtea-web fork of netx."
+HOMEPAGE="http://jcp.org/en/jsr/detail?id=56"
+SRC_URI="http://dev.gentoo.org/~caster/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="source"
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ use source && java-pkg_dosrc javax
+}