summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2014-03-23 18:50:08 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2014-03-23 18:50:08 +0000
commitd4d0746a5e116f973ef746d2aa0d260a06223182 (patch)
tree536c18874a9f5f05cc31f6489828e33a9241b790 /dev-java/netbeans-extide
parentdev-java/netbeans-ergonomics: new ebuild for version 8.0 (diff)
downloadgentoo-2-d4d0746a5e116f973ef746d2aa0d260a06223182.tar.gz
gentoo-2-d4d0746a5e116f973ef746d2aa0d260a06223182.tar.bz2
gentoo-2-d4d0746a5e116f973ef746d2aa0d260a06223182.zip
dev-java/netbeans-extide: new ebuild for version 8.0
(Portage version: 2.2.9-r1/cvs/Linux x86_64, signed Manifest commit with key CFE47E2F)
Diffstat (limited to 'dev-java/netbeans-extide')
-rw-r--r--dev-java/netbeans-extide/ChangeLog10
-rw-r--r--dev-java/netbeans-extide/netbeans-extide-8.0.ebuild108
2 files changed, 116 insertions, 2 deletions
diff --git a/dev-java/netbeans-extide/ChangeLog b/dev-java/netbeans-extide/ChangeLog
index bcb8f9e0f10d..1e1bb8a3ba5e 100644
--- a/dev-java/netbeans-extide/ChangeLog
+++ b/dev-java/netbeans-extide/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/netbeans-extide
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-extide/ChangeLog,v 1.1 2013/10/16 09:40:11 fordfrog Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-extide/ChangeLog,v 1.2 2014/03/23 18:50:08 fordfrog Exp $
+
+*netbeans-extide-8.0 (23 Mar 2014)
+
+ 23 Mar 2014; Miroslav Šulc <fordfrog@gentoo.org>
+ +netbeans-extide-8.0.ebuild:
+ new ebuild for version 8.0
*netbeans-extide-7.4 (16 Oct 2013)
diff --git a/dev-java/netbeans-extide/netbeans-extide-8.0.ebuild b/dev-java/netbeans-extide/netbeans-extide-8.0.ebuild
new file mode 100644
index 000000000000..6a5a521541d9
--- /dev/null
+++ b/dev-java/netbeans-extide/netbeans-extide-8.0.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-extide/netbeans-extide-8.0.ebuild,v 1.1 2014/03/23 18:50:08 fordfrog Exp $
+
+EAPI="4"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Netbeans ExtIDE Cluster"
+HOMEPAGE="http://netbeans.org/projects/ide"
+SLOT="8.0"
+SOURCE_URL="http://download.netbeans.org/netbeans/8.0/final/zip/netbeans-8.0-201403101706-src.zip"
+SRC_URI="${SOURCE_URL}
+ http://dev.gentoo.org/~fordfrog/distfiles/netbeans-8.0-build.xml.patch.bz2
+ http://hg.netbeans.org/binaries/51449E030F3A5F80327536CC51D75EE9D7E59BDA-ant-libs-1.9.2.zip
+ http://hg.netbeans.org/binaries/BEB2DE1B81AFF4A4B68D7839BB10341EE10A7A55-ant-misc-1.9.2.zip"
+LICENSE="|| ( CDDL GPL-2-with-linking-exception )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}"
+
+CDEPEND="~dev-java/netbeans-ide-${PV}
+ ~dev-java/netbeans-platform-${PV}"
+DEPEND=">=virtual/jdk-1.7
+ app-arch/unzip
+ dev-java/javahelp:0
+ ${CDEPEND}"
+RDEPEND=">=virtual/jdk-1.7
+ ${CDEPEND}"
+
+INSTALL_DIR="/usr/share/${PN}-${SLOT}"
+
+EANT_BUILD_XML="nbbuild/build.xml"
+EANT_BUILD_TARGET="rebuild-cluster"
+EANT_EXTRA_ARGS="-Drebuild.cluster.name=nb.cluster.extide -Dext.binaries.downloaded=true -Djava.awt.headless=true"
+EANT_FILTER_COMPILER="ecj-3.3 ecj-3.4 ecj-3.5 ecj-3.6 ecj-3.7"
+JAVA_PKG_BSFIX="off"
+
+src_unpack() {
+ unpack $(basename ${SOURCE_URL})
+
+ einfo "Deleting bundled jars..."
+ find -name "*.jar" -type f -delete
+
+ unpack netbeans-8.0-build.xml.patch.bz2
+
+ pushd "${S}" >/dev/null || die
+ ln -s "${DISTDIR}"/51449E030F3A5F80327536CC51D75EE9D7E59BDA-ant-libs-1.9.2.zip o.apache.tools.ant.module/external/ant-libs-1.9.2.zip || die
+ ln -s "${DISTDIR}"/BEB2DE1B81AFF4A4B68D7839BB10341EE10A7A55-ant-misc-1.9.2.zip o.apache.tools.ant.module/external/ant-misc-1.9.2.zip || die
+ popd >/dev/null || die
+}
+
+src_prepare() {
+ einfo "Deleting bundled class files..."
+ find -name "*.class" -type f | xargs rm -vf
+
+ epatch netbeans-8.0-build.xml.patch
+
+ # Support for custom patches
+ if [ -n "${NETBEANS80_PATCHES_DIR}" -a -d "${NETBEANS80_PATCHES_DIR}" ] ; then
+ local files=`find "${NETBEANS80_PATCHES_DIR}" -type f`
+
+ if [ -n "${files}" ] ; then
+ einfo "Applying custom patches:"
+
+ for file in ${files} ; do
+ epatch "${file}"
+ done
+ fi
+ fi
+
+ einfo "Symlinking external libraries..."
+ java-pkg_jar-from --build-only --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
+
+ einfo "Linking in other clusters..."
+ mkdir "${S}"/nbbuild/netbeans || die
+ pushd "${S}"/nbbuild/netbeans >/dev/null || die
+
+ ln -s /usr/share/netbeans-ide-${SLOT} ide || die
+ cat /usr/share/netbeans-ide-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+ touch nb.cluster.ide.built
+
+ ln -s /usr/share/netbeans-platform-${SLOT} platform || die
+ cat /usr/share/netbeans-platform-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+ touch nb.cluster.platform.built
+
+ popd >/dev/null || die
+
+ java-pkg-2_src_prepare
+}
+
+src_compile() {
+ unset DISPLAY
+ eant -f ${EANT_BUILD_XML} ${EANT_EXTRA_ARGS} ${EANT_BUILD_TARGET} || die "Compilation failed"
+}
+
+src_install() {
+ pushd nbbuild/netbeans/extide >/dev/null || die
+
+ insinto ${INSTALL_DIR}
+
+ grep -E "/extide$" ../moduleCluster.properties > "${D}"/${INSTALL_DIR}/moduleCluster.properties || die
+
+ doins -r *
+
+ popd >/dev/null || die
+
+ dosym ${INSTALL_DIR} /usr/share/netbeans-nb-${SLOT}/extide
+}