summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-01-23 12:47:51 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-01-23 12:47:51 +0000
commitf52e7722b993ad42e382a4c31ed748f45c2505da (patch)
tree50b4289f4784bc7efedca4b8f838654974f3c5b9 /dev-java/qdox
parentkeyword ~x86-fbsd and fix cp call to be bsd-compatible in src_test (diff)
downloadgentoo-2-f52e7722b993ad42e382a4c31ed748f45c2505da.tar.gz
gentoo-2-f52e7722b993ad42e382a4c31ed748f45c2505da.tar.bz2
gentoo-2-f52e7722b993ad42e382a4c31ed748f45c2505da.zip
keyword ~x86-fbsd and fix find call to be bsd-compatible
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/qdox')
-rw-r--r--dev-java/qdox/ChangeLog5
-rw-r--r--dev-java/qdox/qdox-1.6.3.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-java/qdox/ChangeLog b/dev-java/qdox/ChangeLog
index 353447b1a33c..52459344851d 100644
--- a/dev-java/qdox/ChangeLog
+++ b/dev-java/qdox/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-java/qdox
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/qdox/ChangeLog,v 1.22 2010/01/03 21:27:15 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/qdox/ChangeLog,v 1.23 2010/01/23 12:47:51 aballier Exp $
+
+ 23 Jan 2010; Alexis Ballier <aballier@gentoo.org> qdox-1.6.3.ebuild:
+ keyword ~x86-fbsd and fix find call to be bsd-compatible
03 Jan 2010; Christian Faulhammer <fauli@gentoo.org> qdox-1.6.3.ebuild:
Transfer Prefix keywords
diff --git a/dev-java/qdox/qdox-1.6.3.ebuild b/dev-java/qdox/qdox-1.6.3.ebuild
index fe1b1045de58..c6bfead8e6c6 100644
--- a/dev-java/qdox/qdox-1.6.3.ebuild
+++ b/dev-java/qdox/qdox-1.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/qdox/qdox-1.6.3.ebuild,v 1.11 2010/01/03 21:27:15 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/qdox/qdox-1.6.3.ebuild,v 1.12 2010/01/23 12:47:51 aballier Exp $
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-ant-2
@@ -9,7 +9,7 @@ HOMEPAGE="http://qdox.codehaus.org/"
SRC_URI="http://repository.codehaus.org/com/thoughtworks/${PN}/${PN}/${PV}/${P}-sources.jar"
LICENSE="Apache-2.0"
SLOT="1.6"
-KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris"
+KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris"
IUSE=""
CDEPEND="dev-java/ant-core
@@ -25,7 +25,7 @@ src_compile() {
# create jar
mkdir -p build/classes
ejavac -sourcepath . -d build/classes -classpath $(java-pkg_getjars ant-core,junit) \
- $(find -name "*.java") || die "Cannot compile sources"
+ $(find . -name "*.java") || die "Cannot compile sources"
mkdir dist
cd build/classes
jar -cvf "${S}/dist/${PN}.jar" com || die "Cannot create JAR"