summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-03-12 02:10:12 +0000
committerTim Harder <radhermit@gentoo.org>2014-03-12 02:10:12 +0000
commit95314df21bc6064905bc5cdf2df3c58647065a35 (patch)
tree940f7cf2f74c12c25fbec33d8ed4d196bd562282 /dev-java/slf4j-log4j12
parentBlock beautifulsoup-4.2.0, bug 503962 by Wicla. (diff)
downloadgentoo-2-95314df21bc6064905bc5cdf2df3c58647065a35.tar.gz
gentoo-2-95314df21bc6064905bc5cdf2df3c58647065a35.tar.bz2
gentoo-2-95314df21bc6064905bc5cdf2df3c58647065a35.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-java/slf4j-log4j12')
-rw-r--r--dev-java/slf4j-log4j12/ChangeLog8
-rw-r--r--dev-java/slf4j-log4j12/files/slf4j-log4j12-1.7.6-maven-build.xml241
-rw-r--r--dev-java/slf4j-log4j12/slf4j-log4j12-1.7.6.ebuild52
3 files changed, 300 insertions, 1 deletions
diff --git a/dev-java/slf4j-log4j12/ChangeLog b/dev-java/slf4j-log4j12/ChangeLog
index 52a360bb849f..0002478b5542 100644
--- a/dev-java/slf4j-log4j12/ChangeLog
+++ b/dev-java/slf4j-log4j12/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/slf4j-log4j12
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/slf4j-log4j12/ChangeLog,v 1.1 2014/02/04 00:29:06 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/slf4j-log4j12/ChangeLog,v 1.2 2014/03/12 02:10:12 radhermit Exp $
+
+*slf4j-log4j12-1.7.6 (12 Mar 2014)
+
+ 12 Mar 2014; Tim Harder <radhermit@gentoo.org> +slf4j-log4j12-1.7.6.ebuild,
+ +files/slf4j-log4j12-1.7.6-maven-build.xml:
+ Version bump.
*slf4j-log4j12-1.7.5 (04 Feb 2014)
diff --git a/dev-java/slf4j-log4j12/files/slf4j-log4j12-1.7.6-maven-build.xml b/dev-java/slf4j-log4j12/files/slf4j-log4j12-1.7.6-maven-build.xml
new file mode 100644
index 000000000000..fe840a760b42
--- /dev/null
+++ b/dev-java/slf4j-log4j12/files/slf4j-log4j12-1.7.6-maven-build.xml
@@ -0,0 +1,241 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 3/12/14 1:54 AM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="slf4j-log4j12-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="slf4j-log4j12-1.7.6"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.7.6/slf4j-api-1.7.6.jar"/>
+ <pathelement location="${maven.repo.local}/log4j/log4j/1.2.17/log4j-1.2.17.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.7.6/slf4j-api-1.7.6.jar"/>
+ <pathelement location="${maven.repo.local}/log4j/log4j/1.2.17/log4j-1.2.17.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/AllTest.java"/>
+ <exclude name="**/PackageTest.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/AllTest.java"/>
+ <exclude name="**/PackageTest.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ manifest="${maven.build.resourceDir.0}/META-INF/MANIFEST.MF"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+</project>
diff --git a/dev-java/slf4j-log4j12/slf4j-log4j12-1.7.6.ebuild b/dev-java/slf4j-log4j12/slf4j-log4j12-1.7.6.ebuild
new file mode 100644
index 000000000000..e05733765009
--- /dev/null
+++ b/dev-java/slf4j-log4j12/slf4j-log4j12-1.7.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/slf4j-log4j12/slf4j-log4j12-1.7.6.ebuild,v 1.1 2014/03/12 02:10:12 radhermit Exp $
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Simple Logging Facade for Java (SLF4J) log4j bindings"
+HOMEPAGE="http://www.slf4j.org/"
+SRC_URI="http://www.slf4j.org/dist/${P/-log4j12/}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ dev-java/log4j:0
+ dev-java/slf4j-api:0"
+RDEPEND="${COMMON_DEPEND}
+ >=virtual/jre-1.5"
+DEPEND="${COMMON_DEPEND}
+ >=virtual/jdk-1.5
+ test? (
+ dev-java/hamcrest-core:0
+ dev-java/junit:4
+ dev-java/ant-junit4:0
+ )"
+
+S=${WORKDIR}/${P/-log4j12/}/${PN}
+
+EANT_GENTOO_CLASSPATH="log4j,slf4j-api"
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},hamcrest-core,junit-4"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_EXTRA_ARGS="-Dmaven.build.finalName=${PN}"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-maven-build.xml build.xml || die
+ find "${WORKDIR}" -iname '*.jar' -delete || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/org
+}