summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2008-06-21 16:12:05 +0000
committerSerkan Kaba <serkan@gentoo.org>2008-06-21 16:12:05 +0000
commitce01725c9f35db94424c471c0de806966ecdf305 (patch)
treea83d95ac547b18ba4e4768ec57bd04ce3ff37a5e /dev-java/sun-jmx
parentAdd license for coming dev-java/sun-jmx revision. (diff)
downloadgentoo-2-ce01725c9f35db94424c471c0de806966ecdf305.tar.gz
gentoo-2-ce01725c9f35db94424c471c0de806966ecdf305.tar.bz2
gentoo-2-ce01725c9f35db94424c471c0de806966ecdf305.zip
Revision bump to use binary jmx as sources are no longer available. See bug #226381.
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8 x86_64)
Diffstat (limited to 'dev-java/sun-jmx')
-rw-r--r--dev-java/sun-jmx/ChangeLog10
-rw-r--r--dev-java/sun-jmx/sun-jmx-1.2.1-r3.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/dev-java/sun-jmx/ChangeLog b/dev-java/sun-jmx/ChangeLog
index d354c0750315..e5590f98b72e 100644
--- a/dev-java/sun-jmx/ChangeLog
+++ b/dev-java/sun-jmx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jmx
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jmx/ChangeLog,v 1.10 2007/04/14 19:40:04 betelgeuse Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jmx/ChangeLog,v 1.11 2008/06/21 16:12:05 serkan Exp $
+
+*sun-jmx-1.2.1-r3 (21 Jun 2008)
+
+ 21 Jun 2008; Serkan Kaba <serkan@gentoo.org> +sun-jmx-1.2.1-r3.ebuild:
+ Revision bump to use binary jmx as sources are no longer available. See
+ bug #226381.
14 Apr 2007; Petteri Räty <betelgeuse@gentoo.org>
-sun-jmx-1.2.1-r1.ebuild:
diff --git a/dev-java/sun-jmx/sun-jmx-1.2.1-r3.ebuild b/dev-java/sun-jmx/sun-jmx-1.2.1-r3.ebuild
new file mode 100644
index 000000000000..9311237e8ec4
--- /dev/null
+++ b/dev-java/sun-jmx/sun-jmx-1.2.1-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jmx/sun-jmx-1.2.1-r3.ebuild,v 1.1 2008/06/21 16:12:05 serkan Exp $
+
+JAVA_PKG_IUSE="doc examples"
+
+inherit java-pkg-2
+
+MY_P=jmx-${PV//./_}
+DESCRIPTION="Java Management Extensions for managing and monitoring devices, applications, and services."
+HOMEPAGE="http://java.sun.com/products/JavaManagement/index.jsp"
+SRC_URI="${MY_P}-ri.zip"
+LICENSE="sun-bcla-jmx"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+RESTRICT="fetch"
+
+S="${WORKDIR}/${MY_P}-bin"
+IUSE=""
+
+DOWNLOADSITE="https://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_Developer-Site/en_US/-/USD/ViewProductDetail-Start?ProductRef=7657-jmx-1.2.1-oth-JPR@CDS-CDS_Developer"
+
+src_compile() { :; }
+
+pkg_nofetch() {
+ einfo
+ einfo " Due to license restrictions, we cannot fetch the"
+ einfo " distributables automagically."
+ einfo
+ einfo " 1. Visit ${DOWNLOADSITE} and follow instructions"
+ einfo " 2. Download ${SRC_URI}"
+ einfo " 3. Move file to ${DISTDIR}"
+ einfo " 4. Run emerge on this package again to complete"
+ einfo
+}
+
+src_install() {
+ java-pkg_dojar lib/*.jar
+ if use doc; then
+ java-pkg_dojavadoc doc/api
+ java-pkg_dohtml -r doc/doc doc/index.html
+ fi
+ use examples && java-pkg_doexamples examples
+}