summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2006-12-03 21:22:30 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2006-12-03 21:22:30 +0000
commit37357a3be6dd372c6b28c1e3b46d4684bb0454ea (patch)
tree7be7d0ac9e26305289d07f8cdb9a6b4ca97295ba /dev-java/sun-jre-bin
parentAdd ~x86-fbsd keyword. (diff)
downloadgentoo-2-37357a3be6dd372c6b28c1e3b46d4684bb0454ea.tar.gz
gentoo-2-37357a3be6dd372c6b28c1e3b46d4684bb0454ea.tar.bz2
gentoo-2-37357a3be6dd372c6b28c1e3b46d4684bb0454ea.zip
Version bump using the new pax-utils.eclass (bug #156135). Thanks to Kevin F. Quinn <kevquinn@gentoo.org>.
(Portage version: 2.1.2_rc2-r3)
Diffstat (limited to 'dev-java/sun-jre-bin')
-rw-r--r--dev-java/sun-jre-bin/ChangeLog9
-rw-r--r--dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.106
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.10.ebuild139
3 files changed, 153 insertions, 1 deletions
diff --git a/dev-java/sun-jre-bin/ChangeLog b/dev-java/sun-jre-bin/ChangeLog
index 2d692b51f609..2d3c8d5113e7 100644
--- a/dev-java/sun-jre-bin/ChangeLog
+++ b/dev-java/sun-jre-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/sun-jre-bin
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.68 2006/11/23 00:13:48 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.69 2006/12/03 21:22:30 betelgeuse Exp $
+
+*sun-jre-bin-1.5.0.10 (03 Dec 2006)
+
+ 03 Dec 2006; Petteri Räty <betelgeuse@gentoo.org>
+ +sun-jre-bin-1.5.0.10.ebuild:
+ Version bump using the new pax-utils.eclass (bug #156135). Thanks to Kevin
+ F. Quinn <kevquinn@gentoo.org>.
23 Nov 2006; Vlastimil Babka <caster@gentoo.org>
sun-jre-bin-1.4.2.13.ebuild:
diff --git a/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.10 b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.10
new file mode 100644
index 000000000000..d0c6ebd39a99
--- /dev/null
+++ b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.10
@@ -0,0 +1,6 @@
+MD5 eca3b5106aa3cb0469ea01b96dc70510 jdk-1_5_0_10-dlj-linux-amd64.bin 43906073
+RMD160 2d13d637b6d7351410f9e18d581206a05091effe jdk-1_5_0_10-dlj-linux-amd64.bin 43906073
+SHA256 5bbac3fb78db48f7f996e412d45229db3a0b759886f360504cca61c93d4b5f61 jdk-1_5_0_10-dlj-linux-amd64.bin 43906073
+MD5 baa5f71d72d1d4d7c38374d59bedfe7c jdk-1_5_0_10-dlj-linux-i586.bin 49553457
+RMD160 8aa7b53064831d800b8aeae67ffd3f5e4e2e3155 jdk-1_5_0_10-dlj-linux-i586.bin 49553457
+SHA256 e4300d88ae630f02132a4ce23afbdc40f994de91b37d4b64cb1da0b58df678fa jdk-1_5_0_10-dlj-linux-i586.bin 49553457
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.10.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.10.ebuild
new file mode 100644
index 000000000000..4452f4d91f97
--- /dev/null
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.10.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.10.ebuild,v 1.1 2006/12/03 21:22:30 betelgeuse Exp $
+
+inherit pax-utils eutils java-vm-2
+
+MY_PVL=${PV%.*}_${PV##*.}
+MY_PVA=${PV//./_}
+#S="${WORKDIR}/jdk${MY_PVL}"
+
+X86_AT="jdk-${MY_PVA}-dlj-linux-i586.bin"
+AMD64_AT="jdk-${MY_PVA}-dlj-linux-amd64.bin"
+if use x86; then
+ At=${X86_AT}
+elif use amd64; then
+ At=${AMD64_AT}
+fi
+DESCRIPTION="Sun's J2SE Development Kit, version ${PV}"
+HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
+SRC_URI="x86? ( http://download.java.net/dlj/binaries/${X86_AT} )
+ amd64? ( http://download.java.net/dlj/binaries/${AMD64_AT} )"
+SLOT="1.5"
+LICENSE="dlj-1.1"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="nostrip"
+IUSE="X alsa nsplugin"
+
+RDEPEND="
+ sys-libs/glibc
+ alsa? ( media-libs/alsa-lib )
+ X? ( || ( ( x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXt
+ x11-libs/libXtst
+ )
+ virtual/x11
+ )
+ )"
+
+DEPEND=""
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+PACKED_JARS="lib/rt.jar lib/jsse.jar lib/charsets.jar lib/ext/localedata.jar lib/plugin.jar lib/javaws.jar lib/deploy.jar"
+
+QA_TEXTRELS_x86="opt/${P}/lib/i386/motif21/libmawt.so
+ opt/${P}/lib/i386/libdeploy.so"
+
+src_unpack() {
+ if [ ! -r ${DISTDIR}/${At} ]; then
+ die "cannot read ${At}. Please check the permission and try again."
+ fi
+
+ mkdir bundled-jdk
+ cd bundled-jdk
+ sh ${DISTDIR}/${At} --accept-license --unpack || die "Failed to unpack"
+
+ cd ..
+ bash ${FILESDIR}/construct.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
+}
+
+src_install() {
+ local dirs="bin lib man"
+
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler.
+ pax-mark m $(list-paxables ${S}/bin/*)
+
+ # only X86 has the plugin and javaws
+ use x86 && dirs="${dirs} javaws plugin"
+ dodir /opt/${P}
+
+ for i in $dirs ; do
+ cp -pPR $i ${D}/opt/${P}/ || die "failed to copy"
+ done
+ dodoc CHANGES README THIRDPARTYLICENSEREADME.txt
+ dohtml Welcome.html
+ dodir /opt/${P}/share/
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ else
+ eerror "No plugin available for amd64 arch"
+ fi
+ fi
+
+ # TODO Don't think we still needs these -nichoj
+ # create dir for system preferences
+ #dodir /opt/${P}/jre/.systemPrefs
+ # Create files used as storage for system preferences.
+ #touch ${D}/opt/${P}/jre/.systemPrefs/.system.lock
+ #chmod 644 ${D}/opt/${P}/jre/.systemPrefs/.system.lock
+ #touch ${D}/opt/${P}/jre/.systemPrefs/.systemRootModFile
+ #chmod 644 ${D}/opt/${P}/jre/.systemPrefs/.systemRootModFile
+
+ # FIXME figure out how to handle the control pannel conflict with
+ # sun-jdk-bin
+
+ # install control panel for Gnome/KDE
+# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+# ${T}/sun_java-${SLOT}.desktop
+
+# domenu ${T}/sun_java-${SLOT}.desktop
+
+ # bug #56444
+ insinto /opt/${P}/lib/
+ newins "${FILESDIR}"/fontconfig.Gentoo.properties fontconfig.properties
+
+ set_java_env
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if ! use X; then
+ local xwarn="virtual/x11 and/or"
+ fi
+
+ echo
+ ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+
+ echo
+ elog "Beginning with 1.5.0.10 the hotspot vm can use epoll"
+ elog "The epoll-based implementation of SelectorProvider is not selected by"
+ elog "default."
+ elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
+}