summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-03-05 14:19:11 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-03-05 14:19:11 +0000
commit6c7980419a8800a1b10f0bc6ab413c7a6b8c80f7 (patch)
tree1167be477d277cae11f8e5132129790b42197228 /dev-java/swt
parentAdded the local xulrunner use flag introduced in dev-java/swt-3.2.2. (diff)
downloadgentoo-2-6c7980419a8800a1b10f0bc6ab413c7a6b8c80f7.tar.gz
gentoo-2-6c7980419a8800a1b10f0bc6ab413c7a6b8c80f7.tar.bz2
gentoo-2-6c7980419a8800a1b10f0bc6ab413c7a6b8c80f7.zip
Version bump. Adds xulrunner use flag to compile browser support against that (bug #155969). Because of that I dropped amd64 and ppc keywords because I am not sure if it works there. Also silenced cairo signedness warnings with a patch from Hanno Meyer-Thurow <h.mth@web.de> (bug #157826). x86-fbsd I had to drop because they don't have xulrunner keyworded. Version bump is bug #169254.
(Portage version: 2.1.2-r12)
Diffstat (limited to 'dev-java/swt')
-rw-r--r--dev-java/swt/ChangeLog12
-rw-r--r--dev-java/swt/files/digest-swt-3.2.212
-rw-r--r--dev-java/swt/swt-3.2.2.ebuild194
3 files changed, 217 insertions, 1 deletions
diff --git a/dev-java/swt/ChangeLog b/dev-java/swt/ChangeLog
index ae78eaa186d2..29be0866af60 100644
--- a/dev-java/swt/ChangeLog
+++ b/dev-java/swt/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-java/swt
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.59 2007/02/10 15:39:13 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.60 2007/03/05 14:19:11 betelgeuse Exp $
+
+*swt-3.2.2 (05 Mar 2007)
+
+ 05 Mar 2007; Petteri Räty <betelgeuse@gentoo.org> +swt-3.2.2.ebuild:
+ Version bump. Adds xulrunner use flag to compile browser support against
+ that (bug #155969). Because of that I dropped amd64 and ppc keywords because
+ I am not sure if it works there. Also silenced cairo signedness warnings
+ with a patch from Hanno Meyer-Thurow <h.mth@web.de> (bug #157826). x86-fbsd
+ I had to drop because they don't have xulrunner keyworded. Version bump is
+ bug #169254.
10 Feb 2007; nixnut <nixnut@gentoo.org> swt-3.2-r2.ebuild:
Stable on ppc wrt bug 151358
diff --git a/dev-java/swt/files/digest-swt-3.2.2 b/dev-java/swt/files/digest-swt-3.2.2
new file mode 100644
index 000000000000..5d856f4631c3
--- /dev/null
+++ b/dev-java/swt/files/digest-swt-3.2.2
@@ -0,0 +1,12 @@
+MD5 769d0f2efa3894e56966783015862a33 swt-3.2.2-gentoo-patches.tar.bz2 6707
+RMD160 a35840a279f98b4199c25e6b28aadefa1138f843 swt-3.2.2-gentoo-patches.tar.bz2 6707
+SHA256 9f56edd328a5f000dce42c01ae83d1d9e4017dc7fd11ed2a8091ebece783d25e swt-3.2.2-gentoo-patches.tar.bz2 6707
+MD5 45d1f0ff0de9c95fcd92836fea79927c swt-3.2.2-gtk-linux-ppc.zip 3042753
+RMD160 dbec93a4fa1f256a06ff856e5aba8a22a927a52a swt-3.2.2-gtk-linux-ppc.zip 3042753
+SHA256 e5a03729ee01c32950a2244e0d1b8159d988264bc1b335af1b926cba51155450 swt-3.2.2-gtk-linux-ppc.zip 3042753
+MD5 e1340b6c7cf9b617145667b15b02fd49 swt-3.2.2-gtk-linux-x86.zip 3117432
+RMD160 b99c00a6f43316cb82bd38f1e8bd92eea4006b78 swt-3.2.2-gtk-linux-x86.zip 3117432
+SHA256 aae02ccab6ba97d984533c834ca854a649c3a91ad129fb4a61f7e89c55c41f28 swt-3.2.2-gtk-linux-x86.zip 3117432
+MD5 d678cedc336a58b0147081b56de6a1f3 swt-3.2.2-gtk-linux-x86_64.zip 2996317
+RMD160 81ca3cfa69ab084d9bbe04d8ac6a941c65b46b15 swt-3.2.2-gtk-linux-x86_64.zip 2996317
+SHA256 a60902420ca5e540d949613a5eba352a92043cf3c8d20e8a8214fb0c44699e56 swt-3.2.2-gtk-linux-x86_64.zip 2996317
diff --git a/dev-java/swt/swt-3.2.2.ebuild b/dev-java/swt/swt-3.2.2.ebuild
new file mode 100644
index 000000000000..cb2129614447
--- /dev/null
+++ b/dev-java/swt/swt-3.2.2.ebuild
@@ -0,0 +1,194 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.2.2.ebuild,v 1.1 2007/03/05 14:19:11 betelgeuse Exp $
+
+inherit eutils java-pkg-2 java-ant-2 toolchain-funcs
+
+MY_DMF="R-${PV}-200702121330"
+# https://overlays.gentoo.org/svn/proj/java/other/swt-patches
+PATCHSET="${PN}-3.2.2-gentoo-patches"
+DESCRIPTION="GTK based SWT Library"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="x86? (
+ http://download.eclipse.org/downloads/drops/${MY_DMF}/${P}-gtk-linux-x86.zip
+ )
+ x86-fbsd? (
+ http://download.eclipse.org/downloads/drops/${MY_DMF}/${P}-gtk-linux-x86.zip
+ )
+ amd64? (
+ http://download.eclipse.org/downloads/drops/${MY_DMF}/${P}-gtk-linux-x86_64.zip
+ )
+ ppc? (
+ http://download.eclipse.org/downloads/drops/${MY_DMF}/${P}-gtk-linux-ppc.zip
+ )
+ mirror://gentoo/${PATCHSET}.tar.bz2"
+
+SLOT="3"
+LICENSE="CPL-1.0 LGPL-2.1 MPL-1.1"
+KEYWORDS="~x86"
+
+IUSE="cairo gnome seamonkey opengl xulrunner"
+COMMON=">=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6.8
+ >=dev-libs/atk-1.10.2
+ cairo? ( >=x11-libs/cairo-1.0.2 )
+ gnome? (
+ =gnome-base/libgnome-2*
+ =gnome-base/gnome-vfs-2*
+ =gnome-base/libgnomeui-2*
+ )
+ seamonkey? (
+ >=www-client/seamonkey-1.0.2
+ >=dev-libs/nspr-4.6.2
+ )
+ xulrunner? (
+ net-libs/xulrunner
+ )
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON}
+ dev-java/ant-core
+ app-arch/unzip
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-proto/xextproto"
+
+RDEPEND=">=virtual/jre-1.4
+ x11-libs/libXtst
+ ${COMMON}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ # determine the right file to unpack from $A
+ local DISTFILE=${A/${PATCHSET}.tar.bz2/}
+ # just in case patchset is ordered before distfile
+ DISTFILE=${DISTFILE## }
+ unzip -jq "${DISTDIR}"/${DISTFILE} "*src.zip" || die "unable to extract distfile"
+ unpack ./src.zip
+
+ unpack "${PATCHSET}.tar.bz2"
+
+ # Cleanup the redirtied directory structure
+ rm -rf about_files/
+ rm -f .classpath .project
+
+ # Replace the build.xml to allow compilation without Eclipse tasks
+ cp "${FILESDIR}"/build.xml ${S}/build.xml || die "Unable to update build.xml"
+ mkdir ${S}/src && mv ${S}/org ${S}/src || die "Unable to restructure SWT sources"
+
+ # apply all the patches, including arch-specific
+ EPATCH_SOURCE="${WORKDIR}/${PATCHSET}" EPATCH_SUFFIX="patch" epatch
+
+ sed -i "s/CFLAGS = -O -Wall/CFLAGS = ${CFLAGS} -Wall/" \
+ make_linux.mak \
+ || die "Failed to tweak make_linux.mak"
+
+ sed -i "s/MOZILLACFLAGS = -O/MOZILLACFLAGS = ${CXXFLAGS}/" \
+ make_linux.mak \
+ || die "Failed to tweak make_linux.mak"
+
+ cp make_linux.mak make_freebsd.mak
+
+ # https://bugs.eclipse.org/bugs/show_bug.cgi?id=167173
+ epatch "${FILESDIR}/${PN}-3.2.1-fbsd.patch"
+}
+
+src_compile() {
+ # Drop jikes support as it seems to be unfriendly with SWT
+ java-pkg_filter-compiler jikes
+
+ # Identify the AWT path
+ # The IBM VMs and the GNU GCC implementations do not store the AWT libraries
+ # in the same location as the rest of the binary VMs.
+ if [[ ! -z "$(java-config --java-version | grep 'IBM')" ]] ; then
+ export AWT_LIB_PATH=$JAVA_HOME/jre/bin
+ elif [[ ! -z "$(java-config --java-version | grep 'GNU libgcj')" ]] ; then
+ export AWT_LIB_PATH=$JAVA_HOME/$(get_libdir)
+ else
+ if [[ $(tc-arch) == 'x86' ]] ; then
+ export AWT_LIB_PATH=$JAVA_HOME/jre/lib/i386
+ elif [[ $(tc-arch) == 'ppc' ]] ; then
+ export AWT_LIB_PATH=$JAVA_HOME/jre/lib/ppc
+ else
+ export AWT_LIB_PATH=$JAVA_HOME/jre/lib/amd64
+ fi
+ fi
+
+ # Fix the GTK+ Library path
+ export GTKLIBS="$(pkg-config --libs-only-L gtk+-2.0 gthread-2.0) \
+ -lgtk-x11-2.0 -lgthread-2.0 -L/usr/$(get_libdir)/X11 -lXtst"
+
+ # Fix the pointer size for AMD64
+ [[ ${ARCH} == 'amd64' ]] && export SWT_PTR_CFLAGS=-DSWT_PTR_SIZE_64
+
+ local platform="linux"
+
+ use elibc_FreeBSD && platform="freebsd"
+
+ local make="emake -f make_${platform}.mak NO_STRIP=y"
+
+ einfo "Building AWT library"
+ ${make} make_awt || die "Failed to build AWT support"
+
+ einfo "Building SWT library"
+ ${make} make_swt || die "Failed to build SWT support"
+
+ einfo "Building JAVA-AT-SPI bridge"
+ ${make} make_atk || die "Failed to build ATK support"
+
+ if use gnome ; then
+ einfo "Building GNOME VFS support"
+ ${make} make_gnome || die "Failed to build GNOME VFS support"
+ fi
+
+ # Wasn't able to succesfully run test with this
+ # http://overlays.gentoo.org/proj/java/browser/testcases/dev-java/swt
+ #use firefox && local gecko="firefox"
+ use seamonkey && local gecko="seamonkey"
+ use xulrunner && local gecko="xulrunner"
+
+ if [[ ${gecko} ]]; then
+ einfo "Building the Mozilla component"
+ #local idir="$(pkg-config ${gecko}-xpcom --variable=includedir)"
+ local inc="$(pkg-config ${gecko}-xpcom --cflags)"
+ GECKO_INCLUDES="${inc}" \
+ GECKO_LIBS="$(pkg-config ${gecko}-xpcom --libs)" \
+ ${make} make_mozilla || die "Failed to build Mozilla support"
+ fi
+
+ if use cairo ; then
+ einfo "Building CAIRO support"
+ ${make} make_cairo || die "Unable to build CAIRO support"
+ fi
+
+ if use opengl ; then
+ einfo "Building OpenGL component"
+ ${make} make_glx || die "Unable to build OpenGL component"
+ fi
+
+ einfo "Building JNI libraries"
+ eant compile
+
+ einfo "Copying missing files"
+ cp -i "${S}/version.txt" "${S}/build/version.txt"
+ cp -i "${S}/src/org/eclipse/swt/internal/SWTMessages.properties" \
+ "${S}/build/org/eclipse/swt/internal/"
+
+ einfo "Packing JNI libraries"
+ eant jar
+}
+
+src_install() {
+ java-pkg_dojar swt.jar
+
+ java-pkg_sointo /usr/$(get_libdir)
+ java-pkg_doso *.so
+
+ dohtml about.html || die
+}
+