summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2012-07-06 10:55:32 +0000
committerRalph Sennhauser <sera@gentoo.org>2012-07-06 10:55:32 +0000
commitf653908812383ceb8cf4cb21ef1221c47c0e8b0f (patch)
tree99d6c317f9dceb3019b719735ebec0ecbf33bdd8 /dev-java/tijmp
parentVersion bump. #421377; Assign Sergey Popov as a maintainer. (diff)
downloadgentoo-2-f653908812383ceb8cf4cb21ef1221c47c0e8b0f.tar.gz
gentoo-2-f653908812383ceb8cf4cb21ef1221c47c0e8b0f.tar.bz2
gentoo-2-f653908812383ceb8cf4cb21ef1221c47c0e8b0f.zip
Respect JAVACFLAGS. Fixes buiding with JAVA_PKG_STRICT. #421697
(Portage version: 2.1.11.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/tijmp')
-rw-r--r--dev-java/tijmp/ChangeLog8
-rw-r--r--dev-java/tijmp/files/tijmp-0.8-respect-javacflags.patch11
-rw-r--r--dev-java/tijmp/tijmp-0.8.ebuild5
3 files changed, 20 insertions, 4 deletions
diff --git a/dev-java/tijmp/ChangeLog b/dev-java/tijmp/ChangeLog
index baa4057c9fce..d08189102a5c 100644
--- a/dev-java/tijmp/ChangeLog
+++ b/dev-java/tijmp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/tijmp
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tijmp/ChangeLog,v 1.4 2010/05/25 21:42:13 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tijmp/ChangeLog,v 1.5 2012/07/06 10:55:32 sera Exp $
+
+ 06 Jul 2012; Ralph Sennhauser <sera@gentoo.org> tijmp-0.8.ebuild,
+ +files/tijmp-0.8-respect-javacflags.patch:
+ Respect JAVACFLAGS. Fixes buiding with JAVA_PKG_STRICT. #421697
25 May 2010; Pacho Ramos <pacho@gentoo.org> tijmp-0.8.ebuild:
stable amd64, bug 318543
diff --git a/dev-java/tijmp/files/tijmp-0.8-respect-javacflags.patch b/dev-java/tijmp/files/tijmp-0.8-respect-javacflags.patch
new file mode 100644
index 000000000000..96902aedf4ec
--- /dev/null
+++ b/dev-java/tijmp/files/tijmp-0.8-respect-javacflags.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -18,7 +18,7 @@
+ java_files := $(foreach dir,$(dirs),$(find_files))
+ class_files := $(patsubst $(jdir)/%.java,%.class,$(java_files))
+
+-JCFLAGS := -source 1.6 -encoding ISO-8859-1 -Xlint:unchecked -deprecation
++JCFLAGS := $(JAVACFLAGS) -encoding ISO-8859-1 -Xlint:unchecked -deprecation
+
+ # standard java compilation..
+ JAVACOMPILE := $(JAVAC) $(JCFLAGS) -sourcepath $(jdir) -d $(top_builddir)
diff --git a/dev-java/tijmp/tijmp-0.8.ebuild b/dev-java/tijmp/tijmp-0.8.ebuild
index d0ff9b4a2510..36a2c57e2b6e 100644
--- a/dev-java/tijmp/tijmp-0.8.ebuild
+++ b/dev-java/tijmp/tijmp-0.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tijmp/tijmp-0.8.ebuild,v 1.5 2010/05/25 21:42:13 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tijmp/tijmp-0.8.ebuild,v 1.6 2012/07/06 10:55:32 sera Exp $
EAPI=2
@@ -21,6 +21,7 @@ DEPEND=">=virtual/jdk-1.6"
java_prepare() {
epatch "${FILESDIR}/${PN}-jni.h.patch"
+ epatch "${FILESDIR}/${P}-respect-javacflags.patch"
eautoreconf
}