summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2011-01-28 14:45:49 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2011-01-28 14:45:49 +0000
commitb21f05d00ee7a40348733f10e1abd295753c59df (patch)
tree1c6850bc357e48c2f6bebebb3c8e964676a33f88 /dev-java
parentdev-java/lucene: version bump (diff)
downloadgentoo-2-b21f05d00ee7a40348733f10e1abd295753c59df.tar.gz
gentoo-2-b21f05d00ee7a40348733f10e1abd295753c59df.tar.bz2
gentoo-2-b21f05d00ee7a40348733f10e1abd295753c59df.zip
dev-java/jdbc-mysql
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jdbc-mysql/ChangeLog10
-rw-r--r--dev-java/jdbc-mysql/files/5.1.14-java6.patch34
-rw-r--r--dev-java/jdbc-mysql/jdbc-mysql-5.1.14.ebuild76
3 files changed, 118 insertions, 2 deletions
diff --git a/dev-java/jdbc-mysql/ChangeLog b/dev-java/jdbc-mysql/ChangeLog
index 6a155f43b8d0..2a79bd55b082 100644
--- a/dev-java/jdbc-mysql/ChangeLog
+++ b/dev-java/jdbc-mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/jdbc-mysql
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-mysql/ChangeLog,v 1.74 2010/10/17 12:21:19 caster Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-mysql/ChangeLog,v 1.75 2011/01/28 14:45:49 fordfrog Exp $
+
+*jdbc-mysql-5.1.14 (28 Jan 2011)
+
+ 28 Jan 2011; Miroslav Šulc <fordfrog@gentoo.org> +files/5.1.14-java6.patch,
+ +jdbc-mysql-5.1.14.ebuild:
+ Version bump
17 Oct 2010; Vlastimil Babka <caster@gentoo.org> -jdbc-mysql-5.1.6.ebuild:
Remove old.
diff --git a/dev-java/jdbc-mysql/files/5.1.14-java6.patch b/dev-java/jdbc-mysql/files/5.1.14-java6.patch
new file mode 100644
index 000000000000..49343706ad80
--- /dev/null
+++ b/dev-java/jdbc-mysql/files/5.1.14-java6.patch
@@ -0,0 +1,34 @@
+--- build.xml.orig 2010-01-20 19:45:30.000000000 +0100
++++ build.xml 2010-02-13 00:34:30.000000000 +0100
+@@ -131,7 +131,7 @@
+ </if>
+ </target>
+
+- <target name="init" depends="-compiler-check, -init-copy, -init-no-crypto">
++ <target name="init" depends="-init-copy, -init-no-crypto">
+ <!-- We need the following for source distributions as there we
+ can't dynamically alter the classpath, and not having this
+ directory present causes the build to fail -->
+@@ -746,7 +746,8 @@
+ <javac sourcepath="" srcdir="${buildDir}/${fullProdName}"
+ destdir="${compiler.output}"
+ deprecation="off"
+- debug="${debug.enable}">
++ debug="${debug.enable}"
++ bootclasspath="${gentoo.bootclasspath}">
+ <include name="**/*.java" />
+ <exclude name="testsuite/**" />
+ <exclude name="com/mysql/jdbc/integration/**" />
+@@ -763,11 +764,7 @@
+ <javac destdir="${compiler.output}"
+ deprecation="off"
+ debug="${debug.enable}"
+- fork="yes"
+- executable="${com.mysql.jdbc.java6.javac}"
+- compiler="modern"
+- sourcepath="" srcdir="${buildDir}/${fullProdName}"
+- bootclasspath="${com.mysql.jdbc.java6.rtjar}">
++ sourcepath="" srcdir="${buildDir}/${fullProdName}">
+ <include name="**/JDBC4*.java" />
+ <include name="com/mysql/jdbc/exceptions/jdbc4/*" />
+
diff --git a/dev-java/jdbc-mysql/jdbc-mysql-5.1.14.ebuild b/dev-java/jdbc-mysql/jdbc-mysql-5.1.14.ebuild
new file mode 100644
index 000000000000..f358da694a79
--- /dev/null
+++ b/dev-java/jdbc-mysql/jdbc-mysql-5.1.14.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-mysql/jdbc-mysql-5.1.14.ebuild,v 1.1 2011/01/28 14:45:49 fordfrog Exp $
+
+EAPI="2"
+
+JAVA_PKG_IUSE="source"
+JAVA_PKG_WANT_BOOTCLASSPATH="1.5"
+WANT_ANT_TASKS="ant-contrib"
+
+inherit eutils java-pkg-2 java-ant-2
+
+MY_PN="mysql-connector-java"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="MySQL JDBC driver"
+HOMEPAGE="http://www.mysql.com/products/connector/j/"
+SRC_URI="mirror://mysql/Downloads/Connector-J/${MY_P}.tar.gz"
+LICENSE="GPL-2-with-MySQL-FLOSS-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="c3p0 log4j"
+COMMON_DEP="
+ log4j? ( dev-java/log4j )
+ c3p0? ( dev-java/c3p0 )
+ dev-java/commons-logging"
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.6
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${MY_P}"
+
+java_prepare() {
+ epatch "${FILESDIR}/5.0.5-remove-jboss-dependency-from-tests.patch"
+ # http://bugs.mysql.com/bug.php?id=28286
+ epatch "${FILESDIR}/5.0.5-dist-target-depends.patch"
+ # use java6 for everything except jdbc3 - #283848
+ epatch "${FILESDIR}/5.1.14-java6.patch"
+
+ rm -v *.jar || die
+
+ # use test && mkdir src/lib-nodist # needed, or ant will fail
+
+ cd src/lib
+ rm -v *.jar || die
+ java-pkg_jar-from commons-logging
+ use log4j && java-pkg_jar-from log4j
+ use c3p0 && java-pkg_jar-from c3p0
+}
+
+JAVA_ANT_IGNORE_SYSTEM_CLASSES="true"
+EANT_BUILD_TARGET="dist"
+
+src_compile() {
+ # cannot use rewrite-bootclasspath because of the jdbc4 part
+ local bcp="$(java-pkg_get-bootclasspath 1.5)"
+ java-pkg-2_src_compile -Dgentoo.bootclasspath="${bcp}"
+}
+
+# Tests need a mysql DB to exist
+RESTRICT="test"
+src_test() {
+ cd src/lib
+ java-pkg_jar-from junit
+ cd "${S}"
+ ANT_TASKS="ant-junit" eant test -Dcom.mysql.jdbc.noCleanBetweenCompiles=true
+}
+
+src_install() {
+ # Skip bytecode check because we want two versions there
+ JAVA_PKG_STRICT= java-pkg_newjar build/${MY_P}-SNAPSHOT/${MY_P}-SNAPSHOT-bin.jar ${PN}.jar
+ dodoc README CHANGES || die
+ dohtml docs/*.html || die
+ use source && java-pkg_dosrc src/com src/org
+}